Ticket #1524 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

unable to uninstall kobodeluxe package through assassin

Reported by: wendy_hung Owned by: tick@…
Priority: normal Milestone: Om2008.8
Component: Installer Version:
Severity: normal Keywords:
Cc: raster@…, will@…, regina_kim@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Kernel : 20080621-asu.stable-uImage.bin
Root file system :20080623-asu.stable-rootfs.jffs2

1) after installing kobodeluxe
2) uninstall through assassin
3) return to home screen
4) kobodeluxe still remains in launcher screen

All uninstalled packages should be removed from launcher

Change History

comment:1 Changed 10 years ago by raster

  • Status changed from new to closed
  • Resolution set to worksforme

I can't reproduce (i'm not using assassin but opkg directly to test - assassin takes a lot more setup), but kobodeluxue icon disappears when uninstalled, and is there when installed. the icon is blank - the .desktop file doesn't provide an icon in a standard xdg search path, but it works... for me - on my desktop and on the freerunner. please re-open if you can still reproduce.

comment:2 Changed 10 years ago by haduong@…

Works for me too, kobodeluxue icon disappears when uninstalled with opkg.
Still:

  • when installed. the icon is blank
  • package do not show up in Assassin before or after installation

comment:3 Changed 10 years ago by raster

blank icons - know about this. problem is... it's hard to solve - at least on the e/illume end. here is what happens:

opkg installs a new .desktop file. the kernel sends a message to e (because it is listening for new files/changes/deleted files) saying a new file appeared. e now opens the file and looks at it. the .desktop file says "use icon X". illume waits 1 second then refreshes its application list widget - the problem is, the .desktop says to use icon X, BUT.. icon X isn't installed yet, because install takes so long. so a .desktop file that triggers the refresh refers to a file that it hasn't installed yet, and it takes so long toinstall that e gets bored of waiting (1 second) and refreshes anyway (there isn't any other mechanism with FDO/XDG etc. to trigger a refresh that i know of, so monitoring files is the way to go).

now the big problem. we can make it 2 seconds, or 3 - then yu will complain that it is slow to refresh/show a new icon and we just ask for more bugs there. also if the package is very big - it may take longer, and so 2 or 3 seconds isn't enough, so we just play a cat and mouse game of the longest package install vs. time to wait. it's not a game you want to play.

the other problem is - e looks for the icon, doesn't find it. this result is cached. searching for icons is very slow and expensive given the FDO standards, so to be sanely efficient you need to cache results. since the search failed - it has to cache that result for sanity. so a necessity of the standard used requires this.

A solution is to make sure packages install icons before they install .desktops - they should install .desktops very much last. this solves all the issues that can turn up. otherwise we either cause performance problems by removing caches, adding special files that you touch in the applications dirs on end of install, have some magic tool to run to send dbus or whatever messages to all apps saying "now i'm finished installing" etc. either way you have to fiddle with packages and how they install stuff to really get this kind of thing fixed... and if you fiddle - the easy solution is simple install .desktop last :)

Note: See TracTickets for help on using tickets.