Ticket #1525 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

Exposure Crashes (or at least its inaccessible)

Reported by: will Owned by: raster@…
Priority: normal Milestone: Om2008.8
Component: E - Illume Version:
Severity: normal Keywords:
Cc: marek@…, testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

This generally happens when there are a LOT of apps running.
This doesn't happen all the time.
Try to launch Exposure and you get a screen that is re-drawing things a thousand times over. See attachment for more details.

Steps:
1) Launch all the applications you can
2) Press Top Bar, launch Exposure
3) Top Bar icons get re-drawn over and over as it returns to its place

Attachments

exposure.jpg (66.7 KB) - added by will 10 years ago.
ghost in splinter (66.5 KB) - added by wendy_hung 9 years ago.
exposure_crash.png (124.2 KB) - added by will 9 years ago.
exposure_crash

Change History

Changed 10 years ago by will

comment:1 Changed 10 years ago by raster

  • Status changed from new to assigned
  • Owner changed from raster@… to marec@…
  • Component changed from E - Illume to Exposure

this is exposure's window hanging around but exposure not flushing its x buffers or running the main loop to handle redraws. (i can see similar things right now in front of me). it's not illume here (never run exposure and everything else behaves fine).

comment:2 Changed 10 years ago by raster

  • Owner changed from marec@… to raster@…
  • Component changed from Exposure to E - Illume

actually no - i found it's a "ghost window" bug. that damn ghost window bug rears its head again, but this time in a nice repeatable way.

comment:3 Changed 10 years ago by marek

What is the "ghost window" bug ? That sounds scary but fits in the world of daemons, zombies, etc. ;-)

Exposure runs the mainloop all the time - should not be an issue.

comment:4 Changed 10 years ago by wendy_hung

  • Cc regina_kim@…, wendy_hung@… added; marek@… removed

comment:5 Changed 10 years ago by wendy_hung

  • Cc marek@… added

comment:6 Changed 10 years ago by raster

  • Status changed from assigned to closed
  • Resolution set to fixed

hmm i haven't seen this for a while. can't reproduce. i'll mark as fixed - re-open if it comes back.

comment:7 Changed 9 years ago by wendy_hung

  • Status changed from closed to reopened
  • Cc testing@… added; regina_kim@…, wendy_hung@… removed
  • Resolution fixed deleted

Test with the image below:

kernel:20080720-asu.stable-uImage.bin
root file system:20080721-asu.stable-rootfs.jffs2

The ghost screen happened again, this time, it bring out device crashed.
Try for many times, can not totally reproduce this, but have similar result.
Sometimes even splinter happened, i wonder it's not a problem in illume.

please see attached photos.

Changed 9 years ago by wendy_hung

Changed 9 years ago by will

exposure_crash

comment:8 Changed 9 years ago by raster

i have yet to reproduce this in any way... so it's hard to do anything until we know just what is up. there was a time long ago when xglamo itself had bugs where it'd just lose the whole plot sometimes in the draw queue and everything that draws in x was screwed...

comment:9 Changed 9 years ago by raster

  • Status changed from reopened to in_testing

comment:10 Changed 9 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

With the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080805-asu.stable-rootfs.jffs2

After the progress wheel is there, I never seen this happen.
I think this fixed.

Note: See TracTickets for help on using tickets.