Ticket #153 (closed defect: wontfix)

Opened 12 years ago

Last modified 12 years ago

Rationale for copying GtkIconView instead of deriving?

Reported by: mickey@… Owned by: mickey@…
Priority: high Milestone:
Component: openmoko-mainmenu Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Can you please elaborate why you couldn't derive a new class from GtkIconView?
but instead copied its source code?

Change History

comment:1 Changed 12 years ago by ken_zhao@…

  • Owner changed from cj_steven@… to sunzhiyong@…

comment:2 Changed 12 years ago by sunzhiyong@…

  • Status changed from new to assigned

comment:3 Changed 12 years ago by sunzhiyong@…

Because we need to use private parameters to draw decorated ring of icon and
layout for the select items.
I can't find the right way to call private parameters from parent Class Object.
And if you have some more better way to so it, please let me know.
Or would you like to provide a new widget as GtkIconView?, which will be used by
openmoko-mainmenu and openmoko-taskmanager.

comment:4 Changed 12 years ago by mickey@…

i'm thinking about that.

comment:5 Changed 12 years ago by laforge@…

  • Status changed from assigned to new
  • Owner changed from sunzhiyong@… to mickey@…

comment:6 Changed 12 years ago by alphaone@…

  • Status changed from new to closed
  • Resolution set to wontfix

The functionality of main menu has gone into openmoko-today2 now where this
problem doesn't exist.

Note: See TracTickets for help on using tickets.