Ticket #1533 (closed defect: fixed)

Opened 6 years ago

Last modified 4 years ago

The keypad shows brackets number in dialer screen and creat new message

Reported by: wendy_hung Owned by: graeme
Priority: highest Milestone:
Component: Distro Version: GTA02v5
Severity: blocker Keywords: keypad
Cc: testing@…, will@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Summary: The keypad shows brackets number in dialer screen

Kernel : 20080621-asu.stable-uImage.bin
Root file system :20080701-asu.stable-rootfs.jffs2

step + current result:
1) go to dialer
2) press number 0~9 on the keypad
3) show up 1~6, 7.8.9.0show up as {[]}

Sometimes it will show up, reboot the phone will back to normal.

please look at the picture attached.

Attachments

Screenshot-1.png (33.0 KB) - added by wendy_hung 6 years ago.
52 CST 2008.log (40.8 KB) - added by ray_chao 6 years ago.

Change History

Changed 6 years ago by wendy_hung

comment:1 Changed 6 years ago by wendy_hung

thanks for claregj
this ticket related to #1539, plug in usb will have this problem.

comment:2 Changed 6 years ago by roh

  • Owner changed from zecke@… to zecke

comment:3 Changed 6 years ago by wendy_hung

  • Cc testing@… added; will@…, regina_kim@… removed
  • Keywords keypad added
  • Summary changed from The keypad shows brackets number in dialer screen to The keypad shows brackets number in dialer screen and creat new message

Sometimes also happen while you plug in charger.

comment:4 Changed 6 years ago by zecke

  • Cc will@… added

Okay, looks like a kernel or X bug to me. Will investigate... this looks like a big blocker?

comment:5 Changed 6 years ago by wendy_hung

  • Priority changed from high to highest
  • Severity changed from critical to blocker

yes you are right, it's a big blocker. changed it!

comment:6 Changed 6 years ago by zecke

from xmodmap -pk

16 0x0037 (7) 0x0026 (ampersand) 0x007b (braceleft)

so for some reason we manage to get into such a shift/modify state. As it seems to be "USB" plugging related (charging), I think it has to do with key events the pcf50633.c is sending us.

comment:7 Changed 6 years ago by kenrestivo

I had this same problem, but it was intermittent. Haven't had it in a while, and I religiously do an opkg update; opkg upgrade every day.

comment:8 Changed 6 years ago by tingo

  • Version set to GTA02v5

I can confirm that this issue is still present in the daily build of:
root@om-gta02:~# cat /etc/angstrom-version
Angstrom P1-Snapshot-20080722
root@om-gta02:~# cat /etc/om-version
Tag Name:
VERSION: 1d2ffa9abf4464c9ae0d31ee1ca697aaaeb7a81c
Branch: org.openmoko.dev
Build Host: buildhost.openmoko.org
Time Stamp: Fri, 11 Jul 2008 01:49:30 +0200
root@om-gta02:~# uname -a
Linux om-gta02 2.6.24 #1 PREEMPT Wed Jul 23 06:34:19 CEST 2008 armv4tl unknown

As has already been reported, it affects both the dialer keypad and the keyboard used elsewhere (contacts app, PIN code dialog), but only if usb is attached.
--
Torfinn

comment:9 Changed 6 years ago by zecke

  • Status changed from new to accepted

comment:10 Changed 6 years ago by zecke

  • Status changed from accepted to in_testing
  • Component changed from Qtopia to System Software

Funny bug. KEY_POWER2 got reported from the kernel. Now the keycode of KEY_POWER2 is 365 but kdrive can only deal with unsigned char. So 365&0xff got reported (or similar) and we managed to hit a mod key or such with that.

So new xglamo was broken as we handle high keys, old kdrive must have been broken because the mod came some how else.

To avoid this issue we will not forward keycodes >= 256 to the kdrive core.

comment:11 Changed 6 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080724-asu.stable-rootfs.jffs2

anyway, it fixed.

comment:12 Changed 6 years ago by ssinger

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry to reopen,

but I'm seeing this issue (again?) with a asu.dev built from sources of 20080802.

cat /etc/angstrom-version

Angstrom P1-Snapshot-20080804
root@om-gta02:/proc#

cat /etc/om-version
Tag Name:
VERSION: a33d11c36e6a16c034254b1b1aa8f836f18ea53c
Branch: org.openmoko.asu.dev
Build Host: t42
Time Stamp: Mon, 04 Aug 2008 00:21:48 -0400

Both kernel and rootfs were flashed.

Also, #1270 seems to describe the same problem with with the matchbox.

comment:13 Changed 6 years ago by zecke

  • Status changed from reopened to closed
  • Resolution set to fixed

Well... asking the usual questions:

  • Which version of Xglamo is installed?
  • Which machine do you use?
  • Which Xserver is running?

comment:14 Changed 6 years ago by zecke

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry, reopening again. I consider this fixed for gta02/Xglamo and would be highly surprised if that is not the case though.

comment:15 Changed 6 years ago by ssinger

I have a gta02v5 (Revision 350)

I was actually using the xserver-kdrive-fbdev (I'm not sure why glamo wasn't installed)

However when I put xserver-kdrive-glamo -
1:1.3.0.0+git0+d1ab8c0ec48821ef866e927c52b47587a0affc56-r6 on

I get the same issue even after a reboot post installing kdrive-glamo (reboot with USB unplugged, plug it in after poweron and the keys screw up)

root@om-gta02:/etc/X11# opkg list_installed|grep kdrive
xserver-kdrive - 1:1.3.0.0-r25 -
xserver-kdrive-common - 0.1-r28 -
xserver-kdrive-fbdev - 1:1.3.0.0-r25 -
xserver-kdrive-glamo -
1:1.3.0.0+git0+d1ab8c0ec48821ef866e927c52b47587a0affc56-r6 -

ps aux |grep xinit

xinit /etc/X11/Xsession -- /usr/bin/Xglamo :0 -pn -dpi 285 -screen 480x640

-hide-cursor -br

comment:16 Changed 6 years ago by zecke

  • Status changed from reopened to closed
  • Resolution set to fixed

Your installed Xglamo version does _not_ contain the fix for the bracket handling. I don't know why this is the case but if you upgrade it it should work for you as well. Closing the bug due this again. Feel free to reopen if the upgrade doesn't fix the bug.

Also I'm interested how you ended up with Xfbdev running and Xglamo not being installed? Which image did you build?

Your glamo version:
commit d1ab8c0ec48821ef866e927c52b47587a0affc56
Author: Holger Hans Peter Freyther <zecke@…>
Date: Wed Jun 25 10:41:29 2008 +0200

[keyboard] Use the proper source for the high keyboard. fix bugs

I saved the input for the high keycodes to high_keys but to generate
the keycode I went back to use b[1] and b[2] and this happened to work
most of the time. Fix the bug and use high_keys.

You want to have at least:
commit aa7488dd64a716e7c3efae672bb74130205b4eb4
Author: Holger Hans Peter Freyther <zecke@…>
Date: Wed Jul 23 20:04:12 2008 +0200

[keyboard] Do not send keycodes >= NR_KEYS to kdrive as they are not handled


NR_KEYS as of linux/keyboard.h is 256. That fits into unsigned char, the
linux_to_x_keymap is of that size, KdEnqueueKeyboardEvent? takes unsigned
char that will happily take up to 256 different values. Now with the linux
input framework we can report high keys. KEY_POWER2 (365) is such a high
keycode, we get this properly reported through extended keycode's but the
rest of kdrive fails to handle this. So these 365 get casted to unsigned
char (365&0xff) and then something will happen...


In the Openmoko case we managed to hit a modifier that changed our
keyboard.


Do not report keys to kdrive that it currently can not properly handle.


(https://docs.openmoko.org/trac/ticket/1533)

comment:17 Changed 6 years ago by ssinger

I built asu.dev from sources with mokomake with what I THOUGHT were up to date from around Aug 2nd. It produced an jffs2 that for gta02 that did not have glamo (The first time I ran mokomake I might have had the gta01 setup, but then switched it). The image name had gta02 in it though.

However many other things from that build seemed suspect (including the old version of glamo). I've since reimaged to images from the buildhost. Sorry to troubled you.

comment:18 Changed 6 years ago by ssinger

Also, the image
openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2
that I downloaded did NOT have xserver-kdrive-glamo on it either. I had to download it manually as well. If glamo is supposed to be part of the default images than maybe you have another problem.

comment:19 Changed 6 years ago by zecke

Could you give me a full URL to that image?

comment:21 Changed 6 years ago by wendy_hung

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Milestone Om2008.8 deleted

reopen it because it happen with base image now.

Update date: 2008.10.08
Installed list: attach

comment:22 Changed 6 years ago by wendy_hung

  • Owner changed from zecke to graeme
  • Status changed from reopened to assigned

Changed 6 years ago by ray_chao

comment:23 Changed 6 years ago by zecke

Xfbdev is running instead of Xglamo and Xfbdev does not have recent changes from xglamo... We use Xglamo again but Xfbdev should be fixed for gta01.

comment:24 Changed 6 years ago by zecke

  • Component changed from System Software to Distro

comment:25 Changed 4 years ago by joerg

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.