Ticket #1542 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

gps does not get fix

Reported by: emdete Owned by: hardware
Priority: high Milestone:
Component: hardware Version:
Severity: blocker Keywords: gps antenna fix internal
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

neo's gps does not get a fix without external antenna. pluging in an external antenna the neo gets a fix quick.

my gta01 had this problem. my prototyp #47 doesn't have it. many mp-gta02 owner report this problem now with their mp-gta02, my mp-gta02 has to be tested.

Attachments

reception.jpg (188.1 KB) - added by BlueStar88 6 years ago.
No fix with this reception

Change History

comment:1 Changed 6 years ago by emdete

i just checked my brand new mp freerunner and got a fix the first time i booted. because i didn't know how long that took i retried it twice and didn't get a fix in 5 and in 20 minutes.

i checked again with the prototype which got a fix in 2-3 min with the same conditions (under a roof windows).

comment:2 Changed 6 years ago by thomasg

I can confirm this.

I'm a lazy person, so I just copy my mail:

I also did some testing with all the pieces of hardware the freerunner has.
The GPS is very disappointing. I could get a fix in about 2 minutes with my
Neo1973 with a cold start.
This works inside my car (maybe a bit slower), at my room's window (bit
slower), and everywhere outside.

I still didn't manage to get a FIX with my Freerunner. I tried it at my
window (nothing at all), in my car (nothing at all), outside my window
(first coordinates after 15 minutes, no FIX at all), and on top of a hill
with sunshine and no clouds (first coordinates after 5 minutes, no FIX at
all).

After that tests I don't think that my Neo will be able to get a FIX ever.
At least it's totally unusable as any kind of GPS- or Navigation-device.
Getting coordinates from my CellID-database is barely less accurate, but it
goes in no time and everywhere.

Btw. - I took a picture of my GPS_antenna, and I just can't imagine, that
this will be able to get a GPS signal without siginficant loss to the
reciever (that has only a sensitivity of -155 dBm in the best case).
http://c.imagehost.org/0230/gps_antenna.jpg

comment:3 Changed 6 years ago by fgau

same here.

i didn't get a fix in 20 minutes on a free area. my gta01 in the other hand got a fix in 2 minutes.
a test with a externel gps antenne is still pending.

comment:4 Changed 6 years ago by HdR

I can confirm this, too.

I didn't get a fix at my window even after 60 minutes of waiting.
In the garden i tried about 30min to get a fix without any success, on the other hand i got a fix after <5min at a second test in the garden, the third test was disappointing again (>20min without a fix)

If I had a fix, it is lost by going into the house, and doesn't come back, if i go outside again (at leat not in the next 5 minutes)

comment:5 follow-up: ↓ 17 Changed 6 years ago by proquar

I have the same problem.

With the internal antenna I can wait hours and get no fix, on places where I usually receive ~8 satellites. Only thing I get is the time after about 30 minutes.

When I connect an external antenna I get a fix in less than 2 minutes, usually in less than 1 minute. I get the time after about 20 seconds.

If I got a fix with an external antenna and switch back to the internal one, it still receives all satellites it has seen before and easily maintains it's fix and even recovers it when I take the Freerunner inside for a short time.

I'm using a MP Freerunner, 900MHz-version, assembly was on 2008-06-18. (maybe it matters?)

comment:6 Changed 6 years ago by edistar

I can confirm this, too.
Only twice did I get a fix - after a ridiculously long time.. 2h and 1h is just much too long. The other times I tried I didn't get any fix at all.
While looking at the signal strength in openmoko-agpsui it seems to me that it is to weak to get a fix mostly(hanging around 155dbm). I tested outside, on a hill, in the fields and in woods. My other gps device gets a fix in <40sec. So it can't be the surroundings.

comment:7 Changed 6 years ago by zeppo

I can confirm also.
If I have perfect condition I'll get a fix and after waiting some time I'll receive enough (>5) satellites. After walking some time it seems to "carry" the fix. But as soon I have to get a new fix I'll have to wait for hours again.
Also in my case other gps device gets a fix in <40 sec.

comment:8 follow-up: ↓ 9 Changed 6 years ago by calestyo

Same here...

comment:9 in reply to: ↑ 8 Changed 6 years ago by goldie

I can confirm too.
No FIX at all. Tried about 5 times for 30min at home, in garden, on the way to work and so on.

comment:10 Changed 6 years ago by maroi

same problem here, no fix after 30 minutes in the garden and also no fix with external antenna.

comment:11 Changed 6 years ago by BlueStar88

After running OM GPS UI 0.20 for several hours (> 6) I still get no fix and no coordinates. The display shows more than 12 satellites at different levels, mostly above the first third part of the scale and there's a 'normal' log message flow. It was running under different conditions, near by the office window, wrist side for a walk and on a chair in the open home garden.
I haven't placed any assist data into it yet, but it *should* work without it.

I have no external antenna for further testings.

Since the GPS-module should work autonomous (besides the os and user space software) it could be a severe hardware or firmware issue.. :-(

Changed 6 years ago by BlueStar88

No fix with this reception

comment:12 Changed 6 years ago by roh

  • Owner changed from hardware@… to hardware

comment:13 Changed 6 years ago by phyce

  • Priority changed from normal to high
  • Keywords gps antenna fix internal added

Same here, having serious doubts about internal antenna as well...I hope there may be a hardware fix about this that can be home-made.

comment:14 Changed 6 years ago by Ainulindale

Never had a fix on my balcony, whereas my own external GPS device works pretty well there.

I had a fix once in a clear open space outside, managed to keep it for 30 meters, sat, walked again, and it lost all the satellites, and it never did come up again. It's unfortunately the only fix I managed to get in 4 days, even 8 hours outside on a table didn't give any results (whereas the other GPS had a fix in 1 minute).

What is weird is that sometimes I don't have the NMEA unknown messages on the log, and I have to reboot the freerunner in order to be able to have them back.

comment:15 Changed 6 years ago by yarikoptic

I hope you are aware of the recent thread
http://lists.openmoko.org/pipermail/community/2008-July/021774.html
which discovers the mystery of GPS problem -- SD card

comment:16 Changed 6 years ago by emdete

how about this one: http://lists.openmoko.org/pipermail/hardware/2008-April/000055.html (just to get things together).

here is the outcome of my testing:

my gta01 behaves just as describes in the mail from the previous posting: no fix with sd inserted, immediate fix without sd.

my gta02 prototype #47 works fine with and without sd while the extern antenna speeds up alot.

my gta02 mp does not work at all, with or without sd i dont get a fix. the antenna (see http://pyneo.org/gps-nofix/ first three pictures) seems to have issues, but it works fine in another neo.

comment:17 in reply to: ↑ 5 Changed 6 years ago by queen6

Replying to proquar:

I have the same problem.

With the internal antenna I can wait hours and get no fix, on places where I usually receive ~8 satellites. Only thing I get is the time after about 30 minutes.

When I connect an external antenna I get a fix in less than 2 minutes, usually in less than 1 minute. I get the time after about 20 seconds.

If I got a fix with an external antenna and switch back to the internal one, it still receives all satellites it has seen before and easily maintains it's fix and even recovers it when I take the Freerunner inside for a short time.

I'm using a MP Freerunner, 900MHz-version, assembly was on 2008-06-18. (maybe it matters?)

I've got my Freerunner 2 days ago. So far I've got the same problem (although I didn't have a chance to test with external antenna).

Tried with and without SD card, standard and Andy's kernel (patched for GPS problems).

MP Freerunner 900MHz, 2008-06-17

comment:18 Changed 6 years ago by emdete

after sbeh from #neo1973-germany found out, that gps works when the sd card is not inserted, a fix for that problem can be found here: http://www.openmoko.org/wiki/Image:Gta02_gps_10pf_rework_sop.pdf

there are still thinks to clarify: does that fix work in a gta01 also? are there more problems than that?

comment:19 Changed 6 years ago by emdete

again to keep things together:

there is a software workaround in the linux kernel to reduce interference on sd card access. mwester provides the image for download here: http://moko.mwester.net/dl.html#kernels

comment:20 Changed 6 years ago by emdete

more news:

today i got a replacement antenne from TriSoft? (thanks again!) to fix my broken antenna in my MP GTA02.

instead of doing that i fixed my GTA01 with the capacitor and gave it the new antenna.

i immediatly got a fix and the neo saw 11 sat sitting on my desktop (under a roof-window). remember: this gta01 worked without sd but a good antenna, it did not with sd an the same antenna.

so for me seems to be clear: the capacitor-fix works for the gta01 too.

comment:21 Changed 6 years ago by andy

Just to be clear, if you boot with no SD card in and recent kernel, you should have no signals on SD_CLK the whole session, so there is nothing for that capacitor to suppress. Even with an SD Card in with recent kernel, it again should have no signal unless you perform an actual SD Card access. So I wonder if we changed a few things at the same time here?

comment:22 Changed 6 years ago by andy

Dah the coffee just sank in, this will be on s3c24xx SDIO port for GTA01, I don't know its behaviour for SD_CLK issue at all. But, if it does run SD_CLK all the time, it should be possible to turn it off unless we actually perform a transfer as we did on the Glamo driver.

comment:23 Changed 6 years ago by candrews

I am using OM2008.8 on my MP FreeRunner?, and I never get any GPS results in the OM GPS UI or TangoGPS. cat'ing /dev/ttySAC1 shows the device never gets a fix (and yes, the GPS is on). I've used it inside and outside where other devices have no problems. And there is no SD card in the phone. What else can I tell you to help the troubleshooting effort?

comment:24 Changed 6 years ago by emdete

candrews, have you testet an external antenne? this works with all my neos very well (fix in less than a minute).

have you disassembled the neo? did you take a look at the antenna & cable? is it build well? soldering and crimp of the connector and the cable itself with no squashing...? all this may be cause of bad signals too.

also try the ublox binary mode which shows you much better how many sats are in sight which what signals. there is a gps-daemon around capable of logging data from that mode. it's part of fso.

comment:25 Changed 6 years ago by zecke

Can we resolve this?

comment:26 Changed 6 years ago by emdete

i dont know if you can resolve it, but it probably is not yet solved at all. the gta01 still has the same issue with no kernel fix in place as i know and recent tests show another problematic behavior:

if i use gsm heavily i don't get a fix also. so if i download maps via gprs or take a phonecall during the initial fix there is no gps reception at all. i don't want to start a new bugreport for this because i think hf testing of the hw is a general issue with the neo.

i would prefere om does its homework and provides a testsuite for hw funtionality tests under standard load conditions like gps, gsm, bt, wlan switched on and really used...

last step would be to inform the community with the recommended fixes.

comment:27 Changed 6 years ago by mwester

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed

The software fix for this problem on the GTA01 has been committed some time ago, and should be present in all current distro's GTA01 kernels. The fix is a port of the GTA02 solution, with the same behavior(notably, that the SD clock is slowed down significantly whenever the GPS is powered up, and the SD clock is stopped entirely except during actual reading or writing of SD card data). Significant improvements in time-to-first-fix are evident, including the ability to obtain fixes in locations where this was previously not possible.

Marking this ticket as "fixed" -- re-open this if the problem persists (after verifying that the GTA01 patch is present in the kernel, of course).

comment:28 Changed 5 years ago by bascorp

Note: See TracTickets for help on using tickets.