Ticket #1574 (closed enhancement: duplicate)

Opened 9 years ago

Last modified 8 years ago

create Qtopia Email package to be installed through Assassin

Reported by: will Owned by: julian_chu
Priority: low Milestone: Om2008.8
Component: Distro Version:
Severity: normal Keywords: must have
Cc: tick@…, testing@…, julian_chu@…, zecke@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Expected Value:

1) launch assassin
2) open 'Communication' category
3) open 'Qtopia Email'
4) press install
5) go to home, launch messages
6) messages should now include email extension with appropriate settings menus included

Change History

comment:1 Changed 9 years ago by will

  • Component changed from unknown to opkg

comment:2 Changed 9 years ago by roh

  • Owner changed from zecke@… to zecke

comment:3 Changed 9 years ago by will

  • Cc julian_chu@… added
  • Keywords must have added

tick, maybe julian can take care of this?

comment:4 Changed 9 years ago by julian_chu

  • Owner changed from zecke to julian_chu
  • Status changed from new to accepted

comment:5 Changed 9 years ago by julian_chu

  • Cc zecke@… added

I can add PKG_TAGS, but I don't which packages should be added. need input from :Z:

comment:6 Changed 9 years ago by julian_chu

  • Status changed from accepted to in_testing

I had add tag to qtopia-phone-x11-qtmail in ASU-dev branch.

comment:7 Changed 9 years ago by zecke

Julian your changes are not complete. IIRC installing of some other plugins are missing.

comment:8 Changed 9 years ago by wendy_hung

  • Status changed from in_testing to assigned

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080725-asu.stable-rootfs.jffs2

it's in the "UNINSTALL"...
should be in the install section, please make sure add a tag for qt-mail package.

comment:9 Changed 9 years ago by tick

  • Status changed from assigned to in_testing

It's in Installed section now.
Please test.

comment:10 Changed 9 years ago by wendy_hung

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080805-asu.stable-rootfs.jffs2

The problem is, the email package is already installed by default. So email shows up in the UNINSTALL section. The bigger problem is, uninstalling the email package uninstalls the WHOLE qt-messages application.

Expected Value:

Either we create a way that the email package can be installed/uninstalled like a plug-in, without deleting the qt-messages app.

Or we remove the email package all together, both from the repository and the qt-messages app.

comment:11 Changed 9 years ago by wendy_hung

  • Status changed from in_testing to assigned

comment:12 Changed 8 years ago by zecke

  • Component changed from opkg to Distro

comment:13 Changed 8 years ago by john_lee

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to duplicate

this is not a valid ticket. the real issue is to divide email and sms to different packages. closed as a duplicate of #1573.

Note: See TracTickets for help on using tickets.