Ticket #1586 (closed defect: fixed)

Opened 10 years ago

Last modified 15 months ago

Antenna show with signal, but can't make any phone call or receive call (no alert message)

Reported by: wendy_hung Owned by: zecke
Priority: highest Milestone: Om2008.9
Component: Qtopia Version:
Severity: blocker Keywords: must have
Cc: testing@…, raster@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Kernel : 20080705-asu.stable-uImage.bin
Root file system :20080708-asu.stable-rootfs.jffs2

Summary:Antenna show with signal, but can't make any phone call or receive calls (no alert message)

Current result:

1) device is open, check the antenna icon is with the signal
2) make a phone call to neo
3) you can hear the answer tone, but the device won't show any response

4) try to make phone call from NEO
5) the screen show up out going call active but can't hear any answer tone, and there's no alert message show up

Expected:
no idea what cause this, but it happened quite often.
The dialer function should works once it have signal; the antenna icon should show up the signal correctly

Change History

comment:1 Changed 10 years ago by will

raster, do you know anything about this? I get it quite often too.
Icon shows I have signal strength, but when i try to make a call, it won't go through.

comment:2 Changed 10 years ago by raster

as best i know this is internal to qpe - the signal strength gadget displays simply what qpe tells it to (0-100) and if its -1 it displays a "no network" image (a small circle with a diagonal line through it). this info is recieved via dbus signals and as best i can tell, most of the time, seems to say something sensible (max signal or just below max signal) for me and lower if i am deep indoors somewhere.

holger? does this seem right?

comment:3 Changed 10 years ago by roh

  • Owner changed from zecke@… to zecke

comment:4 Changed 10 years ago by will

  • Keywords must have added

comment:5 Changed 10 years ago by wendy_hung

  • Status changed from new to assigned

Tested with the image below:

kernel:20080807-asu.stable-uImage.bin
root file system:20080807-asu.stable-rootfs.jffs2

Now the issue is not that bad,
The antenna did not show up "No signal" icon, if can not make a phone call, it will show up alert message "No phone call is possible. Reasons GSM Phone is not registered. No network."

Will keep looking at this bug.

comment:6 Changed 10 years ago by regina_kim

  • Milestone changed from Om2008.8 to Om2008.9

comment:7 Changed 10 years ago by erin_yueh

since we can display the correct status alert message, could you please verify this bug with 3 latest daily build images? if it works well, then please mark it as fixed and also close this bug. Thanks!

comment:8 Changed 10 years ago by erin_yueh

  • Status changed from assigned to in_testing

comment:9 Changed 10 years ago by regina_kim

  • Status changed from in_testing to closed
  • Resolution set to fixed

kernel : 20080903
rootfs : 20080904

now, it seems very fine. so i will close this ticket.

comment:10 Changed 15 months ago by HaroNusy

Cialis Heure http://cialtobuy.com - viagra cialis Precio Cialis 20 Mg
Cialis Esperienza Personale
Cialis Viagra Prezzo <a href=http://cialtobuy.com >online pharmacy</a> Cheapest Tadalafil

Note: See TracTickets for help on using tickets.