Ticket #1595 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

GTA02 - uboot 1.3.2rc2 terminal s3ser0 doesn't work apparently

Reported by: frances.albanese Owned by: laforge
Priority: normal Milestone:
Component: kernel Version: GTA02v6
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I was hanging around with uboot on a Freerunner when I realized that GSM passthorugh doesn't work anymore as it did in GTA01Bv4: the console doesn't show the input nor a response from the modem; it is only possible to escape (~) after a few trials.

Attachments

uboot-gta02-terminal.patch (2.2 KB) - added by laforge 6 years ago.
patch to fix 'terminal s3ser0' on GTA02

Change History

comment:1 Changed 6 years ago by roh

  • Owner changed from openmoko-kernel@… to openmoko-kernel

comment:2 Changed 6 years ago by laforge

  • Status changed from new to assigned
  • Owner changed from openmoko-kernel to laforge

the problem consists of two parts

1) the hardware flow control is not handled in software since neither CONFIG_HWFLOW are set,

nor is the autobaud-enable-check for a GTA02 board working (explicitly checking for GTA02v1 and
GTA02v2, but not any later versions

2) the serial init function is not called, since it is only called for the console device.

the serial_reinit_all() call in common/cmd_terminal.c was commented out

I'm working on a solution

Changed 6 years ago by laforge

patch to fix 'terminal s3ser0' on GTA02

comment:3 Changed 6 years ago by laforge

the attached fix fixes the problem. please apply this to the u-boot stable (and other) branches.

I will work with u-boot mainline to get a similar fix accepted (since cmd_terminal.c is in mainline).

comment:4 Changed 6 years ago by laforge

  • Status changed from assigned to closed
  • Resolution set to fixed

merged to the stable branch of u-boot.git

Note: See TracTickets for help on using tickets.