Ticket #1609 (closed defect: community)

Opened 9 years ago

Last modified 9 years ago

Default multitap keyboard missing essential linux keys needed for terminal

Reported by: kenrestivo Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version: 2007.2
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The default /etc/multitap-pad/im-multipress.conf renders the terminal useless because it lacks any way to enter the "/", "|", Control, ESC, and Alt keys.

It's easy to add them by editing the conf file from a USB-connected PC, but it's becoming an FAQ that could be avoided by including those keys.

Change History

comment:1 Changed 9 years ago by tick

It looks like a issues of Freerunner?

The keyboard in ASU will have no this issue.

comment:2 Changed 9 years ago by tick

  • Owner changed from tick to openmoko-devel
  • Version set to 2007.2
  • Component changed from Assassin to unknown

comment:3 Changed 9 years ago by kenrestivo

There are two issues here actually:

1) The keyboard that ships with the standard FSO image needs to have its standard numeric /etc/multitap-pad/im-multipress.conf adjusted to add the "/", "|", Ctrl, and ESC keys added.

2) The keyboard in ASU is even less useful. It doesn't even have numbers! And there's no way to backspace if you make a mistake.

If this should be two separate bug reports (one easy fix against FSO, one probably much harder problem in ASU) then I'd be glad to do that.

comment:4 Changed 9 years ago by raster

asu keyboard (btw - not my design - taken from qtopia's predictive keyboard).

  1. slide finger RIGHT for space/next word
  2. slide ginger DOWN for enter/return (and next word)
  3. slide finger LEFT for backspace
  4. slide finger UP to change keyboard layout and get.. numbers, symbols etc. etc. :)
  5. key layout is a text config file. you can make your own!

so i'd ignore the asu keyboard feedback here. it's just bad usability - it does actually work!

comment:5 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.