Ticket #1612 (closed defect: community)

Opened 9 years ago

Last modified 8 years ago

openmoko-dates doesn't update calendar entry time

Reported by: brianwc Owned by: openmoko-devel
Priority: normal Milestone: Om2007.2
Component: unknown Version:
Severity: major Keywords: dates calendar
Cc: brianwc@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I'm using FreeRunner?, flashed to latest recommended 2007.2 kernel and rootfs. I am currently running the FreeRunner? without a SD card.

I installed openmoko-dates2 and tried to enter a calendar entry. Besides finding the date/time up/down buttons very unintuitive on first use, once I understood how to enter dates and times I finally got an entry where the start time was off by one hour from what I intended. So, I went back in to edit it, fixed the start time, went back to the "Week starting..." view and saw that the start time was still not updated. I went back and edited the start time two additional times, each time with the same result: it will not update the start time.

I also added a second entry, then tried to go back and edit its start time and it also will not update. This makes the calendar completely unusable.

Also, in this process it was particularly frustrating that the dates program assumes that an event must last a specified duration and ALSO updates the end time when I just wanted to edit the start time. That is, if an entry was 10am-11am and I want to change it to 9:45am-11am, I have to make two changes, fighting with the software as I go, because when the start time is changed to 9:45, the end time also changes to 10:45, and so I have to go change the end time back to 11, and then in the end, it doesn't even save any of these changes.

Change History

comment:1 Changed 9 years ago by brianwc

  • Cc brianwc@… added

comment:2 Changed 9 years ago by cavaughan

Like Brian, I've noticed a strange issue with the calendar. I created one event that
happens yearly. So there is no time associated. It was saved fine.
Then I created an event that is to start at 14:00. After creating it, but
after closing out of it, it was gone. So I created the same event again,
but left it at it's default time of 09:00. OK, it was there. So then I
changed the time to 14:00 and closed out it. It was still set at 09:00.

NB. If it matter I am using the SD card.

comment:3 Changed 9 years ago by fwendt

@Brian: Regarding your last also (meeting at 10-11, change start to 9:45 and end time is automatically set to 10:45), this is how Evolution, Outlook and my SonyEricsson? M600 behaves as well as most other calendar applications. Perhaps this is what most people expect too? Rescheduling happens quite a lot, but changing both start and end time is not as common in my experience.

comment:4 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.