Ticket #1619 (closed defect: fixed)

Opened 11 years ago

Last modified 17 months ago

[Installer]progress bar just stop and does not show Failed Alert messages if remove usbcable during downloading

Reported by: regina_kim Owned by: tick@…
Priority: normal Milestone: Om2008.9
Component: Installer Version:
Severity: normal Keywords:
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 20080705-asu.stable-uImage.bin
rootfs : 200807014-asu.stable-rootfs.jffs2

summary : progress bar just stop and does not show Failed Alert messages if remove usbcable during downloading(screen just show like picture and can not use other function.refer picture)

step :

  1. connect WIFI by usb cable
  2. enter assassin
  3. select item and install
  4. during installing remove cable

current result :it does not show Alert message and can not use other function.

expected result : it has to show error Alert message

Attachments

Screenshot-5.png (68.1 KB) - added by regina_kim 11 years ago.

Change History

Changed 11 years ago by regina_kim

comment:1 Changed 11 years ago by regina_kim

  • Owner changed from zecke@… to tick
  • Status changed from new to assigned

comment:2 Changed 11 years ago by will

  • Severity changed from major to normal

Tick,
I'm not sure if this is major, since we want to use wifi anyways.
But please take a look when you have time, maybe after the asu launch.

comment:3 Changed 11 years ago by tick

  • Status changed from assigned to accepted

I think if the package is large and package download failed.
The error message will shows up. after timeout. ~_~

But if the package had been download before you unplug the cable,
packagekit will finishes it's job well. (without warning)

I will test it later.

comment:4 Changed 11 years ago by will

thanks tick.
let us know if you have any updates :)

comment:5 follow-up: ↓ 6 Changed 11 years ago by tick

In my own testing, opkg will try very hard to download the package unless. Even I plug and unplug the usb cable for several times (reconstruct the internet settings) opkg will retry and continuing it's process. Finishes it job.

But if I remove the network and never recover it (longer than 10 minutes) It still try to connect, but not working anymore.

Some of the packages will takes a long time to get update, so the timeout cannot be too short.

PLEASE DO NOT INSTALL/UPDATE when the network is TOO BAD. (It can recover from some disconnection, but cannot survive for too bad network condition)

I will add the timeout scheme for that, but it will be very long. (We indeed may have very large packages)

This happens in VERY BAD NETWORK condition.

Idea:

  1. Add a Cancel Button after long wait?
  2. Just let user kill assassin?
  3. Let user wait a long time, and get a Error message? <-- Current I will do

comment:6 in reply to: ↑ 5 Changed 11 years ago by will

Replying to tick:

Idea:

  1. Add a Cancel Button after long wait?
  2. Just let user kill assassin?
  3. Let user wait a long time, and get a Error message? <-- Current I will do

Good. Wait until the connection failure is confirmed, then send an alert message 'ERROR: Package download failed'
You should already have that alert somewhere.
You say let user wait a long time.. how long? and what are they waiting for? Is Installer asking for a connection the whole time?

comment:7 Changed 11 years ago by tick

  • Status changed from accepted to in_testing

because of we may have packages more than 50MB the timeout has to be set more than 15 mins or it may be unable to install large packages.

bye the way, the progressbar will disappear after timeout. after Assassin svn 223

comment:8 Changed 11 years ago by regina_kim

hey tick how long should i wait for timeout?

comment:9 Changed 11 years ago by regina_kim

it takes more than 5 min

comment:10 Changed 11 years ago by regina_kim

  • Status changed from in_testing to assigned
  • Owner changed from tick to tick@…

why i put this status to major because i could not use any function of assasin after remove the usb cable. but now is fine.
today i tested with below image again.
i can not see any Alert message or timeout.
but i tried remove Assain app by illume bar then launch again takes around more than 30 sec.

kernel : 20080723-asu.stable-uImage.bin
rootfs : 20080805-asu.stable-rootfs.jffs2

comment:11 Changed 10 years ago by regina_kim

  • Summary changed from progress bar just stop and does not show Failed Alert messages if remove usbcable during downloading to [Installer]progress bar just stop and does not show Failed Alert messages if remove usbcable during downloading
  • Milestone changed from Om2008.8 to Om2008.9

comment:12 Changed 10 years ago by tick

  • Status changed from assigned to in_testing

Works for me, and had shown to you.
It will takes more than 15 mins.
I will switch this to in_testing agagin

comment:13 Changed 10 years ago by regina_kim

  • Status changed from in_testing to closed
  • Resolution set to fixed

thanks tick.

i have created new ticket #1943

comment:14 Changed 17 months ago by JeffRipt

Generique Levitra 22 http://cialtobuy.com - cialis Il Cialis Si Vende In Farmacia
buy accutane no rx buy accutane in the uk
Cytotec In South Africa <a href=http://cialtobuy.com >buy cialis</a> Acheter Viagra Canada

Note: See TracTickets for help on using tickets.