Ticket #1627 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

[Dialer] The bottom bar menu show "Mute" when incoming a call even setting slient or vibrate only

Reported by: regina_kim Owned by: zecke
Priority: normal Milestone: Om2008.9
Component: Qtopia Version:
Severity: major Keywords: must have
Cc: testing@…, erin_yueh@…, Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 200807017-asu.stable-uImage.bin
rootfs : 200807017-asu.stable-rootfs.jffs2

summary :The bottom bar menu "Mute" when incoming a call even setting slient or vibrate only

step :

  1. go to exposure
  2. select profile
  3. set Silent or vibrate Only
  4. incoming a call -> check the bottom bar menu

current result : it show mute

expected result :it should show send busy

Change History

comment:1 Changed 11 years ago by will

  • Keywords must have added

i guess we should get our 4 profiles working first.
Then see if this is still the case.

comment:2 Changed 11 years ago by roh

  • Owner changed from zecke@… to zecke

comment:3 Changed 11 years ago by wendy_hung

  • Priority changed from normal to high
  • Severity changed from normal to major

comment:4 Changed 11 years ago by wendy_hung

Tested with the image below:

kernel:20080807-asu.stable-uImage.bin
root file system:20080807-asu.stable-rootfs.jffs2

Those 4 profiles works well now, but in the silence mode down of the screen's right conner there still have a "Mute" icon. I think it's quite unnecessary to have it here.

comment:5 Changed 10 years ago by regina_kim

  • Milestone changed from Om2008.8 to Om2008.9

comment:6 Changed 10 years ago by erin_yueh

i think the current dialer UI design is correct. If we set the profile as 'Silent' or 'Vibrate' only, it means 'Mute'. Then that is why we display 'Mute' to inform user the current status when we receive incoming calls!

comment:7 Changed 10 years ago by erin_yueh

  • Cc erin_yueh@…, will@… added
  • Status changed from new to in_testing

i think you misunderstand its meaning.

if the profile is 'Vibrate' or 'Silent', when you receive incoming calls,
the bottom bar menu shows 'Mute', it means the current ring tone status is mute. if you click 'Mute', then it turns to 'Send busy', if you click it, it will reject this phone call.

if the profile is 'Ring', when you receive incoming calls,
the bottom bar menu shows 'Mute', it means you can 'mute' this ring tone. if you click 'Mute', then it turns to 'Send busy', if you click it, it will reject this phone call.

comment:8 Changed 10 years ago by wendy_hung

  • Cc will@… removed
  • Priority changed from high to normal
  • Status changed from in_testing to assigned

No, i think the phone's behaver it's not correct. We can put this with lower priority but it is a problem.

I think what you mean is no matter what status it will show up "mute" right? Does that make any sense?
When your phone have incoming call but without ring tone, you check the incoming call screen it have a "Mute" at the conner but you remember you turn the phone with Ring only status, what will you do ?

Try to set your own phone as silence, see what it behave.

tested with image:
kernel:20080826-asu.stable-uImage.bin
root file system:20080902-asu.stable-rootfs.jffs2
Still act the same.
Remove will@… coz he's already in testing@… list

comment:9 Changed 10 years ago by erin_yueh

let Will decide it! I've discussed it with him yesterday and he can understand this behavior. For me, I don't think we need to modify this UI design, coz it makes sense. But, if Will insists to modify this current qtopia design, we can change it later. It's not a bug, please file a new ticket and mark it as a new feature. Also, lower this priority! Thanks!

comment:10 Changed 10 years ago by will

  • Status changed from assigned to closed
  • Resolution set to worksforme

No, we don't modify this.
'Mute' is used as differently in different phones, the way it is used in Qtopia is nothing we should change.
Regina I will show you how this works later.

comment:11 Changed 10 years ago by zecke

  • Status changed from closed to reopened
  • Resolution worksforme deleted

Let me reopen it. Pressing "Mute" will always attempt to mute the ring tone and if it is already silent there is no need to mute.

Charlie showed interest in doing something about it so I would say let him go ahead with that.

comment:12 Changed 10 years ago by zecke

Code hints:

src/server/phone/callscreen/semithemed/callscreen.cpp contains the "Mute" QAction. It is called m_actionMute. With m_actionMute->setVisible you can control if the action should be visible.

In CallScreen::stateChanged the action will be made visible. You should use the QPhoneProfileManager (src/libraries/qtopia/qphoneprofile.h) to get the current profile and decide if it already silent. If it is silent and you have an incoming call do not show the action, maybe even take a look at CallScreen::muteRingSelected and decide if you should update the SoftKey?.

comment:13 Changed 10 years ago by will

FYI, we tested a GTA01 running Qtopia and the behavior there was exactly the same. Even in Silent mode, with vibration off, the mute button was still there.

comment:14 Changed 10 years ago by charlie

Thanks for the hint Holger.
I just had a look, ehehe in fact it is not that simple : the m_actionMute only corresponds to the entry in the menu you get when you click the option button. So where does the 'mute' button comes from ? Well, it is simply the back button with the label set to 'Mute' :

QSoftMenuBar::setLabel(m_listView, Qt::Key_Back, ":icon/mute", tr("Mute"));

Later on, when we press the mute button, the label is changed to "Reject". How do we know we press mute or reject then ? We check if the m_actionMute is visible.

I think the easier way to solve this without redoing everything is to automatically trigger the mute event if the current profile volume is 0. It is a little hack-ish, but should work.

I will try that...

comment:15 Changed 10 years ago by charlie

  • Status changed from reopened to in_testing

comment:16 Changed 10 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

kernel:20080903-asu.stable-uImage.bin
root file system:20080915-asu.stable-rootfs.jffs2

tested with the image, this bug got fixed!
Thanks for charlie's help.

Note: See TracTickets for help on using tickets.