Ticket #1634 (closed defect: fixed)

Opened 9 years ago

Last modified 8 years ago

[Assassin]"Update"&"Uninstall" button didn't lock up while installing

Reported by: wendy_hung Owned by: tick@…
Priority: high Milestone: Om2008.10
Component: Installer Version:
Severity: critical Keywords: must have
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

kernel:20080717-asu.stable-uImage.bin
root file system:20080717-asu.stable-rootfs.jffs2

Summary:"Update"&"Uninstall" buttom didn't lock up while installing

steps + current result:
1)launch assassin with network
2)choose any package to install
3)while installing touch other buttons (Update/Uninstall?)
4)can touch other buttons
5)same as updating/uninstalling

Expected:
while installing/updating/uninstalling other button should be locked

Change History

comment:1 Changed 9 years ago by tick

  • Status changed from new to in_testing

I cannot reproduce this.
But I saw Wendy showed this to me.
Adding two extra lock for this on assassin svn 198, it should good enough to avoid this.

comment:2 Changed 9 years ago by regina_kim

kernel : 200807017-asu.stable-uImage.bin
rootfs : 200807017-asu.stable-rootfs.jffs2

today's image still does not including.
will test again with monday image.

comment:3 Changed 9 years ago by regina_kim

  • Keywords must have added
  • Owner changed from tick to tick@…
  • Status changed from in_testing to assigned

comment:4 Changed 9 years ago by regina_kim

  • Priority changed from normal to high

comment:5 Changed 9 years ago by tick

  • Status changed from assigned to in_testing

comment:6 Changed 9 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

Tested with the image below:

kernel:20080807-asu.stable-uImage.bin
root file system:20080807-asu.stable-rootfs.jffs2

It's locked now. thanks!!

comment:7 Changed 9 years ago by wendy_hung

  • Status changed from closed to reopened
  • Resolution fixed deleted

tested with the image:
kernel:20080826-asu.stable-uImage.bin
root file system:20080901-asu.stable-rootfs.jffs2

it's unlock again now :(
please take a look of this, thanks!!

comment:8 Changed 9 years ago by regina_kim

  • Milestone changed from Om2008.8 to Om2008.10

comment:9 Changed 8 years ago by tick

  • Status changed from reopened to in_testing

comment:10 Changed 8 years ago by wendy_hung

  • Status changed from in_testing to closed
  • HasPatchForReview unset
  • Resolution set to fixed

[testing image]
test date:2008.11.05
update date:2008.11.05

It was fixed.

Note: See TracTickets for help on using tickets.