Ticket #1636 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[Dialer] The callscreen should be hidden before displaying the "Missed Call" message box

Reported by: regina_kim Owned by: zecke
Priority: low Milestone: Om2008.8
Component: Qtopia Version:
Severity: minor Keywords:
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 200807017-asu.stable-uImage.bin
rootfs : 200807017-asu.stable-rootfs.jffs2

summary : it shows "missed call" Alert message screen first than"disconnected" screen if press send busy button when incoming a call

step :

  1. incoming a call
  2. press "Send busy" -> "Missed call" Alert message show
  3. press No -> it shows "disconnected" screen short second then go to home screen

reproducible: 2~3 out of 10 tries.

current result : like step 3.

expected result : the screen has to show "disconnected" then has to show missed call Alert message

Change History

comment:1 Changed 11 years ago by zecke

why? Do you ask for that if you press the "No" you don't want to see the callscreen anymore?

comment:2 Changed 11 years ago by regina_kim

this issue is not always happens.

just reproducible 2~3 out of 10 tries.

and i think it has to show "disconnected" screen fitst than "missed call"

or does not need to show "disconnected" screen

because if press "send busy" means already reject the

call and not connected call.

so just has to show Missed call Alert message.

comment:3 Changed 11 years ago by zecke

What are you talking about?

  1. You see the callscreen.
  2. A incoming call is presented to you (Incoming as status)
  3. You press busy
  4. You see the "missed call" dialog and press no

5.a. You get back to the callscreen and see the disconnected call
5.b. You don't get back to the callscreen as enough time passed to hide it?

is that what you try to say?

comment:4 Changed 11 years ago by regina_kim

My English is too bad. just come to me then let me show

comment:5 Changed 11 years ago by zecke

your english is fine. but you can show that to me later.

comment:6 Changed 11 years ago by regina_kim

i just discover

5.b. You don't get back to the callscreen as enough time passed to hide it?

comment:7 Changed 11 years ago by zecke

  • Summary changed from [Dialer] it shows "missed call" Alert message screen first than"disconnected" screen if press send busy button when incoming a call to [Dialer] The callscreen should be hidden before displaying the "Missed Call" message box

comment:8 Changed 11 years ago by roh

  • Owner changed from zecke@… to zecke

comment:9 Changed 11 years ago by zecke

  • Status changed from new to in_testing

Done. Please test tomorrow's image.

comment:10 Changed 11 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080723-asu.stable-rootfs.jffs2

Done, directly show up Missed call alert message box
Thanks!

Note: See TracTickets for help on using tickets.