Ticket #1650 (closed defect: fixed)

Opened 11 years ago

Last modified 22 months ago

Mokomakefile: gtk+/gtk+-fastscaling conflicts

Reported by: gcasse Owned by: julian_chu
Priority: high Milestone: Om2007.2
Component: Distro Version: GTA02v6
Severity: major Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Could you please let the recipes of the gtk+ applications depend on gtk+-fastscaling instead?

Current issue:
I try to build the navit ipk, available in openembedded.
The recipe depends on gtk+ .

The opkg install fails, because it tries to install gtk+ whereas gtk+-fastscaling is already installed. The whole error messages are copied below.
A workaround is to use -nodeps:
opkg install -nodeps navit_0.0.4-r0_armv4t.ipk

The solution would be to add in a conf file:
PREFERRED_PROVIDER_gtk+ = "gtk+-fastscaling"

I added it manually in openmoko.conf without success, installing the new package return the same errors (it seems that the previous erroneous package depending on gtk+ was already stored in the opk cache, and opkg remove did not help to clean).

Thank you!

# opkg install navit_0.0.4-r0_armv4t.ipk
Multiple packages (navit and navit) providing same name marked HOLD or PREFER. Using latest.
Installing navit (0.0.4-r0) to root...
navit: unsatisfied recommendation for flite
Installing gtk+ (2.12.11-r2) to root...
Downloading http://buildhost.openmoko.org/daily-feed/armv4t/gtk+_2.12.11-r2_armv4t.ipk
Collected errors:

  • Package gtk+ wants to install file /usr/lib/libgtk-x11-2.0.so.0

But that file is already provided by package * gtk+-fastscaling

  • Package gtk+ wants to install file /usr/lib/libgdk_pixbuf_xlib-2.0.so.0

But that file is already provided by package * gtk+-fastscaling

...

Change History

comment:1 Changed 11 years ago by roh

  • Owner changed from openmoko-devel to julian_chu
  • Component changed from unknown to Distro

comment:2 in reply to: ↑ description Changed 11 years ago by graeme

I removed gtk+-fastscaling from the latest builds because the OM theme no longer requires the hacks to get it working and I wanted to update to the latest gtk+ which has other speed improvements. I guess I forgot an RPROVIDES in the gtk+ recipe.

comment:3 Changed 11 years ago by olberger

  • Priority changed from normal to high

Doing an opkg update; opkg upgrade tonight, I get the same errors :
Collected errors:

  • Package gtk+ wants to install file /usr/lib/libgtk-x11-2.0.so.0

But that file is already provided by package * gtk+-fastscaling

  • Package gtk+ wants to install file /usr/lib/libgdk_pixbuf_xlib-2.0.so.0

But that file is already provided by package * gtk+-fastscaling

  • Package gtk+ wants to install file /usr/lib/libgdk_pixbuf-2.0.so.0

But that file is already provided by package * gtk+-fastscaling

  • Package gtk+ wants to install file /usr/lib/gtk-2.0/2.10.0/engines/libpixmap.so

But that file is already provided by package * gtk+-fastscaling

  • Package gtk+ wants to install file /usr/lib/libgdk-x11-2.0.so.0

But that file is already provided by package * gtk+-fastscaling

  • Package gtk+ wants to install file /usr/bin/gdk-pixbuf-query-loaders

But that file is already provided by package * gtk+-fastscaling

etc.

As this looked like some dev/building problem, it may have not been noticed... but looks like it happpens not only on dev side but will annoy users too.

comment:4 Changed 11 years ago by vortex

  • Severity changed from normal to major

comment:5 Changed 11 years ago by vortex

I can verify this affects anyone (users) trying to

opkg update
opkg upgrade

or even install pkgs such as openmoko-mediaplayer2

with people of various skills levels just receiving their freerunner, it has high visibility on the project.

comment:6 Changed 11 years ago by vortex

  • Version set to GTA02v6
  • Milestone set to OM-2007.2

comment:7 Changed 11 years ago by vortex

  • Status changed from new to closed
  • Resolution set to fixed

comment:8 Changed 11 years ago by vortex

As of now (3/8/08) a fresk

opkg update

seems to fix this issue.

comment:9 Changed 22 months ago by RoberMync

Baclofene Comment Ca Marche <a href=http://cial5mg.xyz/order-cialis.php>Order Cialis</a> Where Can I Buy Lasix Water Pills Online Achat Cialis En Andorre <a href=http://cial5mg.xyz/cialis-buy-online.php>Cialis Buy Online</a> Cephalexin Odor Precio Viagra De Pfizer <a href=http://cial5mg.xyz/buying-cialis-online.php>Buying Cialis Online</a> Propecia Prolactina Buy Female Viagra Online India <a href=http://kama1.xyz/kamagra-soft-tablets.php>Kamagra Soft Tablets</a> Malegra Fxt Overnight Shipping Tadalafil India 40mg <a href=http://cial1.xyz/buy-cialis-online.php>Buy Cialis Online</a> Viagra Levitra Ou Cialis Rhine Inc. India <a href=http://cial5mg.xyz>Buy Cialis</a> Propecia Sale Drugstore Priligy Temps <a href=http://cial5mg.xyz/purchase-generic-cialis.php>Purchase Generic Cialis</a> Priligy Torrinomedica Cialis 20mg Vs 40mg Best Dosage <a href=http://nolvadex.ccrpdc.com/where-to-buy-nolvadex-online.php>Where To Buy Nolvadex Online</a> Online Parmacy Problemas Del Propecia <a href=http://cial5mg.xyz/how-to-buy-cialis.php>How To Buy Cialis</a> Farmaco Viagra Generico Cialis Viagra En Ligne <a href=http://zol1.xyz/zoloft-generic-name.php>Zoloft Generic Name</a> Clomid 100mg How To Get Cialis <a href=http://viag1.xyz/viagra-online-prices.php>Viagra Online Prices</a> Pharmatie Canadienne Viagra Generique Generic Cialis 10 Mg <a href=http://kama1.xyz/kamagra-pharmacy.php>Kamagra Pharmacy</a> Buy Viagra Overnight Shipping Propecia New York <a href=http://zol1.xyz/low-price-zoloft.php>Low Price Zoloft</a> Macrobid Where To Buy Zithromax Penicillin <a href=http://viag1.xyz/best-generic-viagra.php>Best Generic Viagra</a> Pastillas Cialis Opiniones Doryx Microdox <a href=http://viag1.xyz/viagra-online.php>Viagra Online</a> Viagra Kaufen Mit Paypal Compra Kamagra En Espana <a href=http://zol1.xyz/generic-zoloft-usa.php>Generic Zoloft Usa</a> Cephalexin For Toothache Rhine Ink <a href=http://doxycycline.ccrpdc.com/compra-vibramycin-online.php>Compra Vibramycin Online</a> Moltrin 800 For Sale Cheap Viagra Online Usa <a href=http://zol1.xyz/cheap-zoloft-without-prescription.php>Cheap Zoloft Without Prescription</a> Viagra Dino Will Amoxicillin Make You Tired <a href=http://kama1.xyz/low-price-kamagra.php>Low Price Kamagra</a> Zithromax 1 Gm What Is Amoxicillin Used For <a href=http://cial1.xyz/buy-generic-cialis.php>Buy Generic Cialis</a> Baclofen Acheter 25mg Erectile Dysfunction Drugs Best Online <a href=http://xenical.ccrpdc.com/orlistat-1.php>?Orlistat</a> Viagra No Prior Prescription Kamagra Besancon 100mg <a href=http://viag1.xyz/order-viagra-onlines.php>Order Viagra Onlines</a> Cephalexin Indications Levitra Bayer 10 Mg <a href=http://cial5mg.xyz/low-cost-cialis-online.php>Low Cost Cialis Online</a> Amoxicillin For Children

Note: See TracTickets for help on using tickets.