Ticket #1655 (closed defect: worksforme)

Opened 11 years ago

Last modified 11 years ago

[illume] REMOVE button no longer removes apps

Reported by: kenrestivo Owned by: raster
Priority: normal Milestone:
Component: Qtopia Version:
Severity: normal Keywords:
Cc: raster@…, testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The "REMOVE" button in the pull down menu at the top of ASU screens used to work to kill apps. It no longer does. I can select it, it highlights, I can press it, but nothing happens. The apps never die. Once I start an app, even by accident, I'm stuck with it until I reboot the phone. Apps have become like a Halloween monster, they cannot be killed.

This is using today's ASU update.

Change History

comment:1 Changed 11 years ago by zecke

  • Cc raster@… added

Please specify what versions you use. The term "Today's" ASU update is pretty weak. As there is at least asu.dev and asu.stable. And besides you we no slightest clue what feed you are using, if you are compiling yourself etc.

For this bug at least include the following information:

  • Version of illume
  • Version of efl (like efreet, evas..., ecore.. should all be roughly the same)
  • What you actually do. Say which app you have open. Say which app you request to remove but doesn't....

comment:2 Changed 11 years ago by zecke

  • Owner changed from openmoko-devel to raster
  • Component changed from unknown to E - Illume
  • Summary changed from Remove button no longer removes apps to [illume] REMOVE button no longer removes apps

Changing the title, but still leaving it as new/unverified.

comment:3 Changed 11 years ago by zecke

  • Cc wendy_hung@… added

I have asked QA to take a look with today's image.
@wendy: Could you verify, at the rootfs image version you have used. And if you see the bug describe which app you tested? And if the bug is there please set the ASU milestone.

comment:4 Changed 11 years ago by wendy_hung

  • Cc testing@… added; wendy_hung@… removed

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080723-asu.stable-rootfs.jffs2

The "REMOVE" icon works well in illume bar for me.
I tried open all the applications in ASU, and i can close all of them by "REMOVE".

Guess it's not in ASU, but I'll still leave this as new and keep an eye on this in case it will happen in the future.

Thanks!

comment:5 Changed 11 years ago by raster

can't reproduce here either... everything closes on remove... (unless of course the app is hung...)

comment:6 Changed 11 years ago by kenrestivo

It's intermittent with most apps. I am not seeing this problem right now anymore with any app except Media Player.

I notice it happens very consistently with the Media Player app, however.

Versions are as follows:
illume - 0.0+svnr152-r6 -
illume-theme - 0.0+svnr152-r5 -
qtopia-phone-x11-mediaplayer - 4.3.2+git3+876ed02211e50547856491ad54a75299b62efe4c-r31 -
qtopia-phone-x11-mediaserver - 4.3.2+git3+876ed02211e50547856491ad54a75299b62efe4c-r31 -

comment:7 Changed 11 years ago by zecke

Next round of questions.

So what do you try to do:

  • You launch the qtopia mediaplayer
  • You start playback of a file?
  • Clicking Remove while playing is active is not doing anything? What does happen?

comment:8 Changed 11 years ago by raster

  • Status changed from new to closed
  • Resolution set to worksforme

if its certain apps that aren't closing it is almost certainly that app that has the problem. the remeove button either kills the x client - which is rare - or sends a "WM_DELETE" message to the APP - the APP then has to respond by closing its own window. if it doesn't respond - nothing to be done. this is the same mechanism used in E for all windows, on the desktop, which has worked perfectly for years... so i'm finding it very hard to believe this is a problem with E (especially since it also works in ASU with the qt apps and EFL apps that are there by default as well as other test apps).

i have never seen this not work (unless the APP doesnt want to exit - eg it's hung). i can really only mark this as "worksforme" because it does work for me... and has always done so... so unless i can reproduce it...

comment:9 Changed 11 years ago by raster

  • Status changed from closed to reopened
  • Resolution worksforme deleted

comment:10 Changed 11 years ago by raster

  • Component changed from E - Illume to Qtopia

re-open - it's probably an application problem...

comment:11 Changed 11 years ago by raster

  • Status changed from reopened to closed
  • Resolution set to worksforme

can't reproduce/duplicate at all. :(

Note: See TracTickets for help on using tickets.