Ticket #1661 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Unable to send saved tags by entering number (must have)

Reported by: wendy_hung Owned by: jeremy
Priority: highest Milestone: Om2008.9
Component: Locations Version:
Severity: blocker Keywords: must have
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Tested with the image below:
kernel:20080723-asu.stable-uImage.bin
root file system:20080723-asu.stable-rootfs.jffs2

The above image is using the qtopia keyboard. Maybe somehow this disabled this feature that was working before?

  1. launch splinter
  2. select a saved tag
  3. press send
  4. enter a number from keyboard (eg. 0987818682)
  5. press OK
  6. an alert message shows "FAIL Contact not found"

Ecpected result:
We should be able to send tags by entering phone numbers also.

Change History

comment:1 follow-up: ↓ 4 Changed 6 years ago by will

  • Blocked By 1662 added

comment:1 follow-up: ↓ 4 Changed 6 years ago by will

This could be sue to the strange GSM activity going on after using neo for x hours.
See:

https://docs.openmoko.org/trac/ticket/1662

comment:2 Changed 6 years ago by wendy_hung

  • Summary changed from Unable to send saved tags by entering numbermust have to Unable to send saved tags by entering number (must have)

comment:3 Changed 6 years ago by wendy_hung

Tested with the image below:

kernel:20080807-asu.stable-uImage.bin
root file system:20080807-asu.stable-rootfs.jffs2

Is still in the case.

comment:4 in reply to: ↑ 1 Changed 6 years ago by will

  • Status changed from new to assigned
  • Blocked By 1662 removed
  • Milestone changed from Om2008.8 to Om2008.9

Replying to will:

This could be sue to the strange GSM activity going on after using neo for x hours.
See: https://docs.openmoko.org/trac/ticket/1662

No.
Tested all over the US. Sending tags through numbers does not work at first boot.
Can someone look into this please?
Let's get it in an update asap.

comment:5 Changed 6 years ago by jeremy

Actually if the symptom is showing "FAIL Contact not found", it's because typing happens to an unexpected space implicitly leading the number string with the keyboard, but not related to phone functionality. When typing with the keyboard, it adds a space character leading the word, even the first word. This indeed somehow makes confuse.

comment:6 Changed 6 years ago by will

any updates?

comment:7 Changed 6 years ago by regina_kim

kernel : 20080827
rootfs : 20080827

only able to send if number already saved in contacts.

comment:8 Changed 6 years ago by jeremy

Actually it's already fixed soon early but it's not built into stable image yet. I will inform julian and holger cherrypick to stable branch. Thanks.

comment:9 Changed 6 years ago by wendy_hung

Hi jeremy, than please put that in_testing and tell us when we can test with that. :)

comment:10 Changed 6 years ago by regina_kim

  • Status changed from assigned to closed
  • Resolution set to invalid

we discovered this is keyboard problem.

i created new ticket for #1949.

thanks jeremy

Note: See TracTickets for help on using tickets.