Ticket #1662 (closed defect: invalid)

Opened 6 years ago

Last modified 5 years ago

[GSM] not working properly after x hours of usage

Reported by: will Owned by: zecke
Priority: highest Milestone: Om2008.10
Component: kernel Version:
Severity: blocker Keywords: Om2008.11
Cc: testing@…, openmoko-devel@…, marek@…, ole.d@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

holger, this is what we were looking into this afternoon. Phone functionality works at first boot, then slowly functionality starts to drop, becoming totally unusable. Symptons are:

  • outgoing calls get automatically disconnected
  • incoming calls can no be answered, get '1 missed call' upon answering calls
  • incoming / outgoing sms are also not working

I suspect this is also blocking #1661:
https://docs.openmoko.org/trac/ticket/1661

Attachments

x.log (113.6 KB) - added by dolfje 6 years ago.
dmesg.log (15.4 KB) - added by dolfje 6 years ago.
logread.log (63.1 KB) - added by dolfje 6 years ago.
x.2.log (95.7 KB) - added by dolfje 6 years ago.

Change History

comment:1 Changed 6 years ago by odlg

  • Cc ole.d@… added

comment:2 Changed 6 years ago by will

  • Blocking 1661 removed

(In #1661) Replying to will:

This could be sue to the strange GSM activity going on after using neo for x hours.
See: https://docs.openmoko.org/trac/ticket/1662

No.
Tested all over the US. Sending tags through numbers does not work at first boot.
Can someone look into this please?
Let's get it in an update asap.

comment:3 Changed 6 years ago by dolfje

I have this issue, how can I help to test?

comment:5 Changed 6 years ago by regina_kim

  • Milestone changed from Om2008.8 to Om2008.9

comment:6 Changed 6 years ago by erin_yueh

Hi dolfje,

if it happens again on your NEO, please upload '/tmp/x.log' file to this bug. We could analyze network problem from log file. Thanks!

if you have problem on usb networking, you may read this.
http://wiki.openmoko.org/wiki/Usb_networking

you could use scp command to download a file from NEO to your local machine. then upload file here!

comment:7 Changed 6 years ago by dolfje

I've had it again. And I think this issue is related to #1945.

After my FreeRunner? is up a 'long' time and I call to it:

  1. I get no dailing tone and I go directly to the voicemail
  2. I get a dailing tone, but my FreeRunner? don't tell me someone is calling.

So my phone isn't telling me, someone is calling. Afterwards, I get a message I had a missed call. So it knows that someone has called. (Maybe just the phone app that doesn't respond or respond wrongly to the gsm modem and rejects the call).

x.log in attach

Changed 6 years ago by dolfje

comment:8 Changed 6 years ago by zecke

http://wiki.openmoko.org/wiki/Bug_Filing_Policy Please read the part on GSM/Qtopia bugs

comment:9 Changed 6 years ago by dolfje

I've read, but I've also read the comment of erin_yueh.

Btw. You can find a log in the #1945. Because I think they are the same.

ps: If I can repro this again, I will look for getting a logread and a dmesg

comment:10 Changed 6 years ago by erin_yueh

HI! Could you please also upload a logread file? From that file, we can see what AT commands betweeen GSM network and modem. BTW, I read 'logread' file in #1945, but i can see you register to a GSM network called 'BEL PROXIMUS'

Sep 1 10:04:55 om-gta02 user.notice root: AtChat? : T : "AT+COPS?"
Sep 1 10:04:55 om-gta02 user.notice root: AtChat? : F : "+COPS: 0,0,"BEL PROXIMUS""

comment:11 Changed 6 years ago by dolfje

BEL PROXIMUS is my GSM network

(I will try to upload a logread asap. But my phone has to cooperate)

comment:12 Changed 6 years ago by will

  • Milestone changed from Om2008.9 to Om2008.10

comment:13 follow-up: ↓ 14 Changed 6 years ago by dolfje

You had my word for getting a logread asap, well here it comes.

My distro is now Om2008.9 (updated).

My fairy? tale:
After 7 hours that my gsm was up and running, it cannot get phone calls reliable. I phoned it (After I had put my phone out of suspend, 15 minutes before) 9 times. 7 times I get immediately the voice mail. 1 time I get the normal tone but my phone doesn't ring. 1 time it rings as it should be. This all when I look at the status icon and see a network connectivity of 4 blocks.

ps: I haven't had any problems with getting sms' and sending sms'.

Changed 6 years ago by dolfje

Changed 6 years ago by dolfje

Changed 6 years ago by dolfje

comment:14 in reply to: ↑ 13 Changed 6 years ago by erin_yueh

Replying to dolfje:

You had my word for getting a logread asap, well here it comes.

My distro is now Om2008.9 (updated).

My fairy? tale:
After 7 hours that my gsm was up and running, it cannot get phone calls reliable. I phoned it (After I had put my phone out of suspend, 15 minutes before) 9 times. 7 times I get immediately the voice mail. 1 time I get the normal tone but my phone doesn't ring. 1 time it rings as it should be. This all when I look at the status icon and see a network connectivity of 4 blocks.

ps: I haven't had any problems with getting sms' and sending sms'.

thanks for providing your log! From this log, it can tell you were connected with your network 'BEL PROXIMUS', received 2 phone calls, received 1 SMS, have 26 SIM SMS messages, and delete one SMS message. I cannot know why you got the voice mail from this log. It would depends on the local network traffic and need trace protocol layer. If your network never reached you on those 7 calls, we cannot see from the log. This log is stored the information between GSM modem and your application.

comment:15 Changed 6 years ago by dmatijas

I had same issue first on Om2007.7, and have now on 2008.9 in Croatia.

comment:16 Changed 5 years ago by wendy_hung

  • Keywords Om2008.11 added; must have removed
  • HasPatchForReview unset

comment:17 Changed 5 years ago by Zoup

I can confirm this by today daily image and kernel .

comment:18 Changed 5 years ago by PaulFertser

  • Status changed from new to closed
  • Resolution set to invalid

Closing as "not system software, and use supported distro"

Note: See TracTickets for help on using tickets.