Ticket #167 (closed enhancement: fixed)

Opened 12 years ago

Last modified 11 years ago

add LCM QVGA switching support

Reported by: laforge@… Owned by: stefan@…
Priority: high Milestone:
Component: kernel Version: current svn head
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

We want to be able to switch from 480x320 LCM to 240x320 LCM Mode (yes, the LCM
supports this).

Basically the respective SPI initialization squences need to be added ot the LCM
driver, and s3c2410-fb needs to be made capable of re-configuring the display
timings, etc on the fly.

Change History

comment:1 Changed 12 years ago by laforge@…

  • Owner changed from laforge@… to stefan@…

comment:2 Changed 12 years ago by stefan@…

The first batch of patches for SPI init were send to openmoko-kernel.

The problem is that I'm not able to get the fb working together with the LCM in
QVGA mode.

Just setting the mode and timings from data-sheet in mach-gato1.c does not work.
Reconfigure the framebuffer register with JTAG gives a partially result. The
mode is changed if we set to VGA first and set it back to QVGA afterwards.

I'm still not sure what is happening there. Needs more investigation. I will
care about this after 2007-04-14

comment:3 Changed 12 years ago by alphaone@…

Any news on that?

comment:4 Changed 11 years ago by stefan@…

I just sent a patchset which adds QVGA support to openmoko-kernel

http://lists.openmoko.org/pipermail/openmoko-kernel/2007-October/000296.html

The last missing piece is somekind of communication between the lcm and the fb
driver. I like to get some fedback on this before implementing it.

comment:5 Changed 11 years ago by mickey@…

Can we close this now?

comment:6 Changed 11 years ago by nod_huang@…

  • Status changed from new to closed
  • Resolution set to wontfix

won`t fix

comment:7 Changed 11 years ago by laforge@…

  • Status changed from closed to reopened
  • Resolution wontfix deleted

why would we mark a bug as WONTFIX if it

1) might already have been fixed
2) there are still pending questions related to it?

comment:8 Changed 11 years ago by andy

  • Status changed from reopened to closed
  • Resolution set to fixed

Seems Harald committed the patch some months ago, nobody has mentioned QVGA AFAIK since then, seems resolved.

Note: See TracTickets for help on using tickets.