Ticket #1670 (closed enhancement: wontfix)

Opened 9 years ago

Last modified 9 years ago

Battery life too short; phone should sleep

Reported by: kenrestivo Owned by: openmoko-kernel
Priority: normal Milestone: Om2008.10
Component: kernel Version:
Severity: normal Keywords:
Cc: nomeata, testing@…, calestyo@…, ritz Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The battery life is too short for the phone to be usable as a phone.

1) The FR should go into a deep sleep mode after some user-settable timeout, and be woken only upon GSM incoming call or the user pushing the screen lock and/or power button.

2) It should not be awoken by jostling against the touchscreen when in sleep mode.

3) The screen lock button (on ASU) should also dim the screen and NOT allow any touchscreen activity to wake it up. Hitting the lock button should undim the screen again, and, if the phone had timed out into sleep mode, bring it out of sleep mode.

And anything else that might help prolong battery life would be great.

Change History

comment:1 Changed 9 years ago by nomeata

  • Cc nomeata added

comment:2 Changed 9 years ago by wendy_hung

  • Cc testing@… added

comment:3 Changed 9 years ago by calestyo

  • Cc calestyo@… added

comment:4 Changed 9 years ago by ritz

  • Cc ritz added

comment:5 Changed 9 years ago by RuiSeabra

  • Owner changed from openmoko-devel to openmoko-kernel
  • Component changed from unknown to System Software

Unmeasured improvement: dim back-light to zero a little sooner than 600s

Add to /etc/matchbox/session, somewhere in the beginning:

# dim back-light sooner than default, 15s instead of 600s of idle
xset s 15 &

comment:6 Changed 9 years ago by regina_kim

  • Milestone set to Om2008.9

comment:7 Changed 9 years ago by regina_kim

  • Milestone changed from Om2008.9 to Om2008.10

comment:8 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to wontfix

why set this as milestone? this is already the current situation in om2008.

comment:9 Changed 9 years ago by RuiSeabra

No, it's not. The phone doesn't sleep, the phone DIES for effective use after about ten minutes (white screen of death) so the phone can't sleep.

Closing a ticket for the sake of closing is not proper ticket handling.

comment:10 Changed 9 years ago by octavsly

I am using the kernel from 20081103 and the battery life has increased dramatically. After 24hours (also making one call, and playing few times with the settings) the battery is still half.

Are other users experiencing the same?

comment:11 Changed 9 years ago by RuiSeabra

I'm not. It's still short as hell (specially because I have to disable suspend or I get a WSOD).

comment:12 Changed 9 years ago by RuiSeabra

Oh, and I'm running the 20081104 daily.

comment:13 Changed 9 years ago by octavsly

Recharged after 52 hours, (the phone was still on)

comment:14 Changed 9 years ago by RuiSeabra

Nice, but how does that help me? :)

comment:15 Changed 9 years ago by octavsly

Well. I am not a developer. I heard stories of 100+ standby but I was always below 24hours.

In your case, it might be that you have a defective hardware.
What phone version do you have?

comment:16 Changed 9 years ago by RuiSeabra

I have a Neo Freerunner Rev5.

comment:17 Changed 9 years ago by octavsly

I think I have a 6 (don't want to wake it up to see how much it lasts :-)

Note: See TracTickets for help on using tickets.