Ticket #1684 (closed enhancement: fixed)

Opened 10 years ago

Last modified 10 years ago

WLAN to default to off on Freerunner, switchable down /sys

Reported by: andy Owned by: andy@…
Priority: normal Milestone:
Component: kernel Version:
Severity: normal Keywords:
Cc: nomeata Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

GTA02 WLAN is actually always on, but it takes a power and reset signal from GPIO.

Until now, machine init always powered the thing up by these, adding 300ms to early boot and causing it to eat more power for the whole session.

I already have a patch that exposes the power_on and reset GPIO same as done for bt, I will test it (particularly SDIO autodetect is a question, the code seems to be there) shortly.

The impact on userspace is going to be that dumb initscripts that expect eth0 there are going to fail now. It really needs to be done via udev, so the WLAN device can randomly appear and then get configured by NetworkManager? or whatever.

Change History

comment:1 Changed 10 years ago by nomeata

  • Cc nomeata added

comment:2 Changed 10 years ago by xbaldauf

This change is also necessary to work around apparent bugs of the WIFI card (or driver), see http://docs.openmoko.org/trac/ticket/1625 .

comment:3 Changed 10 years ago by andy

Status of this is that Atheros stack cannot handle the device disappearing and reappearing with power on and off. They recommend that we stick WLAN stuff in modules, and have a scripts to rmmod the modules, turn off power; and turn on power then modprobe the modules.

Currently we have the Atheros SDIO stuff built-in to the kernel.

comment:4 Changed 10 years ago by xbaldauf

We should definitely do this: My wifi is very unstable when moving the Freerunner around (all within the coverage area, of course): After about 3 minutes, the connection is gone and wpa_supplicant just tries to associate to the accesspoint without any connection being establishable.

comment:5 Changed 10 years ago by lindi

Is the patch online somewhere? From page 16 of http://downloads.openmoko.org/schematics/GTA02/Schematics_Freerunner-GTA02_A5-A7cumulative_public_RC0.pdf I get the impression that the RESET pin of wlan (12) is connected with Marvell 88W8686 but is not connected to anything with Atheros AR6001GZ. Am I reading the schematics wrong?

comment:6 Changed 10 years ago by andy

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed

This is resolved now since the WLAN stuff can be built as modules. modprobe -r it, or never insert the modules, to get the WLAN into its lowest power mode.

Note: See TracTickets for help on using tickets.