Ticket #1685 (closed enhancement: fixed)

Opened 11 years ago

Last modified 10 years ago

[Suspend/Resume time] The device insist to go suspend even after touch the screen to wake it up from blank time

Reported by: wendy_hung Owned by: raster
Priority: low Milestone: Om2008.9
Component: E - Illume Version:
Severity: normal Keywords:
Cc: devel@…, testing@…, zecke@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel:20080723-asu.stable-uImage.bin
root file system:20080729-asu.stable-rootfs.jffs2

Summary:The device insist to go suspend even after touch the screen to wake it up from blank time

Steps:
1) set the device with suspend time
2) touch the screen right away when the device goes to the blank time

Current results:
The device will show up the screen for a second than go suspend time what ever

Expected:
The screen should be lock immediately

PS.
Raster, I know I've been discussed this with you before, but this will happened when you think the device is wake up and you are ready to use other applications. It's really annoy and confuse. Can we just lock the screen once if it goes to blank time or something like this?

Change History

comment:1 Changed 11 years ago by raster

  • Status changed from new to in_testing

ok - basically it should happen much less now - once a suspend request is in ompower it sets brightness to 0 and turns off the screen (restores on resume). now there is a race (gap between illume asking for a suspend and a wakeup from screenlock thanks to a press).

the problem is i can't turn off touchcreen input device events so they always wake x/backlight up as x is doing this itself. it's better behaved now with ompower changes anyway.

comment:2 Changed 11 years ago by wendy_hung

  • Status changed from in_testing to assigned
  • Cc devel@… added

Tested with the image below:

kernel:20080723-asu.stable-uImage.bin
root file system:20080806-asu.stable-rootfs.jffs2

It's just only a little bit different than before, for us that still looks the same.
Sorry Raster, we have to fix it. Please discuss on the devel list how to solve this issue.
Thank you!

comment:3 Changed 11 years ago by raster

not going to be able to do anything between now and august 8 about this beyond move ALL screen blanking to client-side. also need to add signals to ompower to indicate coming out of suspend and why.

i think you don't have the same thing thats in asu.dev - holger was working on moving to asu.stable just a few hours ago, so you're probably not seeing anything different. you will know it's different as on actual suspend the screen doesnt come back with backlight just before suspend and a small grey cursor top-left of the screen (this is no hidden).

comment:4 Changed 11 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

comment:5 Changed 10 years ago by regina_kim

  • Status changed from assigned to closed
  • Resolution set to fixed

kernel : 20080827
rootfs : 20080827

it has fixed.

thanks Raster!~

Note: See TracTickets for help on using tickets.