Ticket #1687 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

FR LCD goes blank suddenly

Reported by: balajirrao Owned by: openmoko-kernel
Priority: normal Milestone: Om2007.2
Component: kernel Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I'm running 2007.02.

I've applied mwester's fixes to fix sound breakage during suspend/resume. It was working all fine.. Until suddenly I see that the screen remains blank (after suspend I suppose). The display did not come up no matter what.

But the device was accessible through ssh and I did a dmesg and saw a lot of 'pcf50633_battvolt timeout :-('. And apm -s gives 'Device or resource busy'. I had to reboot to fix this.

Change History

comment:1 Changed 11 years ago by mickeyl

  • Owner changed from openmoko-devel to openmoko-kernel
  • Component changed from unknown to System Software

I can confirm this (with FSO). It looks like sometimes the framebuffer gets a blank signal, but no matter what I do, i can only wake it again up by rebooting.

comment:2 Changed 10 years ago by andy

  • HasPatchForReview unset

I assume this is gone in more recent kernels with the WSOD changes about framebuffer blanking.

comment:3 Changed 10 years ago by PaulFertser

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.