Ticket #1698 (closed defect: fixed)

Opened 11 years ago

Last modified 22 months ago

[E-illume bar] time will changing after take off battery.

Reported by: regina_kim Owned by: andy
Priority: high Milestone: Om2008.9
Component: kernel Version:
Severity: critical Keywords:
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 20080723-asu.stable-uImage.bin
rootfs : 20080730-asu.stable-rootfs.jffs2

summary : time will changing after take off battery.

step :

  1. check the current time.
  2. remove battery and Put in battery
  3. turn on device then check the time

current result : time will changing

expected result : time should be same even take off battery.

Change History

comment:1 Changed 11 years ago by raster

  • Owner changed from raster to andy
  • Status changed from new to assigned

system issue - the gadget in illume just displays the current time... whatever it is. btw - i can confirm that this does happen. clock jumps to a very much different time. "date" reports it on the cmd-line as well as illume's clock. they agree on the time at any rate. but time doesn't agree with reality! :(

comment:2 Changed 11 years ago by regina_kim

  • Severity changed from major to critical

comment:3 Changed 11 years ago by rhk

  • Priority changed from high to highest

I can confirm this as well. I had to remove the battery to restart and the clock is now about 10 minutes behind. This is on 2007.2, kernel Linux om-gta02 2.6.24 #1 PREEMPT Tue Aug 5 04:27:23 CEST 2008 armv4tl unknown

comment:4 Changed 11 years ago by rhk

  • Priority changed from highest to high

(hate these properties.. sorry about the change..)

comment:5 follow-up: ↓ 6 Changed 11 years ago by andy

If your backup battery state is low and you remove all other power, then the clock will either stop or act erratic in hardware. Can that be the case here?

comment:6 in reply to: ↑ 5 Changed 11 years ago by rhk

Replying to andy:

If your backup battery state is low and you remove all other power, then the clock will either stop or act erratic in hardware. Can that be the case here?

I guess so.. but.. Why would the backup battery state be low and is there a way to check it? The main battery had been there for hours and FR was on before I had to remove it.

comment:7 Changed 11 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

comment:8 Changed 11 years ago by raster

  • Component changed from E - Illume to Distro

moving to system.. it's either hardware or system...

comment:9 Changed 11 years ago by zecke

  • Component changed from Distro to System Software

Really move that to system.

comment:10 Changed 11 years ago by andy

Werner said yesterday he will study this.

comment:11 Changed 11 years ago by werner

I tried to reproduce it, but I seem to get the correct time.

My test procedure:

  • connect USB and battery power
  • connect the debug board
  • reset and enter u-boot via the serial console
  • obtain the time with "date" or "imd 73 59 7". Example:

GTA02v5 # imd 73 59 7;date
0059: 27 13 10 05 05 05 08 '......
Date: 2008-05-05 (Friday) Time: 10:13:27

  • display time on Neo and PC:

Date: 2008-05-05 (Friday) Time: 10:14:56
Fri Sep 5 10:14:52 ART 2008

(Neo = PC+4s)

  • hardware reset from the debug board, then display time

Date: 2008-05-05 (Friday) Time: 10:16:45
Fri Sep 5 10:16:41 ART 2008

(Neo = PC+4s, as before)

  • turn off battery power for ~5s, power on with POWER button, then display time

Date: 2008-05-05 (Friday) Time: 10:19:05
Fri Sep 5 10:19:01 ART 2008

(Neo = PC+4s)

  • remove USB, then turn off battery power for ~5s, re-apply battery power, then insert USB

Date: 2008-05-05 (Friday) Time: 10:21:39
Fri Sep 5 10:21:35 ART 2008

(Neo = PC+4s)

  • detach all power, including debug board for some 40 minutes
  • backup battery voltage is 1.66V
  • powered on by attaching debug board, battery, then USB

Date: 2008-05-05 (Friday) Time: 11:09:45
Fri Sep 5 11:09:40 ART 2008

(Neo = PC+5s)

So the RTC hardware seems to be stable within the bounds of measurement errors.

Can anyone who experienced this problem please try and see if it can also be
reproduced it in u-boot ? Also, which hardware was used ? If possible, a
measurement of the backup battery voltage would be great as well.

Thanks,

  • Werner

comment:12 Changed 11 years ago by regina_kim

  • Status changed from assigned to closed
  • Resolution set to fixed

kernel : 20080903
roofts : 20080904

i tested with above image. works very well now.

thanks

comment:13 Changed 11 years ago by andy

Thanks for looking at it Werner. If anyone sees this problem again, let us know the kind of change that happened to the time. If the time was just crazy like 99:99 12/34/56 or it just changed by 5 hours or something, we can get a clue.

We didn't change much around this since Aug 5th kernel RHK saw it with.

comment:14 Changed 22 months ago by Chassmetly

Doxycycline Purchase In China <a href=http://viagra.ccrpdc.com/viagra-online.php>Viagra Online</a> Comprar Cialis En Canada Propecia Sas <a href=http://kama1.xyz/order-kamagra.php>Order Kamagra</a> Achat Viagra Cialis Generique Kamagra Oral Jelly Walmart <a href=http://kama1.xyz/online-generic-kamagra.php>Online Generic Kamagra</a> Acticin Scabies Cod Accepted Internet Overnight Shipping Find Generic Clobetasol Low Price Online <a href=http://viag1.xyz/cheap-viagra-online.php>Cheap Viagra Online</a> Novidat 500mg Fill out the easy online application and submit it. Payday loans guidelines make it possible to issue payday advance to residents of USA above years and who have monthly income up and above. Personal loans at low interest APR rates are Looking for a small loan under You can use an unsecured loan to pay for a car or go on a well earned If you are Our fast secure application gives you access to multiple lenders most suitable lender for your specific requirements and get back to you with a you receive a call from someone claiming to be st Loan please hang up.Now here is how and why this system works Out of every block of posts I made I got back responses. <a href=http://easymoneyfast365.com>need money now</a> Terms vary by state Fast Approval Online Watch Out for These Credit Score Dangers Sep This is What You Should Include in Your Family Budget Sep We offer installment loans with rates lower than payday loans and repayment terms that allow for multiple payments rather than one payment.If you are interested in joining our network of private lenders click here for more info Great opportunity for high returns on investment Our loan programs offer investor the flexibility to also buy and hold property as a rental property.Order Propecia Service <a href=http://cial5mg.xyz/generic-cialis-pricing.php>Generic Cialis Pricing</a> Amoxicillin Used To Treat Chlamidia Buy Generic Propecia Online <a href=http://viag1.xyz/where-to-order-viagra.php>Where To Order Viagra</a> La Viagra Necesita Receta

Note: See TracTickets for help on using tickets.