Ticket #1706 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

[Installer] install package time out without warning message

Reported by: wendy_hung Owned by: tick
Priority: normal Milestone: Om2008.9
Component: Installer Version:
Severity: normal Keywords:
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel:20080723-asu.stable-uImage.bin
root file system:20080731-asu.stable-rootfs.jffs2

Summary: Install package time out without warning message

Steps:
1) launch installer
2) pick a bigger package to install (like London map)
3) the "Installing" bar is running for over 30minutes
4) suppose to be system time out or so, but no warning messages

Expected:
should tell us whither the package is too big or if the system time out

Change History

comment:1 Changed 11 years ago by tick

  • Status changed from new to accepted

comment:2 Changed 11 years ago by tick

Timeout set to 900 sec for we may have very large packages.
After Assassin svn 225, it's more stable now, however there may happens to unzip wrong format files, and cause crash in libopkg.
It not happens all the time, very seldom. That will lead action failed. I think it because transfer error. After 15 mins, yes you will get timeout alert if that happened.

Right now action is quite stable, but not perfect yet.

Another case is DBus failed, it more seldom. When this happens, every service using DBus will failed.

comment:3 Changed 11 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

comment:4 Changed 11 years ago by tick

  • Status changed from accepted to in_testing

comment:5 follow-up: ↓ 6 Changed 11 years ago by regina_kim

  • Status changed from in_testing to closed
  • Resolution set to fixed

kernel : 20080826
roofts : 20080901

it shows up "Alert message" but it takes 15 min.
so i will close this ticket.
created new #1743

comment:6 in reply to: ↑ 5 Changed 11 years ago by regina_kim

Replying to regina_kim:

kernel : 20080826
roofts : 20080901

it shows up "Alert message" but it takes 15 min.
so i will close this ticket.
created new #1743

sorry #1943

Note: See TracTickets for help on using tickets.