Ticket #1718 (closed defect: fixed)

Opened 9 years ago

Last modified 3 months ago

python-pygtk programs don't work

Reported by: Mercury Owned by: julian_chu
Priority: normal Milestone: Om2008.8
Component: Distro Version: GTA02v5
Severity: normal Keywords:
Cc: noha Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I tried installing python-pygtk to run a script someone had written, but it (and all other pygtk scripts) fail out with this error:


Traceback (most recent call last):

File "./pygtkconsole.py", line 14, in <module>

import gtk

File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/init.py", line 82, in <module>

init()

NameError?: name 'init' is not defined


The error seems to be indicating that the problem is during the initialization of the gtk stuff.

I'm using the 'http://downloads.openmoko.org/openmoko-repository/ASU/' feed and I ran opkg upgrade today and it didn't help.

Change History

comment:1 Changed 9 years ago by noha

  • Cc noha added

comment:2 Changed 9 years ago by Yasumoto

  • Owner changed from julian_chu to openmoko-devel
  • Version changed from unspecified to GTA02v5
  • Component changed from Distro to unknown

I can confirm this issue using the 2008.08 build released today.

comment:3 Changed 9 years ago by Yasumoto

  • Owner changed from openmoko-devel to julian_chu
  • Component changed from unknown to Distro

comment:4 Changed 9 years ago by neilbrown

I had this problem too.

I found that if you change the "init" call on line 82 of
/usr/lib/python2.5/site-packages/gtk-2.0/gtk/_init_.py
to "_init" (i.e. add a leading underscore),
then pygtk works perfectly.

NeilBrown?

comment:5 follow-up: ↓ 6 Changed 9 years ago by erin

i had same problem too and i modified '/usr/lib/python2.5/site-packages/gtk-2.0/gtk/_init_.py' this file like NeilBrown? replied.

comment:6 in reply to: ↑ 5 Changed 9 years ago by h.koenig

Replying to erin:

i had same problem too and i modified '/usr/lib/python2.5/site-packages/gtk-2.0/gtk/_init_.py' this file like NeilBrown? replied.

same problem here (needed for battery.ipk) -- found same "fix" after spending some time
(and after knowing the problem/fix I also found this ticket;)

what about releasing a new and fixed python-pygtk package to help others ?!

comment:7 Changed 9 years ago by erin_yueh

yeah, you can get the latest released opkg here.

root@om-gta02:~# opkg install python-pygtk
Installing python-pygtk (2.10.4-ml8) to root...
Downloading http://downloads.openmoko.org/repository/testing/armv4t/python-pygtk_2.10.4-ml8_armv4t.ipk

comment:8 Changed 9 years ago by erin_yueh

  • Status changed from new to in_testing

comment:9 Changed 9 years ago by regina_kim

hey Mercury~ please check this issue weather still happen or not.

comment:10 Changed 9 years ago by Mercury

It works now :)

comment:11 Changed 9 years ago by erin_yueh

  • Status changed from in_testing to closed
  • Resolution set to fixed

comment:12 Changed 9 years ago by dolfje

Is this supposed to be solved in the stable updates of om2008.8? Because I still have this problem. I did a forced reinstall of python-pygtk and get again a init.py file with on line 82 init() instead of _init()

comment:13 Changed 9 years ago by rhk

Installed 2008.9 yesterday and had this. Fixed manually editing the line 82 of init.py
Is the fix included in the main repositories now?

comment:14 Changed 9 years ago by exactt

what is the actual reason that a fix released and tested 6(!) weeks ago hasn't made it into the official 2008.8/9 repos yet?

comment:15 Changed 3 months ago by JustDox

Progesterone C.O.D. Internet <a href=http://viag1.xyz/mail-order-viagra.php>Mail Order Viagra</a> Amoxicillin And Refrigerator Propecia Side Effects Ambigram <a href=http://zol1.xyz/order-zoloft-in-usa.php>Order Zoloft In Usa</a> Levitra 40 Mg Sale Zentel No Physician Approval <a href=http://accutane.ccrpdc.com/accutane-pills-online.php>Accutane Pills Online</a> In House Pharmacy Uk Long Term Amoxicillin <a href=http://zol1.xyz/purchase-generic-zoloft.php>Purchase Generic Zoloft</a> Acheter Priligy En Belgique Dapoxetine Priligy <a href=http://viag1.xyz/viagra-cheap.php>Viagra Cheap</a> Meridia Propecia Diflucan Online No Script Fast Shipping <a href=http://zoloft.ccrpdc.com/cheap-generic-zoloft.php>Cheap Generic Zoloft</a> Acheter Cialis Sur Ebay Achat Kamagra Sans Risque <a href=http://zol1.xyz/buy-zoloft-uk.php>Buy Zoloft Uk</a> Preisvergleich Cialis 20 Mg Kohlpharma Traitement Cialis 5mg Cpr 28 <a href=http://zol1.xyz/buy-cheap-zoloft-site.php>Buy Cheap Zoloft Site</a> Amoxil Chat Groovorio <a href=http://zol1.xyz/zoloft-cost.php>Zoloft Cost</a> Cialis Ne Marche Pas Forum Find Finasteride Best Website <a href=http://cial1.xyz/buy-cheap-cialis.php>Buy Cheap Cialis</a> How Long For Cialis Peaks In The Blood Will Propecia Stop My Hair Loss <a href=http://cial5mg.xyz/where-to-order-cialis.php>Where To Order Cialis</a> Precio Kamagra Buy Lopressor Without Prescription <a href=http://viag1.xyz/order-viagra-pills.php>Order Viagra Pills</a> buy generic isotretinoin internet visa with free shipping Generic Viagra Sample Pack <a href=http://zol1.xyz/order-zoloft-pills.php>Order Zoloft Pills</a> Cialis Uberdosiert Forgot To Refrigerate Amoxicillin And Clavulanate <a href=http://zol1.xyz/implicane-tablets.php>Implicane Tablets</a> Precio Viagra Autentica Viagra E Fecondazione <a href=http://zol1.xyz/zoloft-online-cs.php>Zoloft Online Cs</a> Achat Cialis Marseille Where Can I Get Cephalexin <a href=http://cialis.ccrpdc.com/buy-generic-cialis.php>Buy Generic Cialis</a> Can I Take Metamucil With Amoxicillin Propecia Wikipedia <a href=http://cial1.xyz/order-cialis-in-usa.php>Order Cialis In Usa</a> Zithromax I.V. Toradol From Canada <a href=http://kama1.xyz/kamagra-jelly-online.php>Kamagra Jelly Online</a> Priligy Sales Buy Online Amoxicillin <a href=http://viag1.xyz/viagra-cheap.php>Viagra Cheap</a> Quanto Costa Il Cialis 10 Mg Levitra 20 Mg Vademecum <a href=http://xenical.ccrpdc.com/order-orlistat.php>Order Orlistat</a> Puedo Tomar Cialis Con Alcohol Clobetasol Clobex Low Price <a href=http://viag1.xyz/viagra-prices.php>Viagra Prices</a> Cialis Depression Cialis 20 Mg Foglio Illustrativo <a href=http://cial5mg.xyz/shop-cialis-online.php>Shop Cialis Online</a> Celebrex Comprarlo Medicamento Cialis Generica <a href=http://kama1.xyz/generic-kamagra-cheap.php>Generic Kamagra Cheap</a> Non Prescription Azelastine Kamagra Uprima <a href=http://cial1.xyz/order-cialis-online-usa.php>Order Cialis Online Usa</a> Get Discount Fluoxetine With Free Shipping Baclofen <a href=http://zol1.xyz/buy-zoloft-uk.php>Buy Zoloft Uk</a> Cialis En Francia Online Stendra Discount <a href=http://viag1.xyz/viagra-online.php>Viagra Online</a> Venta Cialis Tenerife Cialis Ebay <a href=http://kama1.xyz/order-generic-kamagra.php>Order Generic Kamagra</a> Zithromax Dose For Cats Amerimedrx Pharmacy <a href=http://zol1.xyz/can-i-buy-zoloft-online.php>Can I Buy Zoloft Online</a> Propecia Pris I Sverige How To Buy Amoxicilina Without Dr Approval <a href=http://cial1.xyz/get-cheap-cialis-online.php>Get Cheap Cialis Online</a> Prednisone Online Purchase Levitra Acquistare Impotenza <a href=http://kama1.xyz/kamagra-online-pharmacy.php>Kamagra Online Pharmacy</a> Baclofene Pharmacie En Ligne Vivanza 20mg <a href=http://cial1.xyz/cialis-free-trial.php>Cialis Free Trial</a> Acheter Baclofen En Ligne Canadian Pharmacies That Accept Paypal <a href=http://cial1.xyz/online-cialis.php>Online Cialis</a> Viagra Puissant Pour Homme What Is Amoxicillin Clav Used For <a href=http://prednisone.ccrpdc.com/buy-online-deltasone.php>Buy Online Deltasone</a> My Health 24 Levitra 20 Mg Prospecto <a href=http://doxycycline.ccrpdc.com/doxycycline-cost.php>Doxycycline Cost</a> Purchase Macrobid Amex No Prescription Store Je Veux Acheter Du Cialis <a href=http://cial1.xyz/cialis-prices.php>Cialis Prices</a> Kamagra Vs Viagra

Note: See TracTickets for help on using tickets.