Ticket #1726 (closed defect: fixed)

Opened 11 years ago

Last modified 11 years ago

Entering SIM PIN often includes a space

Reported by: odlg Owned by: openmoko-devel
Priority: high Milestone:
Component: Qtopia Version: GTA02v5
Severity: critical Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

When I am entering the SIM PIN I often get a space before the actual PIN code. Extreme care is needed, because entering the SIM PIN a second time mostly fails.

Change History

comment:1 Changed 11 years ago by zecke

  • Milestone ASU deleted

Which keyboard do you use?

comment:2 Changed 11 years ago by odlg

I use the keyboard from this description: http://n2.nabble.com/Flash-ASU-tp587836p588036.html - dont know what it is called...

comment:3 Changed 11 years ago by zecke

  • Status changed from new to closed
  • Component changed from unknown to Qtopia
  • Resolution set to fixed

As the PIN may not contain spaces I'm stripping whitespace at the beginning and end of the PIN. This should be enough for our keyboard implementations.

I might end up adding code that discards any space even in the middle of the PIN.

Note: See TracTickets for help on using tickets.