Ticket #1734 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

[settings] wifi show up "unknown"

Reported by: wendy_hung Owned by: marek
Priority: high Milestone: Om2008.9
Component: Distro Version:
Severity: major Keywords:
Cc: testing@…, raster@…, marek@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

kernel:20080723-asu.stable-uImage.bin
root file system:20080804-asu.stable-rootfs.jffs2

Summary:wifi show up "unknow"

Steps:
1) go to WiFi? in exposure
2) select one without lock icon
3) it goes with two situation: hightlight means connected and show up unknown directly, and it's more often to show up "unknown"

Excepted:
No unknown.

Change History

comment:1 Changed 6 years ago by marek

  • Status changed from new to accepted
  • Component changed from Network Manager to Exposure

Please check again, some things were fixed in the recent version. If it does not work provide a distinct path to reproduce the problem.

comment:2 Changed 6 years ago by wendy_hung

  • Severity changed from blocker to major

comment:3 follow-up: ↓ 8 Changed 6 years ago by mattt

  • Summary changed from [WiFi] wifi show up "unknow" to [WiFi] wifi show up "unknown"

I have the same error, different build.

Device was flashed with the following in this order:

*u-boot-gta02v5-1.3.1+gitr38+64eb10cab8055084ae25ea4e73b66dd03cc1a0cb-r0.bin
md5 310047f33b6214f9ed299dfa422ceab8

*Om2008.8-gta02-20080808.uImage.bin
md5 f5a0e045ec9a2f0f08513fffc14b362e

*Om2008.8-gta02-20080808.rootfs.jffs2
md5 9d11744284f180b28423d6bfcd46bff2

The device boots ok, but in Settings/Wifi? it says : 'unknown'
No networks are detected.

Additionally, usb is not working, no connection from ubuntu.
Power icon does however change to indicate usb power.

Back story : I previously has 20080806 installed and wifi and usb worked fine.

comment:4 follow-up: ↓ 27 Changed 6 years ago by mattt

Just in the interest of completeness, I reflashed the old rootfs...

openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2
still using the 20080808 kernel.

wifi works
usb works
carrier is detected.

So I don't think it's the kernel.
And it isn't he hardware.

comment:5 Changed 6 years ago by marek

  • Summary changed from [WiFi] wifi show up "unknown" to [Exposure] wifi show up "unknown"

comment:6 Changed 6 years ago by slozano

Same problem here. I flashed the 2008.8 release, bin and rootfs.
USB networking is working after changing the "/etc/networking/interfaces"
GSM is working.
GPS not working yet :(

comment:7 Changed 6 years ago by will

  • Milestone changed from Om2008.8 to Om2008.9

comment:8 in reply to: ↑ 3 Changed 6 years ago by marek

Replying to mattt:

I have the same error, different build.
The device boots ok, but in Settings/Wifi? it says : 'unknown'
No networks are detected.

This is not the same bug - please re-read the initial description.

Additionally, usb is not working, no connection from ubuntu.

This has nothing to do with the wifi bug mentionned here.

Power icon does however change to indicate usb power.

That also has nothing to do with the wifi bug.
Please create another ticket for that after checking for existing bugs concerning this problem.

Back story : I previously has 20080806 installed and wifi and usb worked fine.

No 20080806 was ever released - I don't know what you used before.

comment:9 Changed 6 years ago by marek

  • Status changed from accepted to in_testing

I set this to testing because I think it is solved by now. Please reopen if not.

comment:10 Changed 6 years ago by slozano

I flashed the phone using NOR Flash and the Om_2008.8 page mentions to flash using NAND, would this generate the WIFI unknown problem?

comment:11 follow-up: ↓ 13 Changed 6 years ago by marek

  • Component changed from Exposure to Assassin
  • Summary changed from [Exposure] wifi show up "unknown" to [settings] wifi show up "unknown"

Please be more precise otherwise it is hard to help you.

What did you flash and how can you trigger the "wifi unknown problem" ?
The QA team provided a step by step instruction. If you _can't_ reproduce this open another bug.

In general it does not matter how you flash but what you flash ...

comment:12 Changed 6 years ago by marek

  • Component changed from Assassin to Exposure

Sorry, don't know why it changed to Assassin.

comment:13 in reply to: ↑ 11 ; follow-up: ↓ 16 Changed 6 years ago by slozano

Replying to marek:

Please be more precise otherwise it is hard to help you.

What did you flash and how can you trigger the "wifi unknown problem" ?

I flashed the release Om2008.8.uImage.bin and Om2008.8.rootfs.jffs2 files using dfu-util version 0.1+svn4160 and since that moment the WIFI shows unknown when entering the setting application.
I flashed the 20080424 and the wifi works again, I put the openmoko-openmoko-qtopia-x11 rootfs and the wifi works again. If i put the 2008.08 release bin and rootfs the wifi show unknown.

The QA team provided a step by step instruction. If you _can't_ reproduce this open another bug.

Instructions for flashing?

In general it does not matter how you flash but what you flash ...

Thanks, Saul

comment:14 Changed 6 years ago by shishz

I have updated my 2008.8 freerunner to the packages here:

http://people.openmoko.org/~zecke/om2008.8-testing/

I click Settings (is this what your calling exposure?), then click Wifi, screens then says "Wifi Unknown". If I ssh into the phone and run "iwlist eth0 scan", it lists multiple access points. So, still no wifi access for me.

comment:15 Changed 6 years ago by marek

  • Cc raster@… added
  • Status changed from in_testing to assigned

I can reproduce the same problem now.
The connman network manager does not list network interfaces. We are working on this issue.

comment:16 in reply to: ↑ 13 Changed 6 years ago by marek

Replying to slozano:

Instructions for flashing?

The initial bug report (yellow box at the top) has a step by step instruction how to reproduce the problem.

comment:17 follow-up: ↓ 18 Changed 6 years ago by marek

  • Cc marek@… added
  • Component changed from Exposure to Distro

The root cause seems to be that the hald is not running. This has to be fixed by the distro team.

comment:18 in reply to: ↑ 17 ; follow-up: ↓ 19 Changed 6 years ago by nkinkade

Replying to marek:

Seems that hald wasn't starting because /var/cache/hald didn't exist. I deleted /etc/volatives.cache and rebooted, and this fixed the problem for me. /etc/init.d/populate-volatiles.sh wasn't creating the volatiles, presumably because /etc/volatiles.cache existed and VOLATILE_ENABLE_CACHE is set to "yes" in /etc/default/rcS. How a stale volatiles.cache file got in /etc without the hald entries I don't know. Maybe this information will be of use to someone.

comment:19 in reply to: ↑ 18 Changed 6 years ago by slozano

Replying to nkinkade:

Replying to marek:

I followed the instructions posted by nkinkade ("I deleted /etc/volatives.cache and rebooted"), the WIFI shows ON and I can detect neighboring wireless access points. Diversity WiFi? is working also. Cheers.

comment:20 Changed 6 years ago by marek

  • Status changed from assigned to in_testing

The distro team worked on that issue.

comment:21 Changed 6 years ago by regina_kim

  • Component changed from Distro to Settings

comment:22 Changed 6 years ago by regina_kim

  • Component changed from Settings to Distro

comment:23 Changed 6 years ago by wendy_hung

in four of my device only one happened with this problem.
test with the image:
kernel:20080826-asu.stable-uImage.bin
root file system:20080829-asu.stable-rootfs.jffs2

will test it with next image!

comment:24 Changed 6 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

test with the image:
kernel:20080826-asu.stable-uImage.bin
root file system:20080901-asu.stable-rootfs.jffs2
root file system:20080902-asu.stable-rootfs.jffs2

I guess last time it's because did now flash properly, because after reflash it dissapear the problem
Does not show up unknown now, thanks!

comment:25 Changed 6 years ago by will

  • Component changed from Distro to Settings

comment:26 Changed 6 years ago by will

  • Component changed from Settings to Distro

comment:27 in reply to: ↑ 4 ; follow-up: ↓ 28 Changed 6 years ago by chenna

I have flashed the device with Om2008.8.uImage.bin & Om2008.8.rootfs.jffs2 available at http://downloads.openmoko.org/releases/Om2008.8/.

I could not find the file /etc/volatives.cache but I could find /etc/volatile.cache and deleted this file and rebooted. But still I see wIFI unknown.

I could not locate openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2.

Please share the working image for WIFI, USB networking and Blue tooth.

Replying to mattt:

Just in the interest of completeness, I reflashed the old rootfs...

openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2
still using the 20080808 kernel.

wifi works
usb works
carrier is detected.

So I don't think it's the kernel.
And it isn't he hardware.

comment:28 in reply to: ↑ 27 ; follow-up: ↓ 29 Changed 5 years ago by think-free

Replying to chenna:

I have flashed the device with Om2008.8.uImage.bin & Om2008.8.rootfs.jffs2 available at http://downloads.openmoko.org/releases/Om2008.8/.

I could not find the file /etc/volatives.cache but I could find /etc/volatile.cache and deleted this file and rebooted. But still I see wIFI unknown.

I could not locate openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2.

Please share the working image for WIFI, USB networking and Blue tooth.

Replying to mattt:

Just in the interest of completeness, I reflashed the old rootfs...

openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2
still using the 20080808 kernel.

wifi works
usb works
carrier is detected.

So I don't think it's the kernel.
And it isn't he hardware.

Hi !
Same here, removing the file /etc/volatile.cache didn't change any think :/
Setting up a wireless connection by hand worked for me ( iwconfig eth0 essid "MyEssid?", ifconfig eth0 192.168.1.155/24, route add default gateway 192.168.1.1, echo "nameserver ipOfDnsServer" > /etc/resolv.conf ) but after that the state remain 'unknow' ...

Mofi work for me to setup a connection

comment:29 in reply to: ↑ 28 Changed 5 years ago by think-free

Replying to think-free:

Replying to chenna:

I have flashed the device with Om2008.8.uImage.bin & Om2008.8.rootfs.jffs2 available at http://downloads.openmoko.org/releases/Om2008.8/.

I could not find the file /etc/volatives.cache but I could find /etc/volatile.cache and deleted this file and rebooted. But still I see wIFI unknown.

I could not locate openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2.

Please share the working image for WIFI, USB networking and Blue tooth.

Replying to mattt:

Just in the interest of completeness, I reflashed the old rootfs...

openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2
still using the 20080808 kernel.

wifi works
usb works
carrier is detected.

So I don't think it's the kernel.
And it isn't he hardware.

Hi !
Same here, removing the file /etc/volatile.cache didn't change any think :/
Setting up a wireless connection by hand worked for me ( iwconfig eth0 essid "MyEssid?", ifconfig eth0 192.168.1.155/24, route add default gateway 192.168.1.1, echo "nameserver ipOfDnsServer" > /etc/resolv.conf ) but after that the state remain 'unknow' ...

Mofi work for me to setup a connection

UPDATE : mofi refuse working too ... only connection "by hand" works, after a connection with iwconfig, ... mofi will work but the state remain 'unknow' in setting , i don't know if it's the same problem for that i tell you here, hope it help

comment:30 Changed 5 years ago by marek

  • HasPatchForReview unset

This bug has been closed as the issue was fixed. Don't hesitate opening a new bug if it seems unlikely that this is the same problem. Before, you could not connect at all because hald did not find any wifi hardware. You are able to connect manually which indicates hald works as expected. No need to remove /etc/volatile.cache.
If you file a bug *always* mention the image and installed packages used otherwise it is nearly *impossible* to help you. Please read:

I *guess* connman is not installed on your image (Settings relies on connman to connect to a wifi network).

Note: You should not use the settings UI to connect to wifi networks. As so many people experienced difficulties to connect to networks I had a deeper look into the connman network manager sources (settings heavily relies on this network manager to connect to any network). It became apparent that connman is far from being usable. It is at an early stage of development.

The FSO team look at alternatives but that will take a while.

Note: See TracTickets for help on using tickets.