Ticket #1735 (closed defect: invalid)

Opened 6 years ago

Last modified 3 years ago

[u-boot] get different screen.

Reported by: regina_kim Owned by: werner@…
Priority: normal Milestone: Om2008.9
Component: kernel Version: GTA02v5
Severity: major Keywords: boot screen
Cc: zecke@…, testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

kernel : 20080723-asu.stable-uImage.bin
rootfs : 20080804-asu.stable-rootfs.jffs2

step + summary : [u-boot] get different screen.
it shows boot menu when press power button and the other one direct booting up after flash new image.

Attachments

boot_image.png (8.5 KB) - added by will 6 years ago.

Change History

comment:1 Changed 6 years ago by regina_kim

  • Component changed from unknown to System Software

comment:2 Changed 6 years ago by wendy_hung

  • Severity changed from normal to major

Changed 6 years ago by will

comment:3 Changed 6 years ago by will

correct image is attached.

comment:4 Changed 6 years ago by werner

I can't quite make sense of this bug report.

So boot_image.png is what you want to see ? What does the "incorrect"
one look like ? Or is this a request to change the screen image to a
new version ?

comment:5 Changed 6 years ago by will

The incorrect one, (one that we use in the Om 2008.8 release) is an image of 2 colorful starts on a white background.
This particular ticket only addresses switching the (visual) image.

comment:6 Changed 6 years ago by werner

So you want a means to replace the splash screen image on the devices in the
field ? For this, you need to convert the PNG file to a compressed raw frame
buffer content and then flash this into the splash screen partition.

For the conversion, go to svn.openmoko.org/trunk/src/host/splash/ and run
./splashimg.pl boot_image.png | gzip -9 >new_splash.gz

If your update process runs under Linux (OE package ?) you'd then execute
the following commands:

flash_eraseall /dev/mtd4
nandwrite -p /dev/mtd4 new_splash.gz

If you update through DFU, you would:

dfu-util -a splash -R -D new_splash.gz

Note that there's also a copy of the image in the package the factory uses.
You'll want to change that one as well.

Note the NOR also contains a copy of the splash screen. If you generate a
new NOR image with "mknor", just specify the new image with -s boot_image.png,
and it will put the "openmoko" text near the bottom of the screen.

comment:7 Changed 6 years ago by werner

BTW, here's a copy of the compressed framebuffer image:
http://people.openmoko.org/werner/new_splash.gz

comment:8 Changed 6 years ago by regina_kim

  • Milestone changed from Om2008.8 to Om2008.9

comment:9 follow-up: ↓ 10 Changed 6 years ago by regina_kim

i think this issue is misunderstanding between will and us.

attached file by will is different issue with what i reported.

so i will create new ticket for will issues.

thanks werner.

comment:10 in reply to: ↑ 9 Changed 6 years ago by regina_kim

Replying to regina_kim:

i think this issue is misunderstanding between will and us.

attached file by will is different issue with what i reported.

so i will create new ticket for will issues.

thanks werner.

New ticket is #1948

comment:11 Changed 6 years ago by regina_kim

  • Status changed from new to closed
  • Resolution set to invalid

hey werner.

i discover this is not bug.

today wendy ask matt that said because we flashed different u-boot image.

so sorry about that.

let me close this ticket .

please looking into #1948

comment:12 Changed 3 years ago by tcpejcbdig

Note: See TracTickets for help on using tickets.