Ticket #1749 (closed defect: invalid)

Opened 11 years ago

Last modified 11 years ago

Mixer: Amp Spk switch will turn off left headplug

Reported by: kriss Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version:
Severity: major Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

For some reason only the right headphone speaker is working when Amp Spk is enabled. Cold that be a hardware problem due to the fact that a Freerunner only has one speaker?

Linux om-gta02 2.6.24 #1 PREEMPT Wed Jul 23 06:34:19 CEST 2008 armv4tl unknown

Change History

comment:1 Changed 11 years ago by joerg

  • Status changed from new to closed
  • Resolution set to invalid

Speaker and headphones are mutually exclusive by hardware design.
You must not use speaker (=switch on Amp Spk) while headset is plugged in, as hardware can not switch off left headset when speaker is active.
See schematics: http://people.openmoko.org/joerg/schematics/GTA02/Schematics_Freerunner-GTA02_A5-A7cumulative_public_RC0.pdf

closing bug to INVALID.

jOERG

Note: See TracTickets for help on using tickets.