Ticket #1762 (assigned defect)

Opened 6 years ago

Last modified 6 years ago

[illume bar menu] menu will hiding after qt-keypad when creating texts

Reported by: wendy_hung Owned by: zecke
Priority: high Milestone: Om2008.10
Component: Qtopia Version:
Severity: major Keywords:
Cc: testing@…, zecke@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

Summary:
menu will hiding after qt-keypad when creating texts
kernel:20080808-asu.stable-uImage.bin
root file system:20080808-asu.stable-rootfs.jffs2

Steps+current results:
1) open up several apps in illume bar
2) use qt-keypad to create some text like SMS or location tags
3) touch illume bar to show up the menu
4) you can see the menu will hiding after the keypad and can not use the arrow

Reproduceable:
Always

Expected:
menu bar cover the keypad or other solutions can make illume bar use smoothly

Attachments

Screenshot-1.png (22.2 KB) - added by regina_kim 6 years ago.

Change History

comment:1 Changed 6 years ago by raster

  • Status changed from new to closed
  • Resolution set to worksforme

well - asu.dev works. asu stable is far behind .dev now. not really much i can say here... worksforme. (illume shelf is on top of keyboard - keyboard underneath and hidden by shelf, therefor usable...)

comment:2 Changed 6 years ago by wendy_hung

  • Reproducible set to always
  • Status changed from closed to reopened
  • Resolution worksforme deleted
  • Milestone changed from Om2008.8 to Om2008.9

Hi raster, the qt-keypad partially covered by illume bar. I think it's still one part or this bug, can you take a look of this??

kernel:20080826-asu.stable-uImage.bin
root file system:20080828-asu.stable-rootfs.jffs2

Changed 6 years ago by regina_kim

comment:3 Changed 6 years ago by raster

  • Status changed from reopened to closed
  • Resolution set to wontfix

cannot reproduce. keyboard is below the illume shelf (the top bar with the down arrow, remove button and battery etc. gadgets) is on top of the keyboard (keyboard is below it) as intended.

comment:4 Changed 6 years ago by wendy_hung

  • Status changed from closed to reopened
  • Resolution wontfix deleted

Sorry raster, did you follow the step? why for me is always reproducible?
Maybe I did not make myself clear. You have to open at least 4~5 applications, and in creating text section (try type some worlds) open the illume bar than you can see the problem.
The menu bar can cover the keypad, but only the display world line can not. It will cover the application name which in the illume bar, see the attach photo PLEASE.

comment:5 Changed 6 years ago by raster

  • Status changed from reopened to assigned
  • Owner changed from raster to zecke

oooh the COMPOSE window (that lists all the matches in the dictionary). you have to be in the middle of editing a word with the keyboard! that is a separate window to the keyboard window. the keyboard window is below - that one is not.

problem - it's an override-redirect window. it bypasses the window manager. which means e/illume have zero control over it - they know nothing about it. e (the window manager) has been bypassed.

unfortunately.... there isn't a lot e can do about it. not until qpe changes it to be managed. the problem is.. if it changes to be managed - it will be like any normal window and e will want to manage it as such... and that also causes problems. so there isn't much to be done here right now. it's between zecke and me as to what do to - but i can't do a fix (i didn't know it was the compose box - i thought it was the keyboard - which is under the slipshelf of illume and that is fine. it's this extra override-redirect window that covers the application window area that is the problem).

zecke - what do you want to do? if this area was part of the qpe kbd (like the illume one) it wouldn't be a problem. if its override-redirect... it's really hard to do anything as the wm knows nothing of these windows. it cant maintain stacking. if it become managed - we have whole bunch of issues... like a managed window that needs to not have the wm do any special re-sizing and arranging? and right now all windows get this if they are managed... this could replace the softmenu window contents - but then you'd need softmenu for non-qtopia apps too... again. kettle of problems. simplest is not have it override and make it part of the keyboard window and just have the window be bigger. but.. willing to talk.

comment:6 Changed 6 years ago by regina_kim

  • Milestone changed from Om2008.9 to Om2008.10

comment:7 Changed 6 years ago by zecke

  • Status changed from assigned to in_testing
  • Component changed from E - Illume to Qtopia

I have reverted to not bypass the windowmanager. This will hit testing on tuesday.

comment:8 Changed 6 years ago by zecke

  • Status changed from in_testing to assigned

Okay, we need to bypass the windowmanager. I think we will not make it for Om2008.10

Note: See TracTickets for help on using tickets.