Ticket #1764 (closed enhancement: invalid)

Opened 6 years ago

Last modified 6 years ago

[exposure] cannot switch layout on Om 2008.8 keyboard

Reported by: kavol@… Owned by: marek
Priority: normal Milestone: Om2008.9
Component: Qtopia Version:
Severity: normal Keywords: pm
Cc: marek@…, will@…, raster@…, zecke@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Hi.

I just flashed Om 2008.8 and I have found that the keyboard cannot be switched to the "terminal" layout, or any other, making it totally unusable. There was an icon in the top-right corner of the keyboard in the previous snapshot I tried (openmoko-openmoko-qtopia-x11-image-glibc-ipk--20080806-om-gta02.rootfs.jffs2) wchich allowed to change the layout, but it is missing now.

Opening the "Settings", I see nothing relevant to keyboard configuration.

btw, I'd be also interested in making the "terminal" layout default, as I have no use of the current default layout ...

Change History

comment:1 Changed 6 years ago by zecke

  • Owner changed from tick to openmoko-devel
  • Keywords pm added
  • Component changed from Assassin to System Software
  • Status changed from new to assigned

Tick is not the owner of the bug, putting that into System Software and adding the pm keyword so will sees the bug.

comment:2 Changed 6 years ago by will

  • Cc marek@… added

marek,

is it possible to collect the different keyboards to switch around in exposure? just like we are doing with profiles?

comment:3 Changed 6 years ago by marek

  • Status changed from assigned to accepted
  • Cc will@…, raster@… added
  • Component changed from System Software to Exposure
  • Owner changed from openmoko-devel to marek
  • Type changed from defect to enhancement

Sure, we can do that.
How do I find out what keyboards are currently installed and how do I switch between keyboards ? Raster, can you help me with that ?

comment:4 Changed 6 years ago by olberger

comment:5 Changed 6 years ago by marek

  • Severity changed from critical to normal

Sorry, but this is a workaround and does not answer my questions.

comment:6 Changed 6 years ago by raster

illume's own config panel/dialog supoprts flipping keyboards. as illume doesnt directly integrate qith qpe - but expects system config to drive it, it offers the choices of:

no keyboard (as such qpe's keyboard takes over here and its' he default config in ASU).
internal default keyboard (illume's own keyboard with kbd layout files etc.)
... a list of other external keyboards ...

the list of external keyboards is generated from the system .desktop file list. if the .desktop has "Keyboard" in its categories lise - it will get listed in this dialog. E(illume) will exec the keyboard for you on login or when config changes (and close the previous process if there was one).

although as such - this config dialog is not supported by design in ASU, so i make no guarantees on it as i really haven't focused on it or used it beyond helping do development. there are dbus calls to swizzle with the virtual keyboard too. keyboard can be "none" "internal" or some .desktop file - eg "mykeyboard.desktop".

comment:7 Changed 6 years ago by marek

  • Summary changed from cannot switch layout on Om 2008.8 keyboard to [exposure] cannot switch layout on Om 2008.8 keyboard

comment:8 Changed 6 years ago by will

  • Cc zecke@… added
  • Component changed from Exposure to Qtopia

Let's not do this anymore.
There is a manual kbd layout in qtopia that can be used in qt-terminal.
If Holger can confirm that it can be added in, we can change layouts within the options menu.
forget using exposure.

comment:9 Changed 6 years ago by will

  • Milestone set to Om2008.9

comment:10 Changed 6 years ago by will

  • Status changed from accepted to closed
  • Resolution set to invalid

Since we won't do this in exposure, created a new ticket:

https://docs.openmoko.org/trac/ticket/1820

comment:11 Changed 6 years ago by kavol@…

Hi guys. Thanks for looking into this. The workaround works for me, however I am looking forward for the solution of ticket #1820.

Note: See TracTickets for help on using tickets.