Ticket #1778 (closed defect: worksforme)

Opened 6 years ago

Last modified 6 years ago

keyboard on 2008.8 is almost unusable

Reported by: billk Owned by: zecke
Priority: highest Milestone:
Component: unknown Version: Om2008.8
Severity: major Keywords: keyboard
Cc: yorick Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

This keyboard is extremely frustrating to use for simple tasks like typing in a terminal, making notes or any text work.

Can you please provide one or more of:

  1. the ability to turn off predictive text (doesnt well work anyway)
  2. an alternative multitap keyboard
  3. a full qwerty keyboard (a usable one like that in the FSO, or the matchbox one.)

Note that I have not seen one complimentary comment yet about this, but lots of griping on the mailing lists!

Change History

comment:1 Changed 6 years ago by olberger

  • Type changed from enhancement to defect

Would that help : http://wiki.openmoko.org/wiki/ASU_Keyboard_Toggle#Reactivating_the_keyboard_toggle_under_ASU ?

Didn't try it myself : seems too hackish for time being.

Oh, and this is a defect, useability-wise, in particular for non-english speakers : sending an SMS in french is almost impossible :(

comment:2 follow-up: ↓ 3 Changed 6 years ago by olberger

  • Blocked By 1778 added

At reading https://docs.openmoko.org/trac/ticket/1778 I tend to understand that this is a design decision of the product manager that lead to that situation.

Hence, I guess it may be solved if ticket 1778 was "solved".

comment:3 in reply to: ↑ 2 ; follow-up: ↓ 5 Changed 6 years ago by olberger

  • Blocked By 1654 added; 1778 removed

Replying to olberger:

At reading https://docs.openmoko.org/trac/ticket/1778 I tend to understand that this is a design decision of the product manager that lead to that situation.

Hence, I guess it may be solved if ticket 1778 was "solved".

Uh... wrong copy/paste. I meant tocket #1654 in the 2 above. Sorry.

comment:4 Changed 6 years ago by olberger

  • Blocked By 1654 removed

(In #1654) There are lots of complaints about this on the users side.

We paid for the device, we're concerned, I guess we can ask for its reopening.

comment:5 in reply to: ↑ 3 ; follow-up: ↓ 6 Changed 6 years ago by billk

Replying to olberger:

Replying to olberger:

At reading https://docs.openmoko.org/trac/ticket/1778 I tend to understand that this is a design decision of the product manager that lead to that situation.

Hence, I guess it may be solved if ticket 1778 was "solved".

Uh... wrong copy/paste. I meant tocket #1654 in the 2 above. Sorry.

If you read the title of this bug, you will see it has nothing to do with showing/hiding the keyboard which is the ticket you are referring to!

BillK

comment:6 in reply to: ↑ 5 ; follow-up: ↓ 8 Changed 6 years ago by olberger

Replying to billk:

If you read the title of this bug, you will see it has nothing to do with showing/hiding the keyboard which is the ticket you are referring to!

BillK

With the ability to show the dialog which allows starting a qwerty keyboard, it would become less unusable :

  1. a full qwerty keyboard (a usable one like that in the FSO, or the matchbox one.)

So I guess "fixing" #1654 would help a great deal...

Still it wouldn't help a lot wrt the fact that dictionary is english and you may want to write in other languages for instance.

comment:7 Changed 6 years ago by olberger

  • Blocked By 1654 added

comment:8 in reply to: ↑ 6 ; follow-up: ↓ 9 Changed 6 years ago by olberger

Replying to olberger:

Replying to billk:

If you read the title of this bug, you will see it has nothing to do with showing/hiding the keyboard which is the ticket you are referring to!

BillK

With the ability to show the dialog which allows starting a qwerty keyboard, it would become less unusable :

  1. a full qwerty keyboard (a usable one like that in the FSO, or the matchbox one.)

So I guess "fixing" #1654 would help a great deal...

Having just tested the "opkg install illume-config" workaround for #1654, I understand better now that it indeed doesn't address the problem of the full qwerty keyboard missing.
It is a bit more useable as the qwerty keyboard can appear right away at a single tap on the "qwerty" button in the top row, but then, the rest of its limitations are still there.

We indeed need "a full qwerty keayboard", even if it's easier to make it appear/disappear.

comment:9 in reply to: ↑ 8 Changed 6 years ago by billk

  • Blocked By 1654 removed

Replying to olberger:

Replying to olberger:

Replying to billk:

If you read the title of this bug, you will see it has nothing to do with showing/hiding the keyboard which is the ticket you are referring to!

BillK

With the ability to show the dialog which allows starting a qwerty keyboard, it would become less unusable :

  1. a full qwerty keyboard (a usable one like that in the FSO, or the matchbox one.)

So I guess "fixing" #1654 would help a great deal...

Having just tested the "opkg install illume-config" workaround for #1654, I understand better now that it indeed doesn't address the problem of the full qwerty keyboard missing.
It is a bit more useable as the qwerty keyboard can appear right away at a single tap on the "qwerty" button in the top row, but then, the rest of its limitations are still there.

We indeed need "a full qwerty keayboard", even if it's easier to make it appear/disappear.

Ive removed the block you entered. Please do not put blocks on bugs you do not understand. That bug is irrelevant and from a version WEEKS ago. The bug as it is entered here is that that 2008.8 does not have a keyboard that is usable for anything other than english SMS. If you wish to raise something about a keyboard switcher, please raise a bug to detail THAT problem. In the meantime, I hope you have not confused people so much they ignore this bug.

BillK

comment:10 Changed 6 years ago by Yorick

  • Cc yorick added

I agree,

Since 2008.8 and the installer are all about freedom, there should be an easy way to "free our keyboard". To replace the default keyboard with a full querty one, or be able to turn of predictive text, or be able to just toggle between different keyboard with the button that is already provided.

comment:11 in reply to: ↑ description Changed 6 years ago by zecke

Replying to billk:

This keyboard is extremely frustrating to use for simple tasks like typing in a terminal, making notes or any text work.
Can you please provide one or more of:

  1. the ability to turn off predictive text (doesnt well work anyway)

Well, press and hold, select the char you want. Exact input is possible. We have five "boards" in the keyboard. If you miss any character one can add a "geek" board. Also install a word book of your language to get prediction for that. Test the prediction with english text, it is pretty good.

  1. a full qwerty keyboard (a usable one like that in the FSO, or the matchbox one.)

It does not fit on the screen and will not be usable with a finger/thumb. We want to have a keyboard that is usable with a thumb. I can write german SMS during a taxi drive with the current keyboard, I couldn't do this with the old one.

comment:12 follow-ups: ↓ 15 ↓ 16 Changed 6 years ago by zecke

  • Status changed from new to closed
  • Component changed from Qtopia to unknown
  • Resolution set to worksforme
  • Milestone OM-2008.8 deleted

Okay guys. This is way too emotional to deal with. I mailed to community mailinglist about the keyboard posse some time ago. Please re-read that.

Rule of thumb. One issue one bug:

  • The prediction isn't working for Esperanto? The prediction is only as good as the word book installed. As there is no wordbook for esperanto installed... If you want to help provide gutenberg text for your language so one can create wordbooks and put them in the feed. But by all means file a new bug report for that.
  • You miss keys from any boards. Say which keys you are missing and we can take a look. But file a new bug report.
  • You need manual switching, file a new bug (but there is one already).
  • You want to switch between multiple keyboard providers? Well, see the community mailinglist why this isn't the case... But feel free to file a separate bug for that.

comment:13 follow-up: ↓ 14 Changed 6 years ago by apm

If people are expected to accept the above as answers, then please provide direct links to the community-list mails you mention.

comment:14 in reply to: ↑ 13 Changed 6 years ago by olberger

Replying to apm:

If people are expected to accept the above as answers, then please provide direct links to the community-list mails you mention.

+1

comment:15 in reply to: ↑ 12 Changed 6 years ago by olberger

Replying to zecke:

  • You miss keys from any boards. Say which keys you are missing and we can take a look. But file a new bug report.

Looks like : #1795 (may not be limitative)

comment:16 in reply to: ↑ 12 Changed 6 years ago by olberger

Replying to zecke:

  • You want to switch between multiple keyboard providers? Well, see the community mailinglist why this isn't the case... But feel free to file a separate bug for that.

I guess that #1800 would fit here.

comment:17 in reply to: ↑ description Changed 6 years ago by olberger

Replying to billk:

  1. a full qwerty keyboard (a usable one like that in the FSO, or the matchbox one.)

See http://wiki.openmoko.org/wiki/Om2008.8_Keyboard#Using_the_Full_Qwerty_keyboard for a workaround.

Note: See TracTickets for help on using tickets.