Ticket #1783 (closed defect: community)

Opened 9 years ago

Last modified 5 months ago

openmoko-messages segfaults immediately with a GTK error

Reported by: dingman Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: current svn head
Severity: critical Keywords: sms segfault openmoko-messages
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

openmoko-messages is failing to start, making it impossible to view or send SMS messages. It is installed from the latest daily -devel snapshot a few days ago (20080807?) and opkg-updates to the latest version as of now.

When launched from the terminal, STERR shows:


(openmoko-messages:1663): Gtk-WARNING : gtk_widget_size_allocate(): attempt to allocate widget with width -11 and height -11
Got path /org/gnome/evolution/dataserver/calendar/filehome_rootevolution_memos_local_system for new calendar

(openmoko-messages:1663): Gtk-WARNING : gtk_widget_size_allocate(): attempt to allocate widget with width -11 and height -11

(openmoko-messages:1663): Gtk-WARNING : gtk_widget_size_allocate(): attempt to allocate widget with width -11 and height -11

(openmoko-messages:1663): Gtk-WARNING : gtk_widget_size_allocate(): attempt to allocate widget with width -11 and height -11

(openmoko-messages:1663): Gtk-WARNING : gtk_widget_size_allocate(): attempt to allocate widget with width -11 and height -11

(openmoko-messages:1663): Gtk-WARNING : gtk_widget_size_allocate(): attempt to allocate widget with width -11 and height -11
Segmentation fault


This is from the terminal *on* the FreeRunner?, not SSH with X forwarding.

Change History

comment:1 Changed 9 years ago by rhk

Confirm here. Running 2007.2 with latest updates. I get the same messages both started over ssh -X and locally on freerunner. Might have something to do with https://docs.openmoko.org/trac/ticket/1212. I don't know why would I have an empty contact.

comment:2 Changed 9 years ago by rhk

Don't know if this is the reason behind this bug bug when I try to read the SMS:s with libgsmd-tool it segfaults:

root@om-gta02:~# libgsmd-tool -m shell
libgsm-tool - (C) 2006-2007 by Harald Welte and OpenMoko?, Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

O
# Power-On
EVENT: PIN request (type='SIM PIN') Please enter SIM PIN: 0000
sending pin='0000', newpin=
Modem power-up failed: 11
PIN accepted!
sl
# List SMS
Segmentation fault
root@om-gta02:~#

comment:3 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community

comment:4 Changed 5 months ago by RoberMync

Cialis 10 Mg Vademecum <a href=http://viag1.xyz/viagra-100mg.php>Viagra 100mg</a> Priligy Rite Aid Over The Counter Motilium <a href=http://viag1.xyz/cheap-viagra-usa.php>Cheap Viagra Usa</a> Viagra En Murcia Xl Pharmacy India <a href=http://viag1.xyz/viagra-price.php>Viagra Price</a> Zithromax Atrial Fibrillation Cheap Brand Cialis Online <a href=http://cial1.xyz/get-cheap-cialis-online.php>Get Cheap Cialis Online</a> Buy Van Tin Without Prescription Levitra Abbigliamento On Line <a href=http://zol1.xyz/order-zoloft-online-usa.php>Order Zoloft Online Usa</a> Tomar Viagra Anos Zithromax Sales <a href=http://cial5mg.xyz/order-cialis-online-usa.php>Order Cialis Online Usa</a> Cialysis Cialis 5 Mg Mutuabile <a href=http://viag1.xyz/viagra-cheap-online.php>Viagra Cheap Online</a> Cialis E Propecia Cialis Prix Pharmacie <a href=http://doxycycline.ccrpdc.com/mail-order-vibramycin.php>Mail Order Vibramycin</a> Predison No Scrip How To Get Viagra In Indiana <a href=http://zol1.xyz/order-zoloft-online.php>Order Zoloft Online</a> Propecia Online Buy Canada Healthcare Mall <a href=http://inderal.ccrpdc.com/buy-cheap-propranolol.php>Buy Cheap Propranolol</a> Tagliare Proscar Propecia Cali'S Without Prescription <a href=http://xenical.ccrpdc.com/buy-xenical-online.php>Buy Xenical Online</a> Suhagra 100 Free Shipping buy accutane online legit <a href=http://cial1.xyz/buy-cialis.php>Buy Cialis</a> Zithromax Suspension Dosage Viagra Bestellen Deutschland <a href=http://cialis.ccrpdc.com/cialis-tadalafil.php>Cialis Tadalafil</a> Cialis De 5 Mg

Note: See TracTickets for help on using tickets.