Ticket #1787 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

opkg crashes if PATH is unset

Reported by: chgros Owned by: tick
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords: HasPatch
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

It's annoying because in certain configuration busybox's PATH is not exported (e.g. when I use screen). Plus crashes should just not happen ;)

It's easy to fix, see attached patch.

Attachments

opkg_cmd.c.diff (978 bytes) - added by chgros 6 years ago.

Change History

Changed 6 years ago by chgros

comment:1 Changed 6 years ago by zecke

  • Cc tick@… added

Asking tick to take a look. Please accept the bug and take a look at the patch, apply or provide feedback.

comment:2 Changed 6 years ago by zecke

  • Keywords HasPatch added

comment:3 Changed 6 years ago by tick

  • Owner changed from openmoko-devel to tick
  • Status changed from new to accepted
  • Cc tick@… removed

oh~ God
Sorry I didn't notice this patch.

This looks good to me.

Sorry and Thank you
Tick

comment:4 Changed 6 years ago by tick

  • Status changed from accepted to in_testing

commit as 4613

comment:5 Changed 6 years ago by tick

  • Status changed from in_testing to closed
  • Resolution set to fixed

switch to fixed, since no one complains.
It's work for me.

Thanks Chgros,
Tick

Note: See TracTickets for help on using tickets.