Ticket #1788 (closed enhancement: fixed)

Opened 11 years ago

Last modified 10 years ago

Maps - Please do not store offline data in /tmp

Reported by: Sjors Owned by: jeremy
Priority: normal Milestone: Om2008.8
Component: Locations Version: Om2008.8
Severity: normal Keywords: maps offline
Cc: olv@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I have scrolled around the map in Locations [0] to download some map data of places I plan to go to. That way I can use the map when I am offline.

However, the data is stored in /tmp/diversity-maps/osm which gets deleted upon reboot.

Temporary workaround: tar all tiles and move them to a save place, copy them back after reboot.

Proposed solution: store files in a permanent location.

If the tiles are stored in a permanent location, then the Locations application should probably have a preference menu where you can allocate a maximum number of megabytes.

[0]http://wiki.openmoko.org/wiki/Om2008.8_Locations

Change History

comment:1 Changed 11 years ago by marek

  • Status changed from new to assigned
  • Owner changed from marek to jeremy

I think the main problem is that the disk space is fairly limited. Jeremy can tell you more about that - he is the author of locations.

comment:2 Changed 11 years ago by noha

In tangogps it works ok. /tmp is default but you can change configuration to point the cache dir to your preferred location

comment:3 Changed 11 years ago by avanc

The Locations package provides om-locations-map-pack to store the downloaded data to create a map package:
Create offline Maps

comment:4 Changed 10 years ago by jeremy

  • Cc olv@… added

Yea, if you want to save downloaded maps, you can use Create offline Maps. That's the way for it. For now the UI has no ways to configure it.

comment:5 Changed 10 years ago by olv

  • Status changed from assigned to closed
  • Resolution set to fixed

The storage path is configurable through the config file since 2c362f86b598cd35a63977cb0e6d92d8883d932d on 0.2 branch. See
http://wiki.openmoko.org/wiki/Om_2008.8_Locations#Use_SD_Card_for_Tile_Storage_.28git_only.29

More work (limiting the total size used) is needed befre the path can be default to nand flash.

Note: See TracTickets for help on using tickets.