Ticket #1789 (closed defect: fixed)

Opened 10 years ago

Last modified 9 years ago

2008.8 screen blanks and refuses to wakeup

Reported by: billk Owned by: openmoko-kernel
Priority: highest Milestone: Om2008.10
Component: kernel Version: Om2008.8
Severity: major Keywords: wakeup screen display sleep suspend
Cc: raster@… Blocked By:
Blocking: #1991 Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I have had the FR go into blank screen a number of times and refuse to wakeup. Its not suspended as usb networking still works. Trying to restart the xserver hangs. If I press the power button briefly, nothing happens. Same if I hold it for a second or two. At ~ 10 seconds it will shutdown - sometimes.

Change History

comment:1 Changed 10 years ago by montgoss

I can confirm this bug. It happened to me earlier today.

comment:2 follow-up: ↓ 3 Changed 10 years ago by zecke

  • Cc raster@… added
  • Milestone OM-2008.8 deleted

This also happens with images from asu.dev. So something in the system (ompower, illume) get confused about what state the backlight should have.

Making sure raster sees it and removing the milestone as this is used by our ProductManager?.

comment:3 in reply to: ↑ 2 Changed 10 years ago by queen6

Same problem here. Most of the times I just need to remove the battery and restart the phone.

comment:4 Changed 10 years ago by regina_kim

  • Milestone set to Om2008.9

comment:5 Changed 10 years ago by regina_kim

  • Owner changed from openmoko-devel to openmoko-kernel
  • Component changed from unknown to System Software

comment:6 Changed 10 years ago by octavsly

I just had the same problem with the releases at:
I need to remove the battery :-(

http://downloads.openmoko.org/releases/Om2008.8-update/
Om2008.8-gta02-20080903.uImage.bin    16-Sep-2008 00:31  1.8M  
Om2008.8-gta02-20080916.rootfs.jffs2  16-Sep-2008 00:31   68M  
gta02v5_and_up-u-boot.bin             16-Sep-2008 00:31  211K  

comment:7 Changed 10 years ago by will

  • Milestone changed from Om2008.9 to Om2008.10

comment:8 Changed 10 years ago by zecke

#1884 and #1991 might be related. This looks a lot like a duplicate of #1991.

comment:9 Changed 10 years ago by regina_kim

hey billk ~

could you check it still happen ?

also check weather related what holger mention tickets.

comment:10 Changed 10 years ago by BillK

It does, but only very occasionally, and usually when the phone has not registered (a separate problem? - bug #2012)

Can sometimes happen if I pull usb power soon after the desktop dsplay shows up on bootup, or if I suspend the phone (power button pressed) when not registered, the screen wont wake up - not sure if its even suspended. Killing apm brings it back, but must reboot immediately anyway as it always crashes messily within a few minutes.

However, if the phone boots up properly and registers there is no problem.

Along with my other issues, its all starting to sound like race conditions dependent on the GSM area.

BillK

comment:11 Changed 10 years ago by john_lee

  • Blocking 1991 added

(In #1991) I will add similiar bugs here so it's easier to track.

comment:12 Changed 9 years ago by andy

  • HasPatchForReview unset

Is this issue still seen with recent 2.6.29 kernels?

comment:13 Changed 9 years ago by queen6

Since the time I've switched to andy-tracking (2.6.28-rcX) which was few months ago - I can no longer reproduce this issue.

comment:14 Changed 9 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

Great, thanks for the feedback.

Note: See TracTickets for help on using tickets.