Ticket #1792 (closed defect: fixed)

Opened 11 years ago

Last modified 19 months ago

SMS not received properly during suspend

Reported by: thomasb Owned by: zecke
Priority: normal Milestone: Om2008.9
Component: Qtopia Version: Om2008.8
Severity: normal Keywords:
Cc: erin_yueh@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I'm running Om2008.8 on my Freerunner and have problems receiving SMS messages during suspend. I can reproduce this by suspending my Neo and sending a test message from another phone. I immediately get a receipt confirmation on the other phone.

Expected result: Neo should wake up on receiving SMS (or at least show me the SMS immediately when I wake it up manually)

Actual result: Neo keeps sleeping. After I wake it up manually, no sign of incoming SMS. Some minutes later, I manually start up the Messages application, and only now the Neo starts vibrating and the received SMS shows up.

I'll attach a log file.

To me it looks like the Neo's GSM subsystem receives the message, but doesn't wake up the phone and instead saves the message into the SIM card's internal memory. The SMS then only shows up when Qtopia feels like asking the SIM card for messages the next time (e.g., when starting up the Messages application).

Attachments

sms-during-suspend.log.gz (3.8 KB) - added by thomasb 11 years ago.
logfile (actual message contents scrubbed; the first 4 messages are old ones still stored on the SIM card)
network-registration.log (14.5 KB) - added by thomasb 11 years ago.
Log of network registration (private data scrubbed; timestamps are wrong because the clock wasn't set right)
om2008.8-zecke-testing-11h.log (147.4 KB) - added by thomasb 11 years ago.
Log of OM2008.8-testing running for 11 hours without successfully registering to the network

Change History

Changed 11 years ago by thomasb

logfile (actual message contents scrubbed; the first 4 messages are old ones still stored on the SIM card)

comment:1 Changed 11 years ago by zecke

  • Owner changed from openmoko-devel to zecke
  • Version set to OM-2008.08
  • Component changed from unknown to Qtopia

This sounds like enabling of SMS notification did fail on startup. Could you try to get me the logread output after you are registered with the network (before the device suspends) but only if this run shows the issue as well. If I'm right this is related to #1766 and the "No Network" issue.

  • Power the device, register with network
  • login and get the log (logread) and save it somewhere
  • Check if the issue occurs, if that is the case please attach the log (well remove private data...)

comment:2 Changed 11 years ago by thomasb

Looks like you're right, and this is more related to initialization than to suspend.

I just sent myself two test messages, one before and one after a suspend/resume cycle. I got a receipt confirmation for both on the sending phone (though for the first message only after waking up from suspend), but no incoming notification on the Freerunner. Both messages only showed up when manually opening the "Messages" application.

So the problem persists. I'm attaching a log.

PS: Actually, only now I realized that I'm also affected by #1766. Until now making calls, for example, always worked for me when I tried it with OM2008.8.

Changed 11 years ago by thomasb

Log of network registration (private data scrubbed; timestamps are wrong because the clock wasn't set right)

comment:3 Changed 11 years ago by manimal

I get this error as well with Rogers Wireless (in canada).

the phone wakes up, and just sits on the "home" screen.

Even choosing "messages" leaves me with no incoming text.

If I send myself a new text (using another phone, or the online sms sending service they have), I recieve the latest, but the former message just sits in the inbox unread.

I have to send a message and then check the inbox to see if I missed a text.

this is with the latest stable release (2008.8), no development branch used, or any other repos added.

(on a side note, I did have this problem with the stable 2007.2 build, until I flashed to a daily build from buildhost.. seems to be back with this new stable build)

comment:4 follow-up: ↓ 6 Changed 11 years ago by zecke

The output of logread until after the resume would be interesting.

comment:5 Changed 11 years ago by manimal

I just upgraded using the "testing" repo that I found here: http://n2.nabble.com/Temporary-testing-and-development-feeds-for-ASU-td723045ef1958.html#a729417

it now awakens the device and notifies me of a new message.

comment:6 in reply to: ↑ 4 ; follow-up: ↓ 7 Changed 11 years ago by thomasb

Replying to zecke:

The output of logread until after the resume would be interesting.

Did you mean me or manimal?

Well, I also tried upgrading to both zecke's "testing" and "dev" feeds, but it didn't help. The problem persists, and the logs look pretty much the same to me as before. So there still seems to be a problem with initializing my SIM card.

I also tried vanilla Qtopia from Trolltech again, just to make sure, and there it works. I get notifications of incoming SMSs and the phone wakes up from suspend on incoming messages, too. A glance into the log shows that Qtopia sends an "AT+CNMI" command, which seems to be responsible for enabling SMS notifications. I'v never seen OM2008.8 do that on my phone. I can attach the log from Qtopia, if wanted.

comment:7 in reply to: ↑ 6 Changed 11 years ago by zecke

Replying to thomasb:

Replying to zecke:

The output of logread until after the resume would be interesting.

Did you mean me or manimal?

Go ahead and paste your log. The output of logread, wait long enough to have a long log, make sure to not go into suspend in between. As weird it might sound it might be the same issue as #1766... but I'm waiting for log files.

comment:8 Changed 11 years ago by thomasb

Yes, after reading the latest comments in #1766 it really looks like it could be the same thing. I also never seem to get a "%CSTAT: RDY, 1", not even after several hours.

I let my Freerunner on during last night with suspend disabled, after booting OM2008.8 + zecke-testing feed and entering my PIN. I also sent a test message about 45 mins after startup. I got a receipt confirmation on the sending phone about 30 mins later, but nothing on the Freerunner until I manually opened "Messages" on the next morning (timestamp 19:04:59). "%CSTAT: RDY" never showed up.

Changed 11 years ago by thomasb

Log of OM2008.8-testing running for 11 hours without successfully registering to the network

comment:9 Changed 11 years ago by thomasb

I tested it again with the %CSTAT fix from #1766 (by upgrading to the latest zecke-testing feed) and this seems to have fixed it for me: On incoming SMS the device wakes up from suspend and I get a notification. Great! :-)

comment:10 Changed 11 years ago by zecke

  • Status changed from new to in_testing

Okay, I'm a bit slow but my -dev and -testing feed should have a possible bugfix (for a problem I created by trying to fix another one...).

comment:11 Changed 11 years ago by regina_kim

  • Milestone set to Om2008.9

comment:12 Changed 11 years ago by thomasb

Ok, since I applied that potential bugfix I haven't observed this issue any more: I have been happily sending and receiving SMS during the last week, got proper notifications, and the device woke up on incoming messages as expected. For me it looks like this is fixed.

comment:13 Changed 11 years ago by erin_yueh

hi Regina,

like #1587, could you please verify this bug with 3 latest daily build image? if still good, we may close this bug. if still happens, please attach the log file. We can analyze the network problem from log.

comment:14 Changed 11 years ago by erin_yueh

  • Cc erin_yueh@… added

comment:15 Changed 11 years ago by regina_kim

Erin. sure. let me test today

comment:16 Changed 11 years ago by regina_kim

rootfs : Om2008.8-gta02-20080902.rootfs.jffs2
kernel : Om2008.8-gta02-20080826.uImage.bin

i tested with this images.

Device wakes up from suspend when press power button but still screen is black(blank time) at the moment.(#1952)
so even get SMS we can not recognize weather it works well or not.
we want test after #1952 issue fixed.

comment:17 follow-up: ↓ 18 Changed 11 years ago by regina_kim

hey thomasb
can you test this ticket again weather is happen still ?
what about get sms when not suspend status ??

comment:18 in reply to: ↑ 17 Changed 11 years ago by thomasb

Replying to regina_kim:

hey thomasb
can you test this ticket again weather is happen still ?

Sure. I tested it again today with the most recent packages from the 2008.8-update feed.

what about get sms when not suspend status ??

It works perfectly, both when on suspend and when not suspended: The device wakes up (if suspended), it shows a notification on screen, it vibrates and it beeps.

In the three weeks since the fix for #1776 was applied I have observed this issue exactly once, but I wasn't able to reproduce it. Might as well have been due to normal network delay when delivering the SMS. I will report back if I ever see it again.

Until then, I regard this as fixed for me.

comment:19 Changed 11 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

tested with the image below:
kernel:20080903-asu.stable-uImage.bin
root file system:20080916-asu.stable-rootfs.jffs2

It works well now, let me close this ticket. :)

comment:20 Changed 19 months ago by MiguAnydaY

Wie Wirkt Viagra Am Schnellsten [url=http://cialtobuy.com ]cialis buy onlineurl Kamagra 200mg Oral Jelly
Viagra Brand Vs Generic Levitra 10 Mg Costo Online Xenical 120 Mg Acheter
Zithromax Dosage For Gonorrhea <a href=http://cialtobuy.com >cialis</a> Atomoxetine Costs 50 Mg

comment:21 Changed 19 months ago by MiguAnydaY

Buy Viagra Online No Prescription [url=http://cialtobuy.com ]cialisurl Acheter Tadalafil Canada
Amoxicillin Normal Dose
Cialis Pagamento Postepay <a href=http://cialtobuy.com >cialis online</a> Levaquin Purchasing Price With Next Day Delivery

Note: See TracTickets for help on using tickets.