Ticket #1798 (closed defect: fixed)

Opened 11 years ago

Last modified 10 years ago

No pin-dialog appears (the second)

Reported by: Rorschach Owned by: zecke
Priority: highest Milestone:
Component: unknown Version: Om2008.8
Severity: critical Keywords:
Cc: testing@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

So because the other thread (https://docs.openmoko.org/trac/ticket/1765) was hijacked by people unable to read I opened a new one.

Before you post any comment, any long, just anything READ THIS:
This bugreport IS ABOUT the pin dialog does not appear and so you can't give in your pin and so gsm is not working.

It IS NOT ABOUT having any other problems with gsm, like can't recieve/make calls, it's not about bad connections,..

Please don't hijack this bugreport again. Please!

I'm willing to do any kind of debugging if you could tell me where to look at, I have no single idea where the problem is because until now noone could tell me what produces the pin-dialog and where is it executed.

Change History

comment:1 Changed 11 years ago by olberger

Why don't you stay with #1765 (btw, you can just refer other tickets with the '#' sign in trac bug-tracker) ?

Many others just experience the very same thing as you do... I expect that people qualified enough to help will be able to ignore any irrelevent comments.

I'd rather close this one as duplicate but will restrain, as there is enough noise already.

Btw, exactly the same behaviour here. Sometimes I noticed that the pin dialog would still be "there" but probably hidden behind another window, as I was able to find it in the list of running apps (see : https://docs.openmoko.org/trac/ticket/1765#comment:22)... but sometimes it won't show up at all.

Hope this helps.

comment:2 Changed 11 years ago by Rorschach

zecke@openmoko closed #1765 telling one should open a new one. It was opened again by another one and I think it's pretty confusing if everyone starts posting comments totally unrelated to the problem of the filed bug.

Could you tell me how the name of the process of the pin-dialog is?

comment:3 Changed 11 years ago by apm

No one hijacked your ticket. We all have the same problem. First symptom is that the PIN-dialog doesn't appear. The difference is that we tried to debug the problem and found it was more complex than that.

comment:4 follow-up: ↓ 5 Changed 11 years ago by Rorschach

Problem has finally been identified and workaround is available. Just follow this thread on the ML: http://lists.openmoko.org/pipermail/community/2008-August/026096.html

comment:5 in reply to: ↑ 4 Changed 11 years ago by Anasazi

Replying to Rorschach:

Problem has finally been identified and workaround is available. Just follow this thread on the ML: http://lists.openmoko.org/pipermail/community/2008-August/026096.html

The described workaround does *not* work for me. I tried 5 times now and *never* got a pin dialog (previously once in about 10 tries). So please continue to analyze :-)

comment:6 Changed 11 years ago by Rorschach

That's bad to hear :( For me it works like a charm. Between 5-20 seconds after X started I now get everytime a pindialog.

comment:7 follow-up: ↓ 14 Changed 11 years ago by zecke

  • Status changed from new to in_testing
  • Version changed from GTA02v5 to Om2008.8
  • Milestone Om2008.8 deleted

Okay what about adding this http://people.openmoko.org/zecke/qtopia-testing/ to your feed and trying the Qtopia packages?

Also make sure opkg list_installed | grep gsmd | wc -l says 0.

comment:8 Changed 11 years ago by Rorschach

okay I added the feed and upgraded my packages and the problem seems to be fixed with this :) thanks zecke for your work on this!

comment:9 Changed 11 years ago by Anasazi

ok, with that feeds it works nice, thanks a lot!

comment:10 Changed 11 years ago by wendy_hung

  • Cc testing@… added
  • Milestone set to Om2008.8

kernel:20080808-asu.stable-uImage.bin
root file system:20080814-asu.stable-rootfs.jffs2

Reboot more then 6 times, every time will show up dialog to ask you the pin number.
But not immediately, it's around 20~30 sec. We think it should show up pin-dialog before goes to Home screen just like the usual phone that we use, Will, what do you think?

comment:11 Changed 11 years ago by will

Yes,
PIN dialogue should really be the first thing you see before home screen.

comment:12 Changed 11 years ago by wendy_hung

  • Owner changed from openmoko-devel to zecke
  • Status changed from in_testing to assigned

comment:13 Changed 11 years ago by zecke

  • Status changed from assigned to in_testing
  • Milestone Om2008.8 deleted

Guys, this bug is about PIN Dialog not coming up at all. If it comes up this technical issue is resolved.

If we want to be like other phones and have the PIN Dialog come up first before you can do anything at all (making the phone part the ueber important thing on your device) then this is a complete different issue. This involves the question where do we want to show the PIN Dialog? Should it be illume as we move more stuff to EFL? This also implies changes to the startup system to launch X and qpe early in the process to decrease the time people have to wait. This a whole new issue and involves quite some people to find a good solution. So please file a new bug for that.... :)

comment:14 in reply to: ↑ 7 Changed 11 years ago by Peetrus

Replying to zecke:

Okay what about adding this http://people.openmoko.org/zecke/qtopia-testing/ to your feed and trying the Qtopia packages?

Also make sure opkg list_installed | grep gsmd | wc -l says 0.

Pin dialog comes up every time now after half a minute.

comment:15 Changed 10 years ago by wendy_hung

  • Status changed from in_testing to closed
  • Resolution set to fixed

Let me close this, thank you Zecke!

Note: See TracTickets for help on using tickets.