Ticket #1799 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

sd card changes dev entry after suspend/resume

Reported by: iad.mike2 Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: GTA02v5
Severity: blocker Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

hi,

i'm using a sd card - after starting up my neo located in /dev/mmcblk1
after suspending and then resuming, the device changed to /dev/mmcblk1p1
then i suspended and resumed again and after this it changed again to /dev/mmcblk2
maybe you can repeat it and every time it steps on point forward

it's a little bit annoying, because i want to use it as my home folder and without sus/res the bat live is to short for daily use...

kernel and image are the ones located in
http://buildhost.openmoko.org/daily/freerunner/200808/20080809/

Attachments

dmesg.txt (15.1 KB) - added by zeroedout 9 years ago.
opkg_installed.txt (46.5 KB) - added by zeroedout 9 years ago.

Change History

comment:1 Changed 9 years ago by iad.mike2

  • Owner changed from tick to openmoko-kernel
  • Component changed from Assassin to System Software

comment:2 in reply to: ↑ description Changed 9 years ago by iad.mike2

kernel and image are the ones located in
http://buildhost.openmoko.org/daily/freerunner/200808/20080809/

forgot to say:
it is a 8gb san disk card

Changed 9 years ago by zeroedout

Changed 9 years ago by zeroedout

comment:3 Changed 9 years ago by zeroedout

I have the same bug and I didn't see logs so there they are. Using kernel from kernel-2.6.24 - 3:2.6.24+gitr117+a1e97c611253511ffc2d8c45e3e6d6894fa03fa3-r2 - with a 4Gb sandisk SD card

comment:4 Changed 9 years ago by andy

You might like to try a later kernel, that one is from ~23 Aug.

Since getting a packaged kernel is a bit uncertain at the moment somehow, here is a "moredrivers" kernel image (no modules) from today to try:

http://people.openmoko.org/andy/uImage-moredrivers-stable_40cdde48c70c8b87.bin

comment:5 Changed 9 years ago by andy

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.