Ticket #1808 (closed defect: fixed)

Opened 10 years ago

Last modified 14 months ago

No accelerometer data

Reported by: Mercury Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: Om2008.8
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I am unable to get accelerometer data. I tried the python script on this page: http://wiki.openmoko.org/wiki/Accelerometer_data_retrieval and I got no output. I also get no output when I run cat /dev/input/event3

I tried upgrading my kernel to this: http://buildhost.openmoko.org/daily/freerunner/200808/20080810/uImage-2.6.24+git32+2438a8c74c495c95f5b78301a44ed8e8d0b267d5-r2-om-gta02.bin and I had the same problem.

Change History

comment:1 Changed 10 years ago by Mercury

The accelerometers seem to be working on some level. I'm suspecting something strange with the kernel.

root@lisa:~# echo 1 > /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/power/wakeup
root@lisa:~# cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump (lying flat on desk)
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 3b
09 84 89 01 00 08 12 94 11 1e 0e 01 00 00 00 00
47 00 e4 00 00 00 00 ff 00 fe 00 00 00 35 00 00
95 25 14 00 00 00 00 00 00 00 00 00 00 00 00 00
root@lisa:~# cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump (perpendicular to desk)
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 3b
09 84 89 01 00 08 12 94 11 1e 0e 01 00 00 00 00
47 00 e4 00 00 00 00 ff 00 d7 00 da 00 02 00 00
95 1a 14 00 00 00 00 00 00 00 00 00 00 00 00 00
root@lisa:~# cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump (flat on desk again)
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 3b
09 84 89 01 00 08 12 94 11 1e 0e 01 00 00 00 00
47 00 e4 00 00 00 00 ff 00 fe 00 01 00 34 00 00
95 25 14 00 00 00 00 00 00 00 00 00 00 00 00 00

Looks like it's able to tell what orientation my phone is in, but the input event interface device gives me nothing.

comment:2 Changed 10 years ago by andy

That isn't quite testing what you might imagine since a different bitbanged implementation is used to service the interrupts for speed.

Is this an A6 or A5 revision device? Have a look in /proc/cpuinfo

Revision : 0350 <== A5 (0360 = A6)

comment:3 Changed 10 years ago by Mercury

A5

comment:4 Changed 10 years ago by Fox Mulder

I have the same problem.
When i use /dev/input/event3 i got no data from the second. But when i use /dev/input/event2 i got the right data from the first sensor.
I have this behaviour since the first software release what came with the freerunner shipped and also with the latest kernel update from today (for 2007.2).
I have the version A5.

comment:5 Changed 10 years ago by Fox Mulder

This is weird. Now after i tested it again, i got data from event3 but no more from event2. Is there some way how i could verify if these sensors are "activated" from the system?

comment:6 Changed 10 years ago by rhk

On my revA5, Tried first the 'gestures' alpha2, then http://wiki.openmoko.org/wiki/Accelerometer_data_retrieval and finally tried hexdump from event2 and event3. No actions at all, also tried two reboots. Running 2007.2 with Linux om-gta02 2.6.24 #1 PREEMPT Wed Aug 13 01:26:23 CEST 2008 armv4tl unknown

uboot has not been upgraded at all.

comment:7 Changed 10 years ago by cedric.berger

I had nothing on hexdump /dev/input/event2
but something on hexdump /dev/input/event3

tried yesterday with 2007.2 (opkg upgraded, 12h ago), twice (rebooting) with 2008.8, and always only bottom accel working

this morning I try with Qtopia distro and both accel work. reboot on 2008.8 and it works... (nothing updated since yesterday)

comment:8 Changed 10 years ago by Fox Mulder

I found out, that i got data from both sensors, when i use the direct access from the sys filesystem when i read the dump data from both sensors like this:

cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump
cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.1/dump

But with /dev/input/event2 and event3 i only got data from one sensor back. So it seems that both sensors work but there is a bug in the code which generates the data for the event2/3 devices.

I hope they also fixed it for the 2007.2 version and not only for 2008.8 and qtopia.
I will try it today after updating to the newest daily build. :)

comment:9 Changed 10 years ago by Mercury

Changing my kernel to the official Om2008.8 one seemed to work for me. I'm not sure what the issue was. I'm not sure if I had the same issue as the 'one works one doesn't' people as well.

Before I upgraded the kernel, I noticed some strange behaviour. I would boot debian off my SD card (using the kernel from flash, because at that time u-boot didn't support SDHC), and it would work under Debian but not when I booted ASU (???)

Oh well, it's in the past for me now :) But I'll leave the ticket open for the rest of you.

comment:10 follow-ups: ↓ 11 ↓ 12 Changed 10 years ago by Yorick

I have the same problem on a fully upgraded 2007.2 and a uboot from a week ago or something:
gestures don't work,
hexdump /dev/input/event2 returns nothing
hexdump /dev/input/event3 returns nothing

cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump and cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.1/dump always return the same thing:
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 3b
84 97 95 11 12 03 03 85 10 db 00 08 00 00 00 00
47 00 e4 00 00 00 00 ff 00 0b 00 d7 00 2c 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

several reboots did not fix anything

comment:11 in reply to: ↑ 10 Changed 10 years ago by Yorick

Replying to Yorick:

I have the same problem on a fully upgraded 2007.2 and a uboot from a week ago or something:
gestures don't work,
hexdump /dev/input/event2 returns nothing
hexdump /dev/input/event3 returns nothing

cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump and cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.1/dump always return the same thing:
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 3b
84 97 95 11 12 03 03 85 10 db 00 08 00 00 00 00
47 00 e4 00 00 00 00 ff 00 0b 00 d7 00 2c 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

several reboots did not fix anything

tested it on a openmok-qtopia-080813 and i got the same results

comment:12 in reply to: ↑ 10 Changed 10 years ago by Yorick

Replying to Yorick:

I have the same problem on a fully upgraded 2007.2 and a uboot from a week ago or something:
gestures don't work,
hexdump /dev/input/event2 returns nothing
hexdump /dev/input/event3 returns nothing

cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump and cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.1/dump always return the same thing:
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 3b
84 97 95 11 12 03 03 85 10 db 00 08 00 00 00 00
47 00 e4 00 00 00 00 ff 00 0b 00 d7 00 2c 00 00
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

several reboots did not fix anything

sorry for my fragmented reports:
cat /sys/devices/platform/spi_s3c24xx_gpio.1/spi0.0/dump does seem to be able to detect orientation
when I rotate the FR the numbers change

comment:13 Changed 10 years ago by Yorick

gta02v5
(we really need an "edit" button, so it's not always nescessary to add a reply)

comment:14 follow-up: ↓ 15 Changed 10 years ago by zecke

  • Version changed from GTA02v5 to Om2008.8
  • Milestone Om2008.8 deleted

Could you test with the latest stable kernel? We had some updates that could have changed that.

comment:15 in reply to: ↑ 14 Changed 10 years ago by Yorick

Replying to zecke:

Could you test with the latest stable kernel? We had some updates that could have changed that.

I tested with the latest kernel: no improvements

comment:16 Changed 10 years ago by andy

There's a major rewrite of some stuff coming in the next day or so around this after Sean McNeil? reported a suspicion about what affected it. But I couldn't really make a story about how this wrong stuff being fixed in that actually made the symptom if all you were doing is sitting there reading the input events. Anyway it is worth trying again when these changes go in.

comment:17 Changed 10 years ago by Yorick

hexdump works for event 2 and 3 with a clean install of Om2008.8-update
I also used openmoko eightball with succes

however,
after installing gestures, only hexdump event 2 works and openmoko eightball doesn't work anymore when I shake it.

comment:18 Changed 10 years ago by Yorick

after removing and once again installing accelges hexdump keeps working in 2008.8-upgraded,

removing gestures (accelges) does not solve it for 2007.2

comment:19 Changed 10 years ago by john_lee

  • Status changed from new to assigned
  • Owner changed from openmoko-devel to openmoko-kernel
  • HasPatchForReview unset
  • Component changed from unknown to System Software

comment:20 Changed 9 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to fixed

This is fixed for a while after a fair amount of suffering by Simon Kagstrom, myself and others in andy-tracking and stable.

comment:21 Changed 14 months ago by RoberMync

Cheap Propecia Online Uk <a href=http://cial5mg.xyz/tadalafil-tablets.php>Tadalafil Tablets</a> Cialis Ohne Rezept Im Ausland Keflex Cost <a href=http://viag1.xyz/sildenafil-20mg.php>Sildenafil 20mg</a> Healthy Men Viagra Offer Where Can I Buy Accutane Yahoo <a href=http://kama1.xyz/where-can-i-buy-kamagra.php>Where Can I Buy Kamagra</a> Where To Buy Lasix Buy Cheap Lasix Online Dapoxetine Chlorhydrate <a href=http://prozac.ccrpdc.com/prozac-cheap.php>Prozac Cheap</a> Kamagra Online Bestellen Legal Mnon Prescription Prednisone <a href=http://zol1.xyz/zoloft-order.php>Zoloft Order</a> Acheter Nolvadex Proviron Clomid Culturiste <a href=http://zol1.xyz/cheap-zoloft-online.php>Cheap Zoloft Online</a> Cialis Drug Interactions Dragon Power <a href=http://zol1.xyz/sertralina-generic.php>Sertralina Generic</a> Prix Du Cialis Avec Ordonnance Amoxicillin While Canine Nursing <a href=http://nolvadex.ccrpdc.com/where-to-buy-nolvadex.php>Where To Buy Nolvadex</a> Cilais Paroxetina Vs Fluoxetina <a href=http://kama1.xyz/buy-generic-kamagra.php>Buy Generic Kamagra</a> Vardenafil Levitra Online Cialis En Direct <a href=http://kama1.xyz/buy-generic-kamagra-online.php>Buy Generic Kamagra Online</a> Cefa Tabs Without Prescription Viagra Pfizer Vente En Ligne <a href=http://cial1.xyz/prices-cialis.php>Prices Cialis</a> Finasteride Propecia Comprar Cialis Por Correo <a href=http://kama1.xyz/cheap-kamagra-uk.php>Cheap Kamagra Uk</a> Cialis 2.5 Mg Dog Cephalexin <a href=http://zol1.xyz/cheap-zoloft-50mg.php>Cheap Zoloft 50mg</a> Amoxicillin For Cat Bites Can You Take Metronidazole With Amoxicillin <a href=http://zol1.xyz/buy-zoloft-on-line.php>Buy Zoloft On Line</a> Cephalexin Grand Rapids Mi Want To Buy Fluoxetine Panic Attacks <a href=http://kama1.xyz/kamagra-gel-oral.php>Kamagra Gel Oral</a> Viagra Kaufen Gunstig Cialis Cancer De La Prostate <a href=http://zol1.xyz/buy-generic-zoloft.php>Buy Generic Zoloft</a> Zentel 400 Mg Pl Triexer <a href=http://viag1.xyz/generic-viagra-online.php>Generic Viagra Online</a> Is Canadian Health Care Mall Site Real? Trazodone 100mg <a href=http://viag1.xyz/viagra-cheap-online.php>Viagra Cheap Online</a> Amoxicillin Abuse Generika Cialis Potenzmittel <a href=http://zol1.xyz/generic-zoloft-cheapest.php>Generic Zoloft Cheapest</a> Cheap Retin A Viagra Pfizer 100 Mg Beipackzettel <a href=http://viag1.xyz/cheap-generic-viagra.php>Cheap Generic Viagra</a> Buy Arimidex No Prescription Cephalexin Dental Infection <a href=http://viag1.xyz/viagra-pill.php>Viagra Pill</a> Buy Levitra?Online Dream Pharmaceutical Zithromax Kills Chlamydia <a href=http://zol1.xyz/generic-zoloft.php>Generic Zoloft</a> Acticin Elimite Drugs On Line Potenzmittel Cialis Alkohol <a href=http://kama1.xyz/price-generic-kamagra.php>Price Generic Kamagra</a> Cialis Il Costo Is Keflex Like Penicellin <a href=http://viag1.xyz/cheap-viagra.php>Cheap Viagra</a> Baclofene Acheter En Ligne Cialis Effet Temps <a href=http://kama1.xyz/order-generic-kamagra.php>Order Generic Kamagra</a> American Online Pharmacy

Note: See TracTickets for help on using tickets.