Ticket #1814 (closed defect: fixed)

Opened 11 years ago

Last modified 22 months ago

Broken mplayer package dependenties

Reported by: lock Owned by: julian_chu
Priority: normal Milestone:
Component: Distro Version:
Severity: normal Keywords: mplayer, libxv, libmp3lame0, broken package
Cc: julian_chu@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I use http://buildhost.openmoko.org/daily-feed repository and tray install mplayer (opkg install mplayer). Mplayer package install properitly, but after executing mplayer command i get:

mplayer: error while loading shared libraries: libXv.so.1: cannot open shared object file: No such file or directory

so, i install ldd tool, and check what else is missing:

root@om-gta02:~# ldd `which mplayer`
        libXv.so.1 => not found
        libXxf86dga.so.1 => /usr/lib/libXxf86dga.so.1 (0x40031000)
        libSDL-1.2.so.0 => /usr/lib/libSDL-1.2.so.0 (0x4003e000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x400bf000)
        libmp3lame.so.0 => not found
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x4017e000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0x401c1000)
        libz.so.1 => /usr/lib/libz.so.1 (0x401e8000)
        libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x40200000)
        libasound.so.2 => /usr/lib/libasound.so.2 (0x40225000)
        libdl.so.2 => /lib/libdl.so.2 (0x402ec000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x402f7000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x40367000)
        libmad.so.0 => /usr/lib/libmad.so.0 (0x40397000)
        libm.so.6 => /lib/libm.so.6 (0x403b4000)
        libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x40462000)
        libc.so.6 => /lib/libc.so.6 (0x40474000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x40593000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x4067d000)
        /lib/ld-linux.so.3 (0x40000000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x40693000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x406b8000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x406c2000)

I fix'ed that installing packages (libxv1 and libmp3lame0) from angstrom-distribution.org. But if mplayer package is in official repository dependent packages must be also and must be installed automaticaly.

Attachments

list_installed (41.0 KB) - added by Mercury 11 years ago.
opkg list_installed
list_installed.2 (41.1 KB) - added by Mercury 11 years ago.
opkg list_installed with mplayer installed, and then libxv1 and libmp3lame0 installed from packages build via MokoMakefile?.

Change History

comment:1 Changed 11 years ago by lock

version of mplayer package: 0.0+1.0rc2-r8

comment:2 Changed 11 years ago by marek

  • Status changed from new to closed
  • Resolution set to wontfix

buildhost.om.org (almost) builds OE upstream - this is VERY unstable. If you want support for that, please contact Graeme.
The current buildhost setup will change soon to avoid future confusion.

comment:3 Changed 11 years ago by Mercury

The buildhost setup has changed, and the unstable feed on downloads.openmoko.org still has this problem.

comment:4 Changed 11 years ago by Mercury

It won't let me reopen the ticket :(

comment:5 Changed 11 years ago by zecke

  • Status changed from closed to reopened
  • Resolution wontfix deleted

@Mercury: I don't see an attached output of opkg list_installed... before I reopen I want log files...

Changed 11 years ago by Mercury

opkg list_installed

comment:6 Changed 11 years ago by zecke

  • Status changed from reopened to closed
  • Resolution set to fixed

you don't even have mplayer installed....

comment:7 Changed 11 years ago by Mercury

No, because it has dependency problems. (I thought that the purpose of this ticket was clear.)

I can work around it the same way the original poster did, but I didn't bother. My goal here is to alert you and/or the community to a problem with the software, but I feel like I'm getting attitude (and apparently now you're playing ticket status yo-yo)

I assume you're an openmoko employee, zecke. May I speak to your supervisor?

Changed 11 years ago by Mercury

opkg list_installed with mplayer installed, and then libxv1 and libmp3lame0 installed from packages build via MokoMakefile?.

comment:8 Changed 11 years ago by zecke

I'm not employed but the ones responsible for me are Julian Chu <julian_chu@…> (distro team lead) and Wolfgang Spraul Wolfgang Spraul <wolfgang@…> (VP of Engineering).

comment:9 Changed 11 years ago by zecke

  • Status changed from closed to reopened
  • Resolution fixed deleted

The initial problem says it installed properly but has a runtime issue. In order to verify that you are really using the proper feed and the _current_ package I will need the package version of the mplayer package so that we have a base to compare to.

So as the initial reporter I assumed you have it installed, but you did not. I had no indication about which version you are talking. You might use the right feed, you might not, I don't know... the installed version of a package is a good indication for that... Without any kind of indication what should I do?

...

comment:10 Changed 11 years ago by zecke

  • Cc julian_chu@… added

Notes:

  • mplayer is not in testing and stable, only in unstable. Julian could you write a script to see which packages are only in a certain feed. E.g. what is in stable not in testing and unstable.
  • And mplayer is not in the task-openmoko-feed so I wonder how it ended up there, it nicely illustrates how we don't remove packages when we remove them from the stuff we build. Maybe we should delete the "do_package" stamps before a build so "unsupported" packages vanish (not saying that mplayer should vanish).
  • The mplayer binary inside this package has a bad RPATH. Julian/John?/XorA could you please check if insane.bbclass was inherited in the unstable build and then check why it didn't detect this RPATH. IIRC likewise fixed that part of my code some time ago.
  • And yes with the above named package mplayer links to libXv and libmp3lame and they are not in the Depends of the control file.

comment:11 Changed 11 years ago by graeme

Im not sure what the hell has happened with that package. But the one that buildhost currently has built has the correct dependencies.

Depends: mplayer-common, libxv1 (>= 1.0.3), libxxf86dga1 (>= 1.0.2), libsdl-1.2-
0 (>= 1.2.11), libc6 (>= 2.6.1), libmp3lame0 (>= 3.96.1), ncurses (>= 5.4), libp
ng12-0 (>= 1.2.20), libz1 (>= 1.2.3), libjpeg62 (>= 6b), libasound2 (>= 1.0.15),

libfreetype6 (>= 2.3.6), libfontconfig1 (>= 2.4.1), libmad0 (>= 0.15.1b), libgc

c1 (>= 4.1.2), libx11-6 (>= 1.1.3), libxext6 (>= 1.0.3)

This should rsync tonight to the unstable feed.

comment:12 Changed 11 years ago by julian_chu

I installed the mplayer from testing-repository last night. Right now it has correct dependency and I can use it to see my .mpg files.

comment:13 Changed 10 years ago by julian_chu

  • Status changed from reopened to closed
  • Resolution set to fixed

comment:14 Changed 22 months ago by Chassmetly

Generico Cialis Italia <a href=http://cial1.xyz/low-price-cialis.php>Low Price Cialis</a> Healthy Male Viagra Prix Suisse En Bourges <a href=http://cial5mg.xyz/tadalafil-tablets.php>Tadalafil Tablets</a> Purchase Macrobid Amex No Prescription Store Provera Website Amex Overseas <a href=http://cial1.xyz/generic-cialis-pricing.php>Generic Cialis Pricing</a> Propecia El Corte Ingles Propecia Dermatologist Approved <a href=http://cial1.xyz/cheapest-cialis.php>Cheapest Cialis</a> But Venlafaxine Xr Canada Lactating Amoxicillin <a href=http://cial1.xyz/viagra-cialis.php>Viagra Cialis</a> Online Pharmacy Effexor Xr Viagra Legale <a href=http://lasix.ccrpdc.com/order-lasix-tablets.php>Order Lasix Tablets</a> Viagra Bringt Nichts Generic Super Viagra Pill <a href=http://cial5mg.xyz/how-to-order-cialis.php>How To Order Cialis</a> Levaquin 500mg Comprar Levitra En Espana <a href=http://zol1.xyz/how-to-order-zoloft.php>How To Order Zoloft</a> Buy Lexapro Online Uk Levitra Se Vende En Farmacias <a href=http://cial1.xyz/cialis-prices.php>Cialis Prices</a> Generic Viagra Vega Sildenafil Citrate Overnight4usa Reviews <a href=http://zol1.xyz/zoloft-online-buy.php>Zoloft Online Buy</a> Fluoxetine Antidepressant In Internet On Line Overseas Sheffield Alternativa A Viagra <a href=http://zol1.xyz/cheap-zoloft-tablets.php>Cheap Zoloft Tablets</a> Costo Finasteride Comprar Propecia Viagra Per Amore <a href=http://viagra.ccrpdc.com/cheap-viagra-online.php>Cheap Viagra Online</a> Vente Viagra Montreal mail order isotretinoin Aurora <a href=http://kama1.xyz/order-kamagra-tablets.php>Order Kamagra Tablets</a> Dapoxetine Generique

Note: See TracTickets for help on using tickets.