Ticket #1821 (closed defect: wontfix)

Opened 9 years ago

Last modified 8 years ago

tee (busybox) gives bad performace: write 1 char a time

Reported by: h.koenig Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

using tee(1) to create some log file and view the output gives horrible performace, because tee writes output one character a time (both to stdout and to file):

to test:

echo foo | strace tee bar

gives

...
open("bar", O_WRONLY|O_CREAT|O_TRUNC|O_LARGEFILE, 0666) = 3
...
read(0, "foo\n", 1024) = 4
write(1, "f", 1f) = 1
write(3, "f", 1) = 1
write(1, "o", 1o) = 1
write(3, "o", 1) = 1
write(1, "o", 1o) = 1
write(3, "o", 1) = 1
write(1, "\n", 1
) = 1
write(3, "\n", 1) = 1
read(0, "", 1024) = 0
io_submit(0, 0, 0xfbad2098 <unfinished ... exit status 0>
Process 2475 detached

Change History

comment:1 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to wontfix

I don't think we will fix busybox, could you please bring this to upstream if that's still the case?

Note: See TracTickets for help on using tickets.