Ticket #1828 (closed defect: wontfix)

Opened 10 years ago

Last modified 10 years ago

Assassin doesn't close packagekitd anymore and so blocks opkg

Reported by: Rorschach Owned by: tick
Priority: normal Milestone: Om2008.8
Component: Installer Version: GTA02v5
Severity: major Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Assassin starts packagekitd but doesn't close it if itself is closed.

This makes other interfaces like the non-gui opkg unable to work. This patch should fix it:

om-assassin-read-only/src$ diff assassin.c assassin.c.old
137d136
< system("killall packagekitd");

I couldn't test it because I couldn't manage to compile assassin on my neo at all..

Change History

comment:1 Changed 10 years ago by tick

  • Status changed from new to closed
  • Resolution set to wontfix

Hi Rorschach,

Thanks for reporting and writing patch for this.

I had thought about this, and decided not kill packagekitd few months ago. So it's a feature.

packagekitd will terminate itself automatically after 5 mins without requests.

GUI users will not know the existence of packagekitd, it's transparent. For power users, I think they will know how to deal with packagekitd. (Use it or kill it) :-P

Cheers,
Tick

Note: See TracTickets for help on using tickets.