Ticket #1837 (closed defect: wontfix)

Opened 9 years ago

Last modified 2 months ago

atd issues

Reported by: h.koenig Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I'm using Om 2008.8 with zeckes -dev updates. playing with atd I noticed

1) atd does not remove scripts after execution

atd is a single shot timer, scripts should not run twice. but atd does not remove them from /var/spool/at/ after execution. thus these scripts will run over and over again once they are timed out, whenever atd gets (re)started or triggered...

looking at the sources in atd-0.70-r4/atd/atd.c there is no remove/unlink to the spool files.

to test:

--- 8< ------ 8< ------ 8< ------ 8< ------ 8< ------ 8< ---
cd /var/spool/at

cat >> 1.1 <<EOF
#!/bin/sh
date >> /tmp/at.run
echo >> /var/spool/at/trigger
EOF

chmod +x 1.1
echo >> /var/spool/at/trigger
--- 8< ------ 8< ------ 8< ------ 8< ------ 8< ------ 8< ---

2) /bin/bash atd scripts crash

using /bin/bash instead of /bin/sh in atd-scripts will crash
the script at startup before executing the first command in shell script,
using /bin/sh my atd scripts works (but I need some arithmetic and
"dc" frombusybox outputs time-in-secs as float -- but that's another topic;)

from strace:
...
uname({sys="Linux", node="om-gta02", ...}) = 0
stat64("/", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat64(".", {st_mode=S_IFDIR|0777, st_size=0, ...}) = 0
stat64(".", {st_mode=S_IFDIR|0777, st_size=0, ...}) = 0
stat64("/", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
stat64("..", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
open("..", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 3
fstat64(3, {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
brk(0xbd000) = 0xbd000
getdents64(3, /* 3 entries */, 4096) = 72
lstat64("../at", {st_mode=S_IFDIR|0777, st_size=0, ...}) = 0
close(3) = 0
stat64("../..", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
open("../..", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 3
fstat64(3, {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
getdents64(3, /* 12 entries */, 4096) = 328
lstat64("../../spool", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
close(3) = 0
stat64("../../..", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
open("../../..", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY) = 3
fstat64(3, {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
fcntl64(3, F_SETFD, FD_CLOEXEC) = 0
brk(0xc1000) = 0xc1000
getdents64(3, /* 19 entries */, 8192) = 488
lstat64("../../../var", {st_mode=S_IFDIR|0755, st_size=0, ...}) = 0
close(3) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---

Change History

comment:1 Changed 9 years ago by zecke

That is by design (not the bash crash). If you want your script to be removed then put an rm into the script at least this is how GPE (atd was created by the founder of GPE) and Qtopia handle this.

comment:2 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to wontfix

comment:3 Changed 2 months ago by Chassmetly

Viagra En Generique <a href=http://zol1.xyz/buy-generic-zoloft.php>Buy Generic Zoloft</a> Internet Pharmacy Medications Cytotec Online Purchase In Singapore <a href=http://cial1.xyz/cialis-generic.php>Cialis Generic</a> Genericos Propecia Comprar Generico Cialis Roma <a href=http://doxycycline.ccrpdc.com/vibramycin-pill.php>Vibramycin Pill</a> Propecia Scalp Bumps Is Amoxicillin Good For Treating Pleurisy <a href=http://cial5mg.xyz/tadalafil-online.php>Tadalafil Online</a> Viagra Keine Ejakulation Rosacea Amoxicillin <a href=http://kama1.xyz/kamagra-cheap-online.php>Kamagra Cheap Online</a> Cialis And Ecuador Pharmacy Order Methotrexate Online <a href=http://zol1.xyz/online-zoloft.php>Online Zoloft</a> Generico De Propecia Comprar Kamagra Sublinguale <a href=http://cial1.xyz/cialis-generic.php>Cialis Generic</a> Priligy 60 Mg Price Viagra. Best Price <a href=http://cial5mg.xyz/tadalafil-online.php>Tadalafil Online</a> Cialis Prescrizione Viagra Kaufen Gegen Rechnung <a href=http://viag1.xyz/order-viagra-online.php>Order Viagra Online</a> Canada Z Pack Best Online Viagra Reviews <a href=http://viag1.xyz/buy-25mg-viagra-online.php>Buy 25mg Viagra Online</a> buy generic accutane online no prescription Lasixpurchase <a href=http://cial1.xyz/cialis-free-trial.php>Cialis Free Trial</a> Pharmacies Shipping To Usa Cialis E Sport <a href=http://clomid.ccrpdc.com/generic-clomiphene.php>Generic Clomiphene</a> On Sale Generic Fedex Macrobid Tablets Medication Where To Order Generic Stendra Worldwide <a href=http://cial5mg.xyz/where-to-order-cialis.php>Where To Order Cialis</a> Vente Kamagra France Dove Comprare Cialis Sicuro <a href=http://viag1.xyz/viagra-online-usa.php>Viagra Online Usa</a> Discount Generic Legally Stendra 50mg Fedex Shipping No Script Needed Prednisone Online Purchase <a href=http://kama1.xyz/buy-kamagra-gel.php>Buy Kamagra Gel</a> Lactamase Resistant Abx Order Accutane Online Australia <a href=http://kama1.xyz/generic-kamagra-pricing.php>Generic Kamagra Pricing</a> Cialis Combien De Temps Avant Levitra Krankenkasse Bezahlt <a href=http://viag1.xyz/map.php>Sildenafil</a> Tretinoin 20 20 Gm From India Compra Levitra Generico <a href=http://propecia.ccrpdc.com/propecia.php>Propecia</a> Viagra Cialis Silagra Propecia Ahnlich <a href=http://cial5mg.xyz/generic-cialis-pricing.php>Generic Cialis Pricing</a> Cheap Kamagra Paypal U S A Real Viagra <a href=http://cial1.xyz/buy-generic-cialis.php>Buy Generic Cialis</a> Tadalafil 20mg India Cialis No Pongas Excusas <a href=http://cial1.xyz/cialis-40mg.php>Cialis 40mg</a> Get Cialis Without Presecription Amoxicillin Substitute <a href=http://cial5mg.xyz/cialis-online-pharmacy.php>Cialis Online Pharmacy</a> Propecia Side Effects After Stendra Over Night <a href=http://propecia.ccrpdc.com/buy-propecia-online-uk.php>Buy Propecia Online Uk</a> Propecia Patente Cialis Super Kamagra <a href=http://zol1.xyz/buying-zoloft-online.php>Buying Zoloft Online</a> How To Order Viagra From Canada Puppy Amoxicillin Bladder Infection <a href=http://viag1.xyz/where-to-order-viagra.php>Where To Order Viagra</a> Levitra Online Purchase Cealis Generic <a href=http://zol1.xyz/zoloft-50mg.php>Zoloft 50mg</a> Buy Apcalis Oral Jelly Ajanta Dapoxetine Chlorhydrate <a href=http://nolvadex.ccrpdc.com/nolvadex-pharmacy.php>Nolvadex Pharmacy</a> Doxycycline Malaria Buy Online Prezzi Finasteride Propecia <a href=http://cialis.ccrpdc.com/cialis.php>Cialis</a> No Perscription Digoxin Periactin Amazon <a href=http://cial1.xyz/cialis.php>Cialis</a> Cialis Free Offer Can You Buy Diflucan At Walmart <a href=http://kama1.xyz/price-of-kamagra.php>Price Of Kamagra</a> Cialis Doux Acheter Cialis Au Canada <a href=http://zol1.xyz/zoloft-online-cs.php>Zoloft Online Cs</a> Cialis Hypertrophie Prostate Vasotec <a href=http://viag1.xyz/cheap-viagra-pills.php>Cheap Viagra Pills</a> Baclofene Gamma Gt Tadalafil Generic Tijuana Mexico <a href=http://cial5mg.xyz/cialis-online-buy.php>Cialis Online Buy</a> Finasteride 10mg Overseas Low Price Silagra Online Kaufen <a href=http://zol1.xyz/zoloft-online-cs.php>Zoloft Online Cs</a> Amoxicillin Cough Seraph And Propecia Pseudoginecomastia <a href=http://cial5mg.xyz/cialis-usa.php>Cialis Usa</a> Cialis 5mg At Canadian

Note: See TracTickets for help on using tickets.