Ticket #1846 (closed defect: wontfix)

Opened 9 years ago

Last modified 9 years ago

hidd missing from "testing" feed

Reported by: Mercury Owned by: openmoko-devel
Priority: normal Milestone:
Component: unknown Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The bluez-utils in this feed http://downloads.openmoko.org/repository/testing/ does not have hidd. Once I upgrade, I can no longer use my bluetooth keyboard.

I tried maually copying an hidd from another package, and it doesn't run unless I run it before hcid. Apparantly hcid is listening on the HID control port stuff, does that mean that something in hcid has taken over the bluetooth keyboard stuff?

Can we get hidd back into the feed, or can someone explain how to get my bluetooth keyboard working without it?

Change History

comment:1 Changed 9 years ago by Mercury

Perhaps this is the new interface?

http://wiki.bluez.org/wiki/Input

comment:2 Changed 9 years ago by ecloud

I had the same problem on Gentoo, and indeed hidd is considered obsolete/deprecated. More info:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=477838
http://wiki.bluez.org/wiki/HOWTO/InputDevices
http://bugs.gentoo.org/178160

comment:3 Changed 9 years ago by Mercury

Thanks :) That helped a lot. Here's how I got it working:

I followed the instructions here to bond the device (otherwise referred to as 'pairing'), http://wiki.bluez.org/wiki/HOWTO/Bonding. And after bonding was complete, while the light was still blinking, I followed the instructions here, http://wiki.bluez.org/wiki/HOWTO/InputDevices to register the keyboard as an input device.

Then I got the error
'input[1555]: Authorization denied: Authorization agent does not exist'
When I tried to use the keyboard (apparantly once it's bonded and registered as a keyboard, the keyboard will attempt to automatically connect to the device it's bonded to whenever you hit a key)

I fixed it with this command:
dbus-send --system --type=method_call --print-reply --dest=org.bluez /org/bluez/hci0 org.bluez.Adapter.SetTrusted? string:AA:BB:CC:DD:EE:FF

And now it works . Mostly :( I have a new problem.

When I press some keys, it works, when I press other keys, it doesn't. I don't think it's related to the new way of bluez keyboard input though, because I grabbed an old copy of hidd and tried that and it had identical behaviour. This is very reminiscent of the problem where some keys would work and others would not when you would try to enter a phone number. Has that problem been identified?

comment:4 Changed 9 years ago by Mercury

Actually, apparently, the problem with some keys appearing and some keys not appearing (for example, 'H' doesn't work, but 'h' does.) only happens on the console. In X, nothing comes up at all!

I've also noticed the on screen keyboard doesn't come up when my bluetooth keyboard is connected. Nice. I like that. But, perhaps this issue is somehow related? I had no problem with bluetooth keyboards before I grabbed the testing tree, but I also still had the on screen keyboard whether or not I had my bluetooth keyboard connected.

comment:5 Changed 9 years ago by Mercury

I run evtest on the bluetooth keyboard input event interface and I can see every key, even the ones that don't show up when I type on the console @.@ I have no idea what would be causing this problem.. I thought if the event input interface worked, then I should be able to type, at least on the console..

comment:6 Changed 9 years ago by zecke

@Mercury: I have no idea what kind of keymap we have on the device. What keys are not showing up on the console? Then install things like console-utils and dump the kernel keymap and then take a look if these keys are mapped...

comment:7 Changed 9 years ago by Mercury

I'm working on getting the 'kbd' package compiled for my phone (or find some other way to get keymap information).

In the meantime, I don't know if this helps or not, but before I upgraded from om2008.8 to the 'testing' feed, I was able to use this same bluetooth keyboard both in X and on the console.

Would anything related to the keymap have changed since then?

comment:8 Changed 9 years ago by Mercury

See ticket #1796 My problem is fixed. X wasn't picking up the keyboard because of the command line parameters.

My problem with the console remains. Even though every key works in X, if I go to the console I only see some keys and not others. Even so, I think it may be better for me to submit that as a new ticket following the new ticket submission guidelines.

I suggest, to someone with the ability, that you please close this ticket as WONTFIX (because there's no need to include hidd in the distribution if you're using a newer bluez, because there's a new interface that's available and I can verify that it works with my keyboard.)

comment:9 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.