Ticket #1864 (assigned defect)

Opened 6 years ago

Last modified 6 years ago

Keyboard needs to have a non-predictive mode

Reported by: iknowjoseph Owned by: will
Priority: normal Milestone:
Component: unknown Version: Om2008.8
Severity: normal Keywords: 2008.8, keyboard, predictive, pm
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

Having installed the 2008.8 release dated 26/08/2008 & illume-config I have found the keyboard to be useless for a wide range of input forms simply because it does not feature the option to be used without predictive input.

I cannot, for example, add a map repository to TangoGPS because "www" is not in the predictive dictionary. Presumably the rest of the URL is also not in the predictive dictionary.

The keyboard needs to the option of working without a predictive mode.

Change History

comment:1 Changed 6 years ago by Yorick

I 100% agree with you; furthermore the the full querty keyboard should also be easely installed.
It would even make sence making the full qwerty the default one and the current one optional, because right now the phone is not yet used by "the massas" why might not be interested in typing in the terminal.

in the mean time:
you can press and hold a letter
then stroke from left to right with your finger/stylus
this is a very annoying way to type text (requiring several seconds/character) but it might help you out at the moment

comment:2 Changed 6 years ago by Yorick

you can also edit your file ~/.gconf/apps/tangogps/%gconf.xml when ssh'd in

you can use my file: http://pastebin.com/f1aae45d2
note: on line 4 and 7 you have to edit two stringvalues (if you want to use the friends-feature in tangoGPS)

comment:3 Changed 6 years ago by zecke

  • Milestone Om2008.8 deleted

Clearing milestone (internal field)

comment:4 Changed 6 years ago by zecke

When pressing and holding a zoom widget comes up and you can select a character and write words not in the dictionary. I would label this "non-predictive mode" for thumb keyboards.

comment:5 follow-up: ↓ 7 Changed 6 years ago by iknowjoseph

This is true, and I have successfully used this mode to enter data. However, the extra time it takes to enter characters in this non-predictive mode penalises the user for not using the OM default. I can, for example, put my SonyEricsson? keyboard into non-predictive mode, and enter characters without holding the key down for longer than I need to when in predictive mode.

"Holding down" a displayed key on a touch screen is also very unintuitive.

IMHO this defect is still valid.

comment:6 follow-up: ↓ 8 Changed 6 years ago by zecke

  • Status changed from new to closed
  • Resolution set to duplicate

As it is possible to enter words (even if it needs knowledge how to do that and is not easily discoverable) that are not in the dictionary I think the initial issue does not exist.

Further existing keyboard issues:

#1764 - Request to be able to switch keyboards (e.g. full stylus qwertz)
#1752 - special mode for entering passwords
#1795 - for missing and wanted keys

As I do not see that this bug adds anything not already covered I close it as duplicate.

comment:7 in reply to: ↑ 5 Changed 6 years ago by zecke

Replying to iknowjoseph:

This is true, and I have successfully used this mode to enter data. However, the extra time it takes to enter characters in this non-predictive mode penalises the user for not using the OM default. I can, for example, put my SonyEricsson? keyboard into non-predictive mode, and enter characters without holding the key down for longer than I need to when in predictive mode.

Screenshot of the virtual on screen keyboard would be welcome. I wonder how they make the keys big enough that one can easily hit them with the average finger size in western cultures.

comment:8 in reply to: ↑ 6 Changed 6 years ago by iknowjoseph

Replying to zecke:

As it is possible to enter words (even if it needs knowledge how to do that and is not easily discoverable) that are not in the dictionary I think the initial issue does not exist.

Further existing keyboard issues:

#1764 - Request to be able to switch keyboards (e.g. full stylus qwertz)
#1752 - special mode for entering passwords
#1795 - for missing and wanted keys

As I do not see that this bug adds anything not already covered I close it as duplicate.

Non of those bugs ask for what I have requested: The OM2008.8 keyboard, as it is at the moment, but with the added option of selecting a non-predictive mode that doesn't overly inconvenience the user. Yes, there are currently ways of using the keyboard in a non-predictive way, but it could be improved; it doesn't matter whether you prefer to call it an enhancement or a defect, it's certainly not a duplicate.

comment:9 follow-ups: ↓ 10 ↓ 11 Changed 6 years ago by zecke

I think the current keyboard without prediction and zooming will not be usable with a finger. How would you solve that? Make the keyboard widget bigger so one differentiate between the characters (this would mean having a distance between the keys in pixel that is bigger than the average finger size)?

I believe that just turning off the prediction will not help anyone. The only thing I can think of is to make the distance between the keys bigger than the finger size. This would also mean to break the board layout as not all keys fit in one line. So how exactly is that solved by your current phone?

Feel free to reopen the bug.

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 12 Changed 6 years ago by iknowjoseph

Replying to zecke:

I believe that just turning off the prediction will not help anyone.

On this point then we disagree. I have no problem with the spacing of the keys on the keyboard, but if I hit "w" three times I end up with "was". If I could turn off the predictive input I could have "www" as planned; the keyboard is otherwise quite usable and very attractive.

My current SonyEricsson? uses a regular physical keypad with a predictive- and non-predictive text mode. Selecting the non-predictive mode allows me to insert characters without holding the button down for an extended period of time.

I am reluctant to reopen the bug if it's simply going to become another "works for me" issue.

comment:11 in reply to: ↑ 9 ; follow-up: ↓ 13 Changed 6 years ago by Yorick

Replying to zecke:

I think the current keyboard without prediction and zooming will not be usable with a finger. How would you solve that? Make the keyboard widget bigger so one differentiate between the characters (this would mean having a distance between the keys in pixel that is bigger than the average finger size)?

I believe that just turning off the prediction will not help anyone. The only thing I can think of is to make the distance between the keys bigger than the finger size. This would also mean to break the board layout as not all keys fit in one line. So how exactly is that solved by your current phone?

Feel free to reopen the bug.

Are you sure it would not be usable Zecke? I used raster's Full Qwerty keyboard, with my fingers and it works great! The keys are much closer together on that keboard than on the predictive one...

comment:12 in reply to: ↑ 10 Changed 6 years ago by zecke

Replying to iknowjoseph:

I am reluctant to reopen the bug if it's simply going to become another "works for me" issue.

Well, we will have to find that out.

comment:13 in reply to: ↑ 11 ; follow-up: ↓ 14 Changed 6 years ago by zecke

Replying to Yorick:

Replying to zecke:

Are you sure it would not be usable Zecke? I used raster's Full Qwerty keyboard, with my fingers and it works great! The keys are much closer together on that keboard than on the predictive one...

No, I'm not. I'm just confident that we will get a new wave of reports if we turn off the prediction. So the question is what is the issue and why is someone asking to turn off prediction.

My answers to that are:

a) He is entering IP addresses, passwords and such. In that case turning off prediction can make a lot sense. This would need solving in two ways. Be able to set proper hints on the input (password, ip, no prediction) and then the inputmethod can honor that. But that is a lot more than just turning off prediction in the keyboard.

b) The prediction is not good enough. This is the case for non us languages (as there are no wordbooks) and even the US dictionary does not contain important words. The source of our dictionary is gutenberg (IIRC) so stuff like www, yahoo, msn, or 4u (for you) and other SMS shortcuts do not show up. In that case it is a matter of providing dictionaries for other languages or that contain the word. E.g. you can install the wordbook app and "train" www and your issue should be solved.

c) What do I forget? To ask why do we need to have a non-predictive mode?

I'm still in the process of trying to understand why you want to disable predictive mode and that disabling it is the best thing we can do.

comment:14 in reply to: ↑ 13 ; follow-ups: ↓ 15 ↓ 17 Changed 6 years ago by Yorick

Replying to zecke:

Replying to Yorick:

Replying to zecke:

Are you sure it would not be usable Zecke? I used raster's Full Qwerty keyboard, with my fingers and it works great! The keys are much closer together on that keboard than on the predictive one...

No, I'm not. I'm just confident that we will get a new wave of reports if we turn off the prediction. So the question is what is the issue and why is someone asking to turn off prediction.

My answers to that are:

a) He is entering IP addresses, passwords and such. In that case turning off prediction can make a lot sense. This would need solving in two ways. Be able to set proper hints on the input (password, ip, no prediction) and then the inputmethod can honor that. But that is a lot more than just turning off prediction in the keyboard.

b) The prediction is not good enough. This is the case for non us languages (as there are no wordbooks) and even the US dictionary does not contain important words. The source of our dictionary is gutenberg (IIRC) so stuff like www, yahoo, msn, or 4u (for you) and other SMS shortcuts do not show up. In that case it is a matter of providing dictionaries for other languages or that contain the word. E.g. you can install the wordbook app and "train" www and your issue should be solved.

c) What do I forget? To ask why do we need to have a non-predictive mode?

I'm still in the process of trying to understand why you want to disable predictive mode and that disabling it is the best thing we can do.

I understand what you are trying to say, but:

a) The question is not about turning prediction off, but _providing_ a way to turn it off and on. Because I don't think it will be possible to use those "hints on the input", because even under normal circumstances (like in an SMS) where English-speaking people would like the predictive input you will sometimes type names of people/places

b)in rasters keyboard one can already add his own wordbook
One of the *current* big flaws also is that there is no button to add a word to the dictionary, so at this stage the predictive keyboard is not really user-friendly.

We're not asking that you throw away predictive mode, but that we can disable it and enable it whenever we want (just like on every other phone I have ever used...). Especially since there is not yet a way to change dictionaries (on this keyboard, on the one from raster there is) and no way to let it learn new words.

comment:15 in reply to: ↑ 14 ; follow-up: ↓ 16 Changed 6 years ago by zecke

Replying to Yorick:

I understand what you are trying to say, but:

a) The question is not about turning prediction off, but _providing_ a way to turn it off and on. Because I don't think it will be possible to use those "hints on the input", because even under normal circumstances (like in an SMS) where English-speaking people would like the predictive input you will sometimes type names of people/places

Now the question is if you don't only switch mode based on the input hint but on user choice. How would that happen? With the current plan you would go to exposure and switch the keyboard to a none predictive one. Would that help you? Effectively we would just have a non predictive version of the predictive keyboard and you could pick that. I would not know where to configure the predictive keyboard to dynamically enable/disable prediction..

Depending on how often "sometimes" is the route through exposure might be okay, it might not. Comments?

b)in rasters keyboard one can already add his own wordbook
One of the *current* big flaws also is that there is no button to add a word to the dictionary, so at this stage the predictive keyboard is not really user-friendly.

You can install qtopia-phone-x11-words and add your words to the dictionary.

comment:16 in reply to: ↑ 15 ; follow-up: ↓ 19 Changed 6 years ago by Yorick

Replying to zecke:

Now the question is if you don't only switch mode based on the input hint but on user choice. How would that happen? With the current plan you would go to exposure and switch the keyboard to a none predictive one. Would that help you? Effectively we would just have a non predictive version of the predictive keyboard and you could pick that. I would not know where to configure the predictive keyboard to dynamically enable/disable prediction..

Depending on how often "sometimes" is the route through exposure might be okay, it might not. Comments?

On every phone I know it is possible to turn it of during use. There should be a button to enable or disable it withouth having to go to exposure. If this is not feasable in the short run, even having to set it in exposure will make it A LOT more useful (most people will turn it of the first time they boot and keep it of I think...).

You can install qtopia-phone-x11-words and add your words to the dictionary.

I didn't know this, thank you!

But I keep asking myself: what do you find wrong with Rasters keyboard? It has every functionality the standard 2008.8 has AND MORE.
Only problem is that the full-qwerty sometimes gets beaten by the standard one and we need to reboot, but even then we are not worse of then with the standard keyboard.

Do you use the FreeRunner? as your daily phone zecke? Have you tried playing in the terminal? Surely you must have felt the same frustration as everyone else in that case. Because I quite frankly can't remember anyone EVER saying he found this keyboard useful and practical. I have however heard tens of people complain and even say that this is the reason they delete 2008.8...
The keyboard has its uses, but it's not enough (in the state it is).

comment:17 in reply to: ↑ 14 ; follow-up: ↓ 18 Changed 6 years ago by iknowjoseph

Replying to Yorick:

a) The question is not about turning prediction off, but _providing_ a way to turn it off and on. Because I don't think it will be possible to use those "hints on the input", because even under normal circumstances (like in an SMS) where English-speaking people would like the predictive input you will sometimes type names of people/places

This is exactly what I want. Apologies if it wasn't clear before, but I want the standard 2008.8 keyboard, in predictive mode, but with a button to toggle that mode on and off. On my SonyEricsson? I can hold down the * key and it gives me the same keyboard, but with the predictive mode toggled off.

To be honest, this would be the simplest the keyboard could be whilst still operating in a useful manner. A more advanced (although I can't imagine difficult) solution would be to automatically turn off the predictive keyboard when entering a web address, password, config setting, etc.

comment:18 in reply to: ↑ 17 Changed 6 years ago by zecke

  • Keywords predictive, pm added; predictive removed

Replying to iknowjoseph:

Replying to Yorick:

a) The question is not about turning prediction off, but _providing_ a way to turn it off and on. Because I don't think it will be possible to use those "hints on the input", because even under normal circumstances (like in an SMS) where English-speaking people would like the predictive input you will sometimes type names of people/places

This is exactly what I want. Apologies if it wasn't clear before, but I want the standard 2008.8 keyboard, in predictive mode, but with a button to toggle that mode on and off. On my SonyEricsson? I can hold down the * key and it gives me the same keyboard, but with the predictive mode toggled off.

To be honest, this would be the simplest the keyboard could be whilst still operating in a useful manner. A more advanced (although I can't imagine difficult) solution would be to automatically turn off the predictive keyboard when entering a web address, password, config setting, etc.

Well, we are extremely limited on hardware keys (we only have two) and also limited on screen real estate. In the Opie/Qtopia? world we have a way to switch between keyboards since 2000, the X11 world does not offer anything like that and it takes time to even get basics like keyboard switching done... Anyway I can provide keyboards and #1764 needs addressing to select them.

comment:19 in reply to: ↑ 16 Changed 6 years ago by zecke

Replying to Yorick:

On every phone I know it is possible to turn it of during use. There should be a button to enable or disable it withouth having to go to exposure.

Sure, mentioned that to PM in June. But on your phone you probably use "*" to switch between modes. What you ask is to have "modes" and "keyboards". I think we should only go for keyboards. Which brings the technical question how to switch keyboards fast if one is provided by a Gtk+, the other by a EFL and a third one with a Qt process. Everything is easy if you go to an island and control everything, allow keyboards to be written with any language and keyboard requires a lot more effort to get basics done.

If this is not feasable in the short run, even having to set it in exposure will make it A LOT more useful (most people will turn it of the first time they boot and keep it of I think...).

Okay, #1764 here...

But I keep asking myself: what do you find wrong with Rasters keyboard?

Nothing. When we decided to go to for the Qtopia keyboard raster's keyboard didn't have good prediction, it leaked memory, it had no zoom, no selection of different keymaps....One was unable to use it without a stylus leave alone a ride in a car. So I was asked to port the Qtopia keyboard and roughly spend six hours on it, raster has spend at least three weeks working on his keyboard. And using the Qtopia keyboard allowed him, or made him, to rewrite his keyboard to be better.

It has every functionality the standard 2008.8 has AND MORE.

It was not back then.

Only problem is that the full-qwerty sometimes gets beaten by the standard one and we need to reboot, but even then we are not worse of then with the standard keyboard.

I don't follow.

Do you use the FreeRunner? as your daily phone zecke?

I'm one of the fews that do. It is my primary phone and I take it with me on my travels and rely on it to make "emergency" calls when I'm totally lost.

Have you tried playing in the terminal?

I don't use a terminal. My primary use case is to write SMS and that is possible. The frustration of zooming and waiting for it to select is nothing compared to not being able to write SMS in public transportation or the jittering of raster's current zoom widget (experience from raster's keyboard).

comment:20 Changed 6 years ago by zecke

Small hint: You can put "export QTOPIA_NO_VIRTUAL_KEYBOARD=1" into /etc/X11/Xsession.d/89Qtopia and qpe will not instantiate a virtual keyboard and illume's keybord should be shown.

See:
http://git.openmoko.org/?p=qtopia.git;a=commit;h=b3d1d38877b5b433c81e18c34484856ce7bd0955

comment:21 follow-ups: ↓ 22 ↓ 24 Changed 6 years ago by zecke

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Summary (from my point of view):

  • One wants to be able to switch keyboard implementations fast (qwertz, pickboard, chinese)
  • One wants to be able to change "modes" fast (prediction on and off)

Discussion:

  • Fast probably means one to two clicks. Either use a hardware key or have it easily accessible in the decoration.
  • Does mode vs. keyboard make sense? For the prediction case it might not. In Opie we had multikeys which could load any layout and then a per keyboard config made sense. Personally I would go for "keyboards" and have per keyboard configs with the assumption that keyboard switching is fast and config is only used once in a while.

A lot of this is probably duplicate to the "how to switch keyboard discussion"

comment:22 in reply to: ↑ 21 Changed 6 years ago by iknowjoseph

Replying to zecke:

Summary (from my point of view):

  • One wants to be able to switch keyboard implementations fast (qwertz, pickboard, chinese)
  • One wants to be able to change "modes" fast (prediction on and off)

Discussion:

  • Fast probably means one to two clicks. Either use a hardware key or have it easily accessible in the decoration.
  • Does mode vs. keyboard make sense? For the prediction case it might not. In Opie we had multikeys which could load any layout and then a per keyboard config made sense. Personally I would go for "keyboards" and have per keyboard configs with the assumption that keyboard switching is fast and config is only used once in a while.

A lot of this is probably duplicate to the "how to switch keyboard discussion"

This all sounds good.

I like flicking the keyboard up to change the mode it's in. How about flicking it up to a non-predictive mode? Perhaps differentiated from the predictive keyboard by colouring the keys differently?

Thanks for re-opening the ticket; I tried to do the same myself but lacked the permissions to do so.

comment:23 Changed 6 years ago by Yorick

That seems to sum it up nicely zecke.

For predictive input it might also be nice to be able to add the word to the wordbook from within the keyboard. For example: when typing a word on the default kb by "pressing and holding" the letters, a button could appear to add the resulting word to the wordbook.

I have *personally* a preference for mode over keyboard changing (e.g. a button to turn predictive on an off) this will maybe make it more easy to add the words to the dictionary while typing.

Thank you once more for your time and effort.

comment:24 in reply to: ↑ 21 Changed 6 years ago by ymahe

Replying to zecke:

Summary (from my point of view):

  • One wants to be able to switch keyboard implementations fast (qwertz, pickboard, chinese)
  • One wants to be able to change "modes" fast (prediction on and off)

Maybe some parameters to add to the keyboard configuration:

  • One wants to be able to switch keyboard auto-activation (if he wants the keyboard, he has to touch the icon)
  • One wants to be able to switch keyboard place on the screen (popup over the current application or re-dimension the window of the current application)
  • One wants to easily add new dictionnaries and switch between them

comment:25 Changed 6 years ago by john_lee

  • Owner changed from openmoko-devel to will
  • Status changed from reopened to assigned
  • HasPatchForReview unset

I'm reassigning this to will, our product design manager. I believe currently the design is to keep using qtopia type predictive keyboard even in our future release. so, this ticket could be used as a reference for him.

Note: See TracTickets for help on using tickets.