Ticket #1867 (closed defect: wontfix)

Opened 8 years ago

Last modified 8 years ago

Dhclient is not working

Reported by: Zoup Owned by: openmoko-kernel
Priority: normal Milestone:
Component: kernel Version: Om2008.8
Severity: normal Keywords: dhclient dhcp-client
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Dhclient Declines are Offers

Listening on LPF/eth0/00:12:cf:8e:fd:9d
Sending on LPF/eth0/00:12:cf:8e:fd:9d
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 6
DHCPOFFER from 192.168.0.110
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.110
DHCPDECLINE on eth0 to 255.255.255.255 port 67
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPOFFER from 192.168.0.110
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.110
...

Change History

comment:1 Changed 8 years ago by maxious

A possible workaround is to use udhcpc which is part of busybox.

comment:2 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to wontfix

hmm before we get Network manager or connman right please use udhcpc instead. it works for me.

Note: See TracTickets for help on using tickets.