Ticket #1879 (closed defect: community)

Opened 9 years ago

Last modified 8 years ago

[unstable] attempting to bond crashes hcid

Reported by: Mercury Owned by: Nytowl
Priority: normal Milestone:
Component: Distro Version:
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible: always

Description

When I attempt to bond (or even start up passkey-agent) according to the instructions on the bluez site http://wiki.bluez.org/wiki/HOWTO/Bonding, hcid crashes and must be killed with -9

My log buffer is flooded with the following endlessly:


Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!
Aug 27 17:16:03 lisa daemon.err hcid[2127]: register_passkey_agent called without any adapter info!


I'm using the unstable opkg feed from downloads.openmoko.org

Change History

comment:1 Changed 9 years ago by zecke

Aeh? My logic scanner failed on crashing AND you need to kill it. If it crashed you don't need to kill it...

Please provide the output of opkg list_installed as of the http://wiki.openmoko.org/wiki/Bug_Filing_Policy and then provide instructions on how to reproduce and what you actually do...

Provide enough information to be able to help you...

comment:2 Changed 9 years ago by Mercury

Your logic scanner has a more rigid definition of crashing than mine. It's locks up competely.

I also posted a link to a tutorial which has instructions on how to bond with a device. I could enumerate the steps in greater detail if that link isn't sufficient? This should work (Just change over to the unstable feed, run opkg upgrade, and run this.) :

1) make sure hcid is running
2) Run passkey-agent 0000 aa:bb:cc:dd:ee:ff (or any other mac)
3) logread -f <-- flood o' text.

Also I apologize for not sending 'opkg list_installed' At the time I filed this ticket I don't believe that policy was in place. However, perhaps instead of requiring a list of package versions and such it may be better to just instruct people to upgrade to the most recent versions on the feed instead. Since that may actually eliminate bugs before they're reported, and it's a lot easier to type (As I did in the ticket description) 'I'm using the unstable opkg feed from downloads.openmoko.org'

Unfortunately, I have since downgrated my bluez-utils and the problem is gone now, and I don't plan on upgrading again, so if I generated 'opkg list_installed' right now it won't be as useful for you.

comment:3 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to wontfix

hmm, closed for now. if it's still there please kindly reopen.

comment:4 Changed 9 years ago by mwester

  • Status changed from closed to reopened
  • Resolution wontfix deleted

Confirming this problem still exists; seems to be an upstream issue that has also been noted by the Debian community:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=501222

The workaround suggested (use --default instead of a specific bt address) works, although admittedly it is a less-than-perfect solution.

comment:5 Changed 8 years ago by roh

  • Owner changed from julian_chu to Nytowl

maintainer change

comment:6 Changed 8 years ago by Nytowl

  • Status changed from reopened to closed
  • Resolution set to community

This is a bluez 3.x problem

We are moving forward with Bluez 4

Note: See TracTickets for help on using tickets.