Ticket #1892 (closed defect: worksforme)

Opened 10 years ago

Last modified 10 years ago

Locations doesn't start

Reported by: flamma Owned by: jeremy
Priority: normal Milestone:
Component: Locations Version: Om2008.9-dev
Severity: normal Keywords:
Cc: Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible: always

Description

Since 2008.8 update, Locations crash before starting. If called from a console, previously setting the display, I get the following message:

root@om-gta02:~# om-locations
Error connecting to bus: dbus-launch failed to autolaunch D-Bus session: Autolaunch requested, but X11 support not compiled in.
Cannot continue.

Segmentation fault
root@om-gta02:~#

This happens with GPS on and with GPS off.

Change History

comment:1 Changed 10 years ago by marek

  • Status changed from new to accepted

It seems you also need to set the environment variable for the session dbus path. You can retrieve it from cat /proc/<enlightenment_id>/environ
Please check whether it solves your problem.

comment:2 Changed 10 years ago by flamma

That worked!

Not only it allowed me to run from the console, but now I can execute it from the desktop entry, even if I restart the hone. I can't understand why setting an environment variable once in one session, can make the application work forever (hopefully!), unless locations need to be started once to configure something that solves it.

Anyway, it works. You're quick. Thanks a lot.

comment:3 Changed 10 years ago by marek

  • Version changed from Om2008.8 to Om2008.9-dev
  • Severity changed from critical to normal

The dbus path is random and will change everytime the session is restarted. It wont survive a reboot. Also, the shell variable has nothing to do with a desktop entry. The desktop entry is started by enlightenment which already has that variable. Your desktop entry also did not work ?

comment:4 Changed 10 years ago by flamma

It didn't work. So, I tried with console and got that error. I thought that was the origin of the problem. Once solved, I have rebooted and Locations seems to start from desktop, but now that I looked at it, it seems to have the same behaviour as before.

comment:5 Changed 10 years ago by marek

  • Owner changed from marek to jeremy
  • Status changed from accepted to assigned

Ok, I reassign to jeremy because he knows that application better than me.

comment:6 Changed 10 years ago by jeremy

Hi, flamma:

It never happens for me. You said after you set the environment variable, you can execute it from desktop icon forever. But right now it happens again? Hmm..., I don't think locations need to be started once to configure something that solves it. Could you please tell me how you did the 2008.8 update? and what's the versions of om-locations, diversity-daemon, and EFL(including Evas, Edje, Ecore, Eet, Etk)? Thanks.

comment:7 Changed 10 years ago by flamma

I'm very sorry, Jeremy. I can't say you the versions since I flashed the phone again with the 8/30 image. The only thing I can say, is that I had flashed normally my phone with the first Om2008.8 update. And that, after executing Locations first time, it worked right. I don't know if it is a coincidence.

Yesterday I was playing with Locations and seemed to work fine. If I find a problem again, I will post here.

comment:8 Changed 10 years ago by jeremy

  • Status changed from assigned to closed
  • Resolution set to worksforme

I think that may be system weird, out of memory or something at that moment. Instead, it's not an issue related to Locations. Just needs a reboot to make it normal.

Note: See TracTickets for help on using tickets.